CORRECTIF : sessions impression hôte peuvent cesser de répondre (se bloquer) lorsque l'option de requête déterminée réponse est activée dans Host Integration Server

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Numéro d'article: 886666 - Voir les produits auxquels s'applique cet article
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Sommaire

Symptômes

Dans Microsoft Host Integration Server ordinateur hôte Imprimer les sessions qui ont l'option requête déterminée réponse activée peuvent cesser de répondre (se bloquer). Lorsque ce problème se produit, vous ne pouvez pas envoyer tout nouveau ordinateur hôte travaux à la session impression ordinateur hôte d'impression.

Cause

Ce problème se produit car le serveur d'impression n'envoie pas de réponse du système ordinateur hôte lorsqu'un travail d'impression est terminé si l'heure entre les travaux d'impression est plus que le délai est configuré dans l'option Après traitement extrémités, retard fermeture d'imprimante dans la session d'impression. Étant donné que le système ordinateur hôte attend une réponse indique que le travail précédent a terminé l'impression, autres travaux d'impression Impossible d'envoyer à la session d'impression. Ce comportement provoque la session d'impression cesse de répondre.

Résolution

Hôte Integration Server 2000

Informations sur le service pack

Pour résoudre ce problème, procurez-vous le dernier service pack Microsoft Host Integration Server 2000. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
328152 Comment obtenir le dernier pack service de Host Integration Server 2000

Informations sur le correctif

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en coordinated universal temps (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'outil Date et heure du Panneau de configuration.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   29-Sep-2004  16:34  5.0.0.1002   20,752  Msg5250.dll
   29-Sep-2004  16:34  5.0.0.1002  250,128  Ppd3270.dll
   29-Sep-2004  16:34  5.0.0.1002  139,536  Ppd5250.dll
   29-Sep-2004  16:34  5.0.0.1002   49,424  Prmngext.dll
   29-Sep-2004  16:34  5.0.0.1002  209,168  Snacfg.dll
   29-Sep-2004  16:34  5.0.0.1002   24,848  Snaxlt.dll
   29-Sep-2004  16:34  5.0.0.1002  282,896  Winvprt.dll
   29-Sep-2004  16:34  5.0.0.1002   57,616  Pdfcomp.exe
   29-Sep-2004  16:34  5.0.0.1002   94,480  Snaprint.exe

				
note En raison des dépendances de fichiers, le correctif plus récent contenant ces fichiers peut également contenir des fichiers.

Hôte Integration Server 2004

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en coordinated universal temps (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'outil Date et heure du Panneau de configuration.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   29-Sep-2004  17:33  6.0.1905.0   29,184  Msg5250.dll
   29-Sep-2004  17:33  6.0.1905.0   39,424  Pdfcomp.exe
   29-Sep-2004  17:33  6.0.1905.0  183,808  Ppd3270.dll
   29-Sep-2004  17:33  6.0.1905.0   93,184  Ppd5250.dll
   29-Sep-2004  17:33  6.0.1905.0   33,280  Prmngext.dll
   29-Sep-2004  17:33  6.0.1905.0  167,936  Snacfg.dll
   29-Sep-2004  17:33  6.0.1905.0   61,440  Snaprint.exe
   29-Sep-2004  17:33  6.0.1905.0   12,288  Snaxlt.dll
   29-Sep-2004  17:33  6.0.1905.0  194,560  Winvprt.dll
				

note En raison des dépendances de fichiers, le correctif plus récent contenant ces fichiers peut également contenir des fichiers.

Contournement

Pour contourner ce problème, désactivez l'une des options de configuration suivantes dans les propriétés d'impression session ou les deux :
  • demande réponse déterminée
  • une fois le projet terminaisons, délai de fermeture d'imprimante

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ». Ce problème a été corrigé dans Microsoft Host Integration Server 2000 Service Pack 2.

Plus d'informations

Dans SNA Server 4.0 et versions antérieures, le service d'impression ordinateur hôte (Snaprint.exe) s'ouvre définis toutes les imprimantes qui sont utilisés par les sessions impression ordinateur hôte configuré lorsque le service démarre. L'option Après traitement terminaisons, retard fermeture d'imprimante a été ajoutée dans Host Integration Server 2000 pour optimiser les performances et de ressources système. Si l'imprimante est toujours disponible, les ressources système comme imprimante poignées sont consommés. Toutefois, si l'imprimante est constamment ouvert et fermé avec chaque travail d'impression qui est envoyé, performances souffre. En définissant l'option de délai d'attente Après traitement extrémités, retard fermeture d'imprimante , l'imprimante restera disponible pour les travaux d'impression qui est envoyés proches à améliorer les performances et l'imprimante se fermera pendant temps spécifié non occupé pour libérer des ressources.

Par défaut, l'option Après traitement extrémités, retard fermeture d'imprimante est activée et le délai est défini à 10 secondes sur Host Integration Server 2000 et Host Integration Server 2004.

Le problème décrit dans la section « Symptômes » se produit lorsque les options de requête déterminée réponse et Après traitement extrémités, retard fermeture d'imprimante sont les deux activées sur une session impression ordinateur hôte. Si plusieurs tâches d'impression ordinateur hôte sont envoyées à la session impression ordinateur hôte et le délai entre chaque travail d'impression est inférieure au délai spécifié dans l'option Délai d'attente Après traitement terminaisons, retard fermeture d'imprimante , tous les travaux d'impression sont imprimées. En outre, le service d'impression ordinateur hôte envoie une réponse au système ordinateur hôte pour indiquer que chaque travail imprimé correctement. L'option de requête déterminée réponse fournit cette fonctionnalité.

Si plusieurs tâches impression ordinateur hôte sont envoyées à la session impression ordinateur hôte et le délai entre un ou plusieurs des travaux d'impression est plus de l'option de délai d'attente Après traitement extrémités, retard fermeture d'imprimante , tous les travaux d'impression sont correctement imprimées. Toutefois, le service d'impression ordinateur hôte ne pas envoyer de réponse dans le système ordinateur hôte pour le travail impression qui vous a été envoyé après que le délai d'attente After Job Ends, Delay Closing Printer expiration. Ce comportement provoque la session d'impression cesse de répondre car le système ordinateur hôte ne pas envoyer les travaux d'impression supplémentaires à la session d'impression pendant qu'il attend la réponse pour le travail impression précédente.

Propriétés

Numéro d'article: 886666 - Dernière mise à jour: mardi 4 décembre 2007 - Version: 2.6
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Host Integration Server 2000 Standard Edition
  • Microsoft Host Integration Server 2000 Service Pack 1
  • Microsoft Host Integration Server 2004 Standard Edition
Mots-clés : 
kbmt kbautohotfix kbhotfixserver kbqfe kbhostintegserv2000presp2fix kbfix kbbug KB886666 KbMtfr
Traduction automatique
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