CORRECÇÃO: Sessões de impressão do anfitrião poderão deixar de responder (não reagir) quando a opção de pedido de resposta definitiva está activada no Host Integration Server

Traduções de Artigos Traduções de Artigos
Artigo: 886666 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

No Microsoft Host Integration Server, anfitrião impressão sessões que têm a opção de Pedido de resposta definitiva activada poderão deixar de responder (não reagir). Depois de ocorrer este problema, não é possível enviar tarefas de impressão para a sessão de impressão do anfitrião para qualquer novo anfitrião.

Causa

Este problema ocorre porque o servidor de impressão não envia uma resposta para o sistema anfitrião quando uma tarefa de impressão é concluída se o tempo entre tarefas de impressão for mais do que o tempo limite configurado na opção Depois de extremidades de tarefa, atraso fecho impressora na sessão de impressão. Porque o sistema anfitrião está a aguardar uma resposta que indica que a tarefa anterior foi concluída a impressão, tarefas de impressão adicionais não poderão ser enviadas para a sessão de impressão. Este comportamento faz com que a sessão de impressão para deixar de responder.

Resolução

Host Integration Server 2000

Informações sobre Service Packs

Para resolver este problema, obtenha o service pack mais recente do Microsoft Host Integration Server 2000. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
328152Como obter o service pack mais recente do Host Integration Server 2000

Informações sobre a correcção

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas no formato de universal hora (UTC) coordenada Coordinated. Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   29-Sep-2004  16:34  5.0.0.1002   20,752  Msg5250.dll
   29-Sep-2004  16:34  5.0.0.1002  250,128  Ppd3270.dll
   29-Sep-2004  16:34  5.0.0.1002  139,536  Ppd5250.dll
   29-Sep-2004  16:34  5.0.0.1002   49,424  Prmngext.dll
   29-Sep-2004  16:34  5.0.0.1002  209,168  Snacfg.dll
   29-Sep-2004  16:34  5.0.0.1002   24,848  Snaxlt.dll
   29-Sep-2004  16:34  5.0.0.1002  282,896  Winvprt.dll
   29-Sep-2004  16:34  5.0.0.1002   57,616  Pdfcomp.exe
   29-Sep-2004  16:34  5.0.0.1002   94,480  Snaprint.exe

				
Nota Devido a dependências de ficheiros, a correcção mais recente que contenha estes ficheiros também poderão conter ficheiros adicionais.

Host Integration Server 2004

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas no formato de universal hora (UTC) coordenada Coordinated. Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   29-Sep-2004  17:33  6.0.1905.0   29,184  Msg5250.dll
   29-Sep-2004  17:33  6.0.1905.0   39,424  Pdfcomp.exe
   29-Sep-2004  17:33  6.0.1905.0  183,808  Ppd3270.dll
   29-Sep-2004  17:33  6.0.1905.0   93,184  Ppd5250.dll
   29-Sep-2004  17:33  6.0.1905.0   33,280  Prmngext.dll
   29-Sep-2004  17:33  6.0.1905.0  167,936  Snacfg.dll
   29-Sep-2004  17:33  6.0.1905.0   61,440  Snaprint.exe
   29-Sep-2004  17:33  6.0.1905.0   12,288  Snaxlt.dll
   29-Sep-2004  17:33  6.0.1905.0  194,560  Winvprt.dll
				

Nota Devido a dependências de ficheiros, a correcção mais recente que contenha estes ficheiros também poderão conter ficheiros adicionais.

Como contornar

Para contornar este problema, desactive uma ou ambas as seguintes opções de configuração nas propriedades da sessão de impressão:
  • Pedir resposta definitiva
  • Depois de extremidades de tarefa, atraso fechar impressora

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".Este problema foi corrigido no Microsoft Host Integration Server 2000 Service Pack 2.

Mais Informação

No SNA Server 4.0 e versões anteriores, o serviço de impressão do anfitrião (Snaprint.exe) abre definidas todas as impressoras que são utilizadas pelas sessões de impressão de anfitrião configuradas quando o serviço é iniciado. A opção Depois de tarefa termina, atraso fecho impressora foi adicionada no Host Integration Server 2000 para optimizar o desempenho e recursos do sistema. Se a impressora sempre estiver disponível, os recursos do sistema, tais como identificadores de impressora são consumidos. No entanto, se a impressora constantemente é aberta e fechada com cada tarefa de impressão é enviada, desempenho será afectado. Definindo a opção de tempo de espera depois da tarefa termina, o atraso de fecho impressora , a impressora permanecerá disponível para tarefas de impressão que são enviadas juntos para melhorar o desempenho e a impressora será fechada durante não-disponibilidade para libertar recursos.

Por predefinição, a opção Depois de extremidades de tarefa, atraso fecho impressora está activada e o tempo limite é definido para 10 segundos no Host Integration Server 2000 e o Host Integration Server 2004.

O problema descrito na secção "Sintomas" ocorre quando as opções de Pedido de resposta definitiva e depois da tarefa termina, o atraso de fecho impressora estão ambos activadas numa sessão de impressão do anfitrião. Se vários trabalhos de impressão de anfitrião são enviados para o anfitrião imprime sessão e o atraso entre cada tarefa de impressão é menor que o tempo limite especificado na opção de tempo de espera depois da tarefa termina, o atraso de fecho impressora , todas as tarefas de impressão são impressos. Além disso, o serviço de impressão do anfitrião envia uma resposta para o sistema anfitrião para indicar que cada tarefa impresso com êxito. A opção de Pedido de resposta definitiva fornece esta funcionalidade.

Se vários trabalhos de impressão anfitrião são enviados para a sessão de impressão do anfitrião e o atraso entre um ou mais os trabalhos de impressão for mais do que a opção de tempo de espera Após a tarefa termina, atraso fechar impressora , todas as tarefas de impressão são impressas com êxito. No entanto, o serviço de impressão do anfitrião não envia uma resposta para o sistema anfitrião para a tarefa de impressão foi enviada após o tempo limite Depois de extremidades de tarefa, atraso fecho impressora expirado. Este comportamento faz com que a sessão de impressão para deixar de responder porque o sistema anfitrião não enviará quaisquer tarefas de impressão adicionais para a sessão de impressão enquanto está a aguardar a resposta à tarefa de impressão anterior.

Propriedades

Artigo: 886666 - Última revisão: 4 de dezembro de 2007 - Revisão: 2.6
A informação contida neste artigo aplica-se a:
  • Microsoft Host Integration Server 2000 Standard Edition
  • Microsoft Host Integration Server 2000 Service Pack 1
  • Microsoft Host Integration Server 2004 Standard Edition
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbhostintegserv2000presp2fix kbfix kbbug KB886666 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 886666

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com