CORRECÇÃO: Sessões de impressão do host podem parar de responder (travar) quando a opção de solicitação de resposta definitiva está ativada no Host Integration Server

Traduções deste artigo Traduções deste artigo
ID do artigo: 886666 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

No Microsoft Host Integration Server, host Imprimir sessões que têm a opção de Solicitação de resposta definitiva habilitada podem parar de responder (travar). Após esse problema, você não pode enviar qualquer novo host trabalhos de impressão para a sessão de impressão do host.

Causa

Esse problema ocorre porque o servidor de impressão não envia uma resposta para o sistema host quando um trabalho de impressão é concluído se o tempo que esteja entre trabalhos de impressão for maior do que o tempo limite configurado na opção após o trabalho termina, o atraso fechar impressora da sessão de impressão. Porque o sistema host está esperando uma resposta que indica que o trabalho anterior foi concluída a impressão, trabalhos de impressão adicionais não podem ser enviados para a sessão de impressão. Esse comportamento faz com que a sessão de impressão para parar de responder.

Resolução

Host Integration Server 2000

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Microsoft Host Integration Server 2000. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
328152Como obter o service pack mais recente para o Host Integration Server 2000

Informações sobre o hotfix

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   29-Sep-2004  16:34  5.0.0.1002   20,752  Msg5250.dll
   29-Sep-2004  16:34  5.0.0.1002  250,128  Ppd3270.dll
   29-Sep-2004  16:34  5.0.0.1002  139,536  Ppd5250.dll
   29-Sep-2004  16:34  5.0.0.1002   49,424  Prmngext.dll
   29-Sep-2004  16:34  5.0.0.1002  209,168  Snacfg.dll
   29-Sep-2004  16:34  5.0.0.1002   24,848  Snaxlt.dll
   29-Sep-2004  16:34  5.0.0.1002  282,896  Winvprt.dll
   29-Sep-2004  16:34  5.0.0.1002   57,616  Pdfcomp.exe
   29-Sep-2004  16:34  5.0.0.1002   94,480  Snaprint.exe

				
Observação Devido às dependências do arquivo, a correção mais recente que contém esses arquivos também pode conter arquivos adicionais.

Host Integration Server 2004

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version     Size     File name
   -----------------------------------------------------
   29-Sep-2004  17:33  6.0.1905.0   29,184  Msg5250.dll
   29-Sep-2004  17:33  6.0.1905.0   39,424  Pdfcomp.exe
   29-Sep-2004  17:33  6.0.1905.0  183,808  Ppd3270.dll
   29-Sep-2004  17:33  6.0.1905.0   93,184  Ppd5250.dll
   29-Sep-2004  17:33  6.0.1905.0   33,280  Prmngext.dll
   29-Sep-2004  17:33  6.0.1905.0  167,936  Snacfg.dll
   29-Sep-2004  17:33  6.0.1905.0   61,440  Snaprint.exe
   29-Sep-2004  17:33  6.0.1905.0   12,288  Snaxlt.dll
   29-Sep-2004  17:33  6.0.1905.0  194,560  Winvprt.dll
				

Observação Devido às dependências do arquivo, a correção mais recente que contém esses arquivos também pode conter arquivos adicionais.

Como Contornar

Para contornar este problema, desative uma das seguintes opções de configuração nas propriedades da sessão de impressão ou ambas:
  • Solicitar resposta definitiva
  • depois de extremidades de trabalho, fechar impressora de atraso

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".Esse problema foi corrigido no Microsoft Host Integration Server 2000 Service Pack 2.

Mais Informações

SNA Server 4.0 e versões anteriores, o serviço de impressão do host (Snaprint.exe) abre definidas todas as impressoras que são usadas pelas sessões de impressão do host configurado quando o serviço é iniciado. A opção Após extremidades de trabalho, atraso fechar impressora foi adicionada no Host Integration Server 2000 para otimizar o desempenho e recursos do sistema. Se a impressora está sempre disponível, serão consumidos de recursos de sistema, como identificadores de impressora. No entanto, se a impressora constantemente é aberta e fechada com cada trabalho de impressão é enviado, desempenho sofre. Definindo a opção de tempo limite após o trabalho termina, o atraso fechar impressora , a impressora permanecerá disponível para trabalhos de impressão que são enviados próximos para melhorar o desempenho e a impressora será fechado durante os períodos não ocupado para liberar recursos.

Por padrão, a opção após o trabalho termina, o atraso fechar impressora está ativada e o tempo limite é definido como 10 segundos no Host Integration Server 2004 e Host Integration Server 2000.

O problema descrito na seção "Sintomas" ocorre quando as opções de Solicitação de resposta definitiva e após o trabalho termina, o atraso fechar impressora estão ativadas em uma sessão de impressão do host. Se vários trabalhos de impressão do host são enviados para o host Imprimir sessão e o atraso entre cada trabalho de impressão é menor do que o tempo limite é especificado na opção de tempo limite após o trabalho termina, o atraso fechar impressora , todos os trabalhos de impressão são impressos. Além disso, o serviço de impressão do host envia uma resposta para o sistema host para indicar que cada trabalho é impresso com êxito. A opção de Solicitação de resposta definitiva fornece essa funcionalidade.

Se vários trabalhos de impressão do host são enviados para a sessão de impressão do host e o atraso entre uma ou mais trabalhos de impressão é mais do que a opção de tempo limite Após extremidades de trabalho, atraso fechar impressora , todos os trabalhos de impressão serão impressas com êxito. No entanto, o serviço de impressão do host não envia uma resposta para o sistema host para o trabalho de impressão que foi enviado após expirado o tempo limite após o trabalho termina, o atraso fechar impressora . Esse comportamento faz com que a sessão de impressão para parar de responder porque o sistema host não irá enviar os trabalhos de impressão adicionais à sessão de impressão enquanto ele está aguardando a resposta para o trabalho de impressão anterior.

Propriedades

ID do artigo: 886666 - Última revisão: terça-feira, 4 de dezembro de 2007 - Revisão: 2.6
A informação contida neste artigo aplica-se a:
  • Microsoft Host Integration Server 2000 Standard Edition
  • Microsoft Host Integration Server 2000 Service Pack 1
  • Microsoft Host Integration Server 2004 Standard Edition
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbhostintegserv2000presp2fix kbfix kbbug KB886666 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 886666

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com