Article ID: 886685 - Last Review: June 27, 2007 - Revision: 3.2

Sending request files (.srq) are not processed and site routing packages are deleted before the routing request file is processed in Systems Management Server

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SYMPTOMS

The Microsoft Systems Management Server (SMS) Scheduler component cannot process the routing request (.rtr) because the corresponding send request ID is already being used. The following entry appears in the SMS\Logs\Sched.log file:
WARNING: Found duplicate Send Request ID already exists in sites current list - ID: x_xxxxxx
Abandoning processing of the routing request xxxxxxxx.RTR.  It will be retried on the next routing request processing cycle
When SMS later tries to process the .rtr file again, the missing routing package file (.rpg) causes all the send requests that are created by the .rtr file to fail. Errors that are similar to the following errors appear in the SMS\Logs\Sender.log file for each send request:
~Package file = D:\SMS\inboxes\schedule.box\tosend\xxxxxxxx.RPG
~Instruction file = D:\SMS\inboxes\schedule.box\tosend\xxxxxxxx.I1v
Could not get size of local file D:\SMS\inboxes\schedule.box\tosend\xxxxxxxx.RPG. Win32 error 1   
  Error: File does not exist.
Verification reports invalid send requests.
The orphaned send requests may cause the SMS Scheduler component not to process new fan-out routing requests.

CAUSE

This problem occurs because the SMS Scheduler component deletes .rpg files that are older than 25 hours. This problem can occur on child primary sites where fan-out routing of site-to-site traffic occurs.

RESOLUTION

SMS 2003 service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
885643  (http://support.microsoft.com/kb/885643/ ) How To obtain the latest Systems Management Server 2003 service pack

SMS 2.0 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have SMS 2.0 Service Pack 5 installed to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   ------------------------------------------------------------
   20-Feb-2004  09:03  2.0.6.7           355,242  Smsupdate.exe
   25-Feb-2003  15:05  2.0.1493.5197   1,633,696  Basesvr.dll
   06-Aug-2000  00:51  2000.80.194.0     274,489  Ntwdblib.dll
   23-Feb-2003  01:05  2.0.1493.5011     855,312  Preinst.exe
Important You must apply this hotfix to all primary site servers in your SMS hierarchy. When you install this hotfix, the invalid send requests are automatically removed. When the processing of a routing request file (.RTR) is postponed by the SMS Scheduler component, the File Modified time stamp on the routing package file (.rpg) is updated to the current date and time. The updated time stamp prevents the SMS Scheduler component from deleting the .rpg file before the .rtr file is processed.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Systems Management Server 2003 Service Pack 2.

MORE INFORMATION

This hotfix is included in SMS 2003 Service Pack 2 (SP2). If you experience this symptom on a site that is running SMS 2003 with SP2, see the following Microsoft Knowledge Base article for an updated hotfix:
927723  (http://support.microsoft.com/kb/927723/ ) Error message in the Sched.log file in SMS 2003 with Service Pack 2: "WARNING: Found duplicate Send Request ID already exists"

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Systems Management Server 2003
  • Microsoft Systems Management Server 2.0 Service Pack 5
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbsmssender kbsmspackage kbsmsdistribution kbscheduler kberrmsg kbperformance kbsoftwaredist kbfix KB886685
 

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