Article ID: 887175 - Last Review: July 24, 2007 - Revision: 1.13

A local copy of the file that is specified in the ftp: get command is deleted on your Windows Server 2003-based computer

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SYMPTOMS

Consider the following scenario:
  • You use the ftp command on a Microsoft Windows Server 2003-based computer to obtain files from a remote computer.
  • You use the get subcommand with the ftp command to download a specific file.
  • A file with the same name as the file that is specified in the ftp: get command already exists on your computer.
  • The file that is specified in the ftp: get command does not exist on the remote computer.
When this scenario occurs, the local copy of the file that is specified in the ftp: get command is deleted from your computer. This problem occurs even though the file cannot be downloaded from the remote computer.

CAUSE

This problem occurs because the Windows File Transfer Protocol (FTP) utility deletes the local copy of the file that is specified in the get command first, and then tries to download the remote file. The local file is deleted even if the file specified in the get command does not exist on the remote computer, or if the file cannot be downloaded for some other reason.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
64-bit editions of Windows Server 2003
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   18-Dec-2004  00:40  5.2.3790.242      107,008  Ftp.exe          IA-64
   18-Dec-2004  00:51  5.2.3790.242       45,056  Wftp.exe         x86
32-bit editions of Windows Server 2003
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   18-Dec-2004  00:51  5.2.3790.242       45,056  Ftp.exe  

WORKAROUND

To work around this problem, use the mget command instead of the get command to obtain the file from the remote computer. For more information about the mget command, visit the following Web site:
http://technet.microsoft.com/en-us/library/bb490664.aspx (http://technet.microsoft.com/en-us/library/bb490664.aspx)

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbwinserv2003presp1fix KB887175