Una solicitud puede devolver un puntero nulo a la interfaz IFontDisp cuando un programa que utiliza la versión de Windows XP SP2 del acceso de solicitudes de archivo ATL.dll a la propiedad de fuente de ambiente

Seleccione idioma Seleccione idioma
Id. de artículo: 887569 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Puede experimentar el problema siguiente cuando un programa utiliza la versión de Microsoft Windows XP Service Pack 2 (SP2) del archivo ATL.dll para controles ActiveX de host. Cuando un programa que utiliza esta versión del acceso de solicitudes de archivo ATL.dll a la propiedad de fuente de ambiente que está en un contenedor de host de ATL (Active Template Library), la solicitud puede devolver un puntero nulo a la interfaz IFontDisp.

Cuando se devuelve el puntero nulo, puede producirse una infracción de acceso porque la mayoría de los controles de ActiveX no reconocen un puntero nulo. El programa puede dejar de responder. O bien, los controles ActiveX no funcionen correctamente.

Causa

Este problema se produce debido a una regresión en la versión del archivo ATL.dll que se incluye con Windows XP SP2.

El control realiza una llamada al método IAxWinAmbientDispatch::get_Font . Esta llamada, a continuación, hace que el ATL! ATL::CAxHostWindow::get_Font que se llame al método. La llamada a la ATL! ATL::CAxHostWindow::get_Font método devuelve un resultado HRESULT de S_OK. Sin embargo, se devuelve un puntero nulo a la interfaz IFontDisp. Programas normalmente se suponen que se devuelve un puntero válido si la interfaz devuelve un resultado HRESULT de S_OK. Sin embargo, el control no reconoce el puntero nulo que se devuelve a la interfaz IFontDisp. Por lo tanto, experimenta los problemas que se describen en la sección "Síntomas".

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Date         Time   Version            Size    File name
---------------------------------------------------------
11-Jan-2005  23:25  3.5.2284.1         58,880  Atl.dll

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 887569 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 2.2
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
Palabras clave: 
kbmt kbautohotfix kbqfe kbhotfixserver kbwinxpsp3fix kbfix kbbug KB887569 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 887569

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com