Windows Server 2003 기반 컴퓨터에서 스마트 카드를 사용할 때 "로그온 실패" 메시지가 나타난다

기술 자료 번역 기술 자료 번역
기술 자료: 887578 - 이 문서가 적용되는 제품 보기.

중요한 이 문서에서는 레지스트리 수정 방법에 대한 정보가 들어 있습니다. 수정하기 전에 레지스트리를 백업하는 것이 있는지 확인하십시오. 문제가 발생하는 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 백업, 복원 및 레지스트리 수정 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
256986Microsoft Windows 레지스트리에 대한 설명
모두 확대 | 모두 축소

이 페이지에서

현상

Microsoft Windows Server 2003 도메인 컨트롤러에 로그온할 수 있는 스마트 카드를 사용하려고 하면 로그온할 수 없는 및 다음과 같은 메시지가 나타날 수 있습니다.
로그온 실패

원인

이 문제가 발생할 때 인증서 해지 목록 (CRL) 오래되었습니다 및 새 CRL을 사용할 수 없습니다. 공개 키 인프라 (PKI) 것입니다 작동하지 않는 새 CRL을 게시하면 CRL 배포 서버에 발생할 수 있습니다. 새 CRL이 게시된 경우 클라이언트 컴퓨터에 로그온을 사용할 수 없습니다.

해결 방법

서비스 팩 정보

이 문제를 해결하려면 Windows Server 2003용 최신 서비스 팩을 구하십시오. 추가 정보는 다음 문서 번호를 클릭하여 Microsoft 기술 자료에서 확인하십시오:
889100Windows Server 2003용 최신 서비스 팩을 구하는 방법

핫픽스 정보

Microsoft에서 제공하는 핫픽스를 사용할 수 있습니다. 그러나 이 핫픽스는 이 문서에서 설명된 문제만 해결할 수 있습니다. 이 문서에 설명된 특정 문제가 발생한 시스템에만 이 핫픽스를 적용하십시오. 추후에 이 핫픽스를 테스트할 수 있습니다. 따라서 이 문제로 심각하게 영향을 받은 경우를 제외하곤 이 핫픽스가 포함된 다음 소프트웨어 업데이트까지 기다리는 것이 좋습니다.

다운로드할 핫픽스가 있는 경우, 이 기술 자료 문서의 맨 위에 "사용 가능한 핫픽스 다운로드" 링크가 있습니다. 이 링크가 표시되지 않는 경우, Microsoft 고객 지원 서비스에 문의하여 핫픽스를 구할 수 있습니다.

참고 추가적인 문제가 발생할 경우 또는 모든 문제 해결에 필요한 경우 별도의 서비스 요청을 만들어야 할 수도 있습니다. 핫픽스에 적용되지 않는 추가 지원 질문과 문제에는 일반 지원 비용이 적용됩니다. Microsoft 고객 서비스 지원 전화 번호 전체 목록 또는 별도의 서비스 요청을 만들려면 다음 Microsoft 웹 사이트로 이동하십시오:
http://support.microsoft.com/contactus/?ws=support
참고 "핫픽스 다운로드 가능" 형식에는 핫픽스를 사용할 수 있는 언어가 표시됩니다. 사용자 언어가 표시되지 않으면 해당 언어의 핫픽스를 사용할 수 없습니다 때문입니다.

전제 조건

전제 필요합니다.

재시작 요구 사항

이 핫픽스를 적용한 후에는 컴퓨터를 다시 시작해야 합니다.

핫픽스 대체 정보

이 핫픽스는 다른 핫픽스를 대체하지 않습니다.

파일 정보

이 핫픽스의 영어 버전은 다음 표에 나열된 파일 특성(또는 그 이후의 파일 특성)이 있습니다. 이러한 파일의 시간과 날짜는 UTC (협정 세계시) 로 나열됩니다. 파일 정보에서는 현지 시간으로 변환됩니다. UTC와 로컬 시간의 차이를 알려면 제어판의 날짜 및 시간 항목에서 표준 시간대 탭을 사용하십시오.
Windows Server 2003
IA-64 기반 버전
표 축소표 확대
파일 이름파일 버전파일 크기날짜시간플랫폼SP 요구 사항서비스 분기
Crypt32.dll5.131.3790.4251,578,4962005년 10월 1405: 21IA-64없음RTMQFE
Cryptnet.dll5.131.3790.425160,2562005년 10월 1405: 21IA-64없음RTMQFE
Kdcsvc.dll5.2.3790.425590,3362005년 10월 1405: 21IA-64없음RTMQFE
Kerberos.dll5.2.3790.425907,2642005년 10월 1405: 21IA-64없음RTMQFE
Wcrypt32.dll5.131.3790.425612,8642005년 10월 1405: 21x 86없음우와
Wcryptnet.dll5.131.3790.42561,9522005년 10월 1405: 21x 86없음우와
Wkerberos.dll5.2.3790.425344,0642005년 10월 1405: 21x 86없음우와
Crypt32.dll5.131.3790.25481,759,2322005년 10월 1405: 21IA-64sp1sp1qfe
Cryptnet.dll5.131.3790.2548172,5442005년 10월 1405: 21IA-64sp1sp1qfe
Kdcsvc.dll5.2.3790.2548613,8882005년 10월 1405: 21IA-64sp1sp1qfe
Kerberos.dll5.2.3790.2548963,0722005년 10월 1405: 21IA-64sp1sp1qfe
Wcrypt32.dll5.131.3790.2548595,9682005년 10월 1405: 21x 86sp1우와
Wcryptnet.dll5.131.3790.254862,4642005년 10월 1405: 21x 86sp1우와
Wkerberos.dll5.2.3790.2548350,7202005년 10월 1405: 21x 86sp1우와
x 64 기반 버전
표 축소표 확대
파일 이름파일 버전파일 크기날짜시간플랫폼SP 요구 사항서비스 분기
Crypt32.dll5.131.3790.25481,428,9922005년 10월 1405: 21x 64sp1sp1qfe
Cryptnet.dll5.131.3790.2548111,1042005년 10월 1405: 21x 64sp1sp1qfe
Kdcsvc.dll5.2.3790.2548419,8402005년 10월 1405: 21x 64sp1sp1qfe
Kerberos.dll5.2.3790.2548720,8962005년 10월 1405: 21x 64sp1sp1qfe
Wcrypt32.dll5.131.3790.2548595,9682005년 10월 1405: 21x 86sp1우와
Wcryptnet.dll5.131.3790.254862,4642005년 10월 1405: 21x 86sp1우와
Wkerberos.dll5.2.3790.2548350,7202005년 10월 1405: 21x 86sp1우와
x 86 기반 버전
표 축소표 확대
파일 이름파일 버전파일 크기날짜시간플랫폼SP 요구 사항서비스 분기
Crypt32.dll5.131.3790.425612,8642005년 10월 1404: 10x 86없음RTMQFE
Cryptnet.dll5.131.3790.42561,9522005년 10월 1404: 10x 86없음RTMQFE
Kdcsvc.dll5.2.3790.425227,8402005년 10월 1404: 10x 86없음

핫픽스를 설치한 후

중요한 이 섹션에서는, 메서드 또는 작업이 레지스트리 수정 방법을 알려 주는 단계가 포함되어 있습니다. 그러나 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 따라서 다음 이 단계를 주의 깊게 따라야 합니다. 추가 보호 기능을 수정하기 전에 레지스트리를 백업해야. 그런 다음 문제가 발생할 경우 레지스트리를 복원할 수 있습니다. 백업 및 복원하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
322756백업 및 Windows 에서 레지스트리를 복원하는 방법

인증 기관 (CA)이 이 핫픽스를 설치한 후 새 CRL을 게시하는 데 사용할 수 없는 경우 레지스트리 키를 CRL 유효 기간을 확장할 수 있습니다. 이렇게 하려면 다음과 같이 하십시오.

도메인 컨트롤러에서

  1. 레지스트리 편집기를 시작하십시오.
  2. 다음 레지스트리 하위 키를 찾습니다.
    HKEY_Local_Machine\System\CurrentControlSet\Services\KDC
  3. 편집 메뉴에서 새로 만들기를 누르고 다음 레지스트리 항목을 추가하십시오.

    값 이름: CRLValidityExtensionPeriod
    형식 값: DWORD
    값 데이터: 시간 (십진수)
    설명: 이 DWORD 값을 지정한 시간 수 기준으로 CRL 유효 기간을 확장할 수 있습니다. 이 값을 0이 아닌 값으로 설정할 경우 스마트 카드 로그온에 대한 코드 검사 인증서 상태를 수보다 더 의해 CRL이 만료되었습니다 한 시간 오류가 지정된 유효 기간이 무시합니다. 스마트 카드 로그온에 사용된 인증서 평가 중에 사용되는 CRL이 이 확장을 유효 기간이 적용됩니다. 예를 들어, 이 확장을 NTAuth 저장소에 채워져 있는 CA가 발급한 인증서 및 NTAuth 저장소에 인증서를 확인하는 데 사용되는 신뢰 체인에 포함된 인증서를 적용할 수 있습니다.
  4. 다음 레지스트리 하위 키를 찾습니다.
    HKEY_Local_Machine\System\CurrentControlSet\Services\KDC
  5. 편집 메뉴에서 새로 만들기를 누르고 다음 레지스트리 항목을 추가하십시오.

    값 이름: CRLTimeoutPeriod
    형식 값: DWORD
    값 데이터: (10진수) 초
    설명: 이 DWORD 값의 가양성을 줄이고 CRL 제한 시간을 지정할 수 있습니다. 키 배포 센터 (KDC) 코드 검사 인증서 정책이 이 값을 전달합니다. 기본적으로 이 레지스트리 값이 설정되지 않은 경우에도 KDC 90초 시간 제한 값을 지정합니다.

클라이언트 컴퓨터에서

Windows XP
  1. 레지스트리 편집기를 시작하십시오.
  2. 다음 레지스트리 하위 키를 찾습니다.
    HKEY_Local_Machine\System\CurrentControlSet\Control\LSA\Kerberos
  3. 편집 메뉴에서 새로 만들기를 누르고 다음 레지스트리 항목을 추가하십시오.

    값 이름: CRLTimeoutPeriod
    형식 값: DWORD
    값 데이터: (10진수) 초
    설명: 이 DWORD 값의 가양성을 줄이고 CRL 제한 시간을 지정할 수 있습니다. Kerberos 클라이언트가 코드 검사 인증서 정책이 이 값을 전달합니다. 기본적으로 이 레지스트리 값이 설정되지 않은 경우에도 Kerberos 클라이언트가 시간 제한 값을 90 초 단위로 지정합니다.
  4. 다음 레지스트리 하위 키를 찾습니다.
    HKEY_Local_Machine\System\CurrentControlSet\Control\LSA\Kerberos
  5. 편집 메뉴에서 새로 만들기를 누르고 다음 레지스트리 항목을 추가하십시오.

    값 이름: UseCachedCRLOnlyAndIgnoreRevocationUnknownErrors
    형식 값: DWORD
    데이터 값: 1
    설명: 이 DWORD 값을 1로 설정하면 후에 Kerberos 클라이언트가 (스마트 카드 로그온 클라이언트에서) 의해 만료된 CRL을 발생시킨 "알 수 없는 해지" 오류를 무시합니다.
Windows Server 2003, Windows Vista 및 Windows Server 2008
  1. 레지스트리 편집기를 시작하십시오.
  2. 다음 레지스트리 하위 키를 찾습니다.
    HKEY_Local_Machine\System\CurrentControlSet\Control\LSA\Kerberos\Parameters
  3. 편집 메뉴에서 새로 만들기를 누르고 다음 레지스트리 항목을 추가하십시오.

    값 이름: CRLTimeoutPeriod
    형식 값: DWORD
    값 데이터: (10진수) 초
    설명: 이 DWORD 값의 가양성을 줄이고 CRL 제한 시간을 지정할 수 있습니다. Kerberos 클라이언트가 코드 검사 인증서 정책이 이 값을 전달합니다. 기본적으로 이 레지스트리 값이 설정되지 않은 경우에도 Kerberos 클라이언트가 시간 제한 값을 90 초 단위로 지정합니다.
  4. 다음 레지스트리 하위 키를 찾습니다.
    HKEY_Local_Machine\System\CurrentControlSet\Control\LSA\Kerberos\Parameters
  5. 편집 메뉴에서 새로 만들기를 누르고 다음 레지스트리 항목을 추가하십시오.

    값 이름: UseCachedCRLOnlyAndIgnoreRevocationUnknownErrors
    형식 값: DWORD
    데이터 값: 1
    설명: 이 DWORD 값을 1로 설정하면 후에 Kerberos 클라이언트가 (스마트 카드 로그온 클라이언트에서) 의해 만료된 CRL을 발생시킨 "알 수 없는 해지" 오류를 무시합니다.

해결 과정

이 문제를 해결하려면 스마트 카드를 로그온할 때 필요한 정책을 해제하십시오. 이 정책을 사용하지 않도록 설정하려면 다음 이 단계를 수행하십시오.
  1. 시작 을 누르고, 실행 을, gpedit.msc 를 입력한 다음 확인 을 누릅니다.
  2. 로컬 컴퓨터 정책 에서 컴퓨터 구성, Windows 설정 을 확장하고 확장한 다음 보안 설정 을 확장하십시오.
  3. 로컬 정책 을 확장한 다음 보안 옵션 을 클릭하십시오.
  4. 오른쪽 창에서 두 번 대화형 로그온: 스마트 카드 필요.
  5. 사용 안 함 을 클릭한 다음 확인 을 클릭하십시오.

현재 상태

Microsoft는 "본 문서의 정보는 다음의 제품에 적용됩니다." 절에 나열된 Microsoft 제품에서 이 문제를 확인했습니다. 이 문제는 Windows Server 2003 서비스 팩 2에서 처음 수정되었습니다.

추가 정보

PKI 및 CRL에 대한 자세한 내용은 해당 "검사 목록: Windows에 로그온하기 위한 스마트 카드 배포" 도움말 항목에서 다음 Microsoft 웹 사이트를:
http://technet2.microsoft.com/WindowsServer/en/library/2e0186ba-1a09-42b5-81c8-3ecca4ddde5e1033.mspx?mfr=true
추가 정보는 다음 문서 번호를 클릭하여 Microsoft 기술 자료에서 확인하십시오:
824684Microsoft 소프트웨어 업데이트를 설명하는 데 사용되는 표준 용어에 대한 설명

속성

기술 자료: 887578 - 마지막 검토: 2008년 12월 4일 목요일 - 수정: 7.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
키워드:?
kbmt kbautohotfix kbwinserv2003sp2fix kbqfe kbhotfixserver kbbug kbcertservices kbppkey kbsmartcard kbwinserv2003presp1fix kbfix kbprb KB887578 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com