Alguns hotfixes anteriores ao Service Pack 1 (SP1) não migram para a versão SP1 ao atualizar seu computador para Windows XP SP1

Traduções deste artigo Traduções deste artigo
ID do artigo: 887822
Expandir tudo | Recolher tudo

Sintomas

Ao atualizar seu computador com Microsoft Windows XP para Windows XP Service Pack 1 (SP1), alguns hotfixes anteriores ao SP1 instalados no seu computador podem não migrar com êxito da versão de lançamento do Windows XP para Windows XP SP1.

Observações
  • Ao instalar um hotfix do Windows XP anterior ao SP1 em um computador com Windows XP, uma versão SP1 desse hotfix também é copiada no computador para ser usado quando você atualizar o computador para Windows XP SP1. Ao atualizar o computador para Windows XP SP1, a versão SP1 do hotfix é automaticamente instalada.

    Para obter informações adicionais sobre esse processo automático, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
    328848 Descrição de pacotes de atualização de modo duplo para o Windows XP
  • Para verificar se um hotfix migrou para o nível Windows XP SP1, revise o arquivo Xpsp1hfm.log na sua pasta Windows.
  • Esse problema não ocorre ao atualizar para Windows XP Service Pack 2 (SP2) nos seguintes casos:
    • Você atualizou a partir da versão de lançamento do Windows XP sem hotfixes instalados.
    • Você atualizou a partir do Windows XP SP1 com os hotfixes anteriores ao Windows XP SP2 instalados.
  • Após atualizar seu computador para Windows XP SP1, alguns hotfixes anteriores ao SP1 não podem ser instalados. A seguinte mensagem de erro pode ser exibida:
    A Instalação encontrou um erro: Arquivos do pacote são incompatíveis com os arquivos no seu sistema.
    Essa mensagem de erro está listada no arquivo de log para a atualização, como KBxxxxxx.log. O programa Windows Installer também retorna um código de erro estendido 0xf0f1.

Causa

Esse problema é causado pelo arquivo Branches.inf. O arquivo Branches.inf ajuda o programa Windows Installer a identificar qual versão de um hotfix específico instalar.

Esse problema ocorre se os seguintes hotfixes estiverem instalados:
841356 MS04-037: Vulnerabilidade no shell do Windows pode permitir a execução de código remoto
840987 MS04-032: Atualização de segurança para o Microsoft Windows
824151 MS04-030: Vulnerabilidade no manipulador de mensagens WebDAV XML pode ocasionar ataque DoS (denial of service)

Resolução

Para resolver esse problema, ao atualizar seu computador com Windows XP, use um dos seguintes métodos:
  • Atualize seu computador com Windows XP para Windows XP SP2.

    Para obter informações adicionais sobre como obter o service pack mais recente para o Windows XP, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
    322389 Como obter o service pack mais recente do Windows XP
  • Instale a atualização crítica para Windows XP (KB887822). Para fazer isso, visite um dos seguintes sites da Microsoft:

Situação

A Microsoft confirmou que esse é um problema nos produtos da empresa que estão listados na seção "Aplica-se a".

Mais Informações

Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft:
824684 Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft

Propriedades

ID do artigo: 887822 - Última revisão: quinta-feira, 3 de fevereiro de 2011 - Revisão: 2.1
Palavras-chave: 
kbqfe kbHotfixServer kbwinxppresp3fix kbwinxpsp3fix kbfix kbbug KB887822

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com