ID do artigo: 887828 - Última revisão: segunda-feira, 26 de novembro de 2007 - Revisão: 3.3

Uma perda de memória ocorre ao executar a API de Sincronização de alteração incremental em um loop no Exchange Server 2003

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

No Microsoft Exchange Server 2003, ao executar programaticamente a API de ICS em um loop para sincronizar as informações no Armazenamento de informações do Exchange, isso faz com que o programa pare de responder ou seja fechado. Nesse cenário, o programa recebe o seguinte código de erro do computador com Exchange Server:
0x80004005

Causa

Esse problema pode ocorrer após a instalação do hotfix descrito no seguinte artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
843523  (http://support.microsoft.com/kb/843523/ ) Ocorre uma perda de memória ao executar um programa que usa a API de Sincronização de alteração incremental no computador com Exchange Server 2003
Esse problema ocorre devido a uma perda de memória que ocorre no objeto ICS no Emsmdb32.dll. Nesse cenário, ao executar o ICS, cada uma das operações de sincronização de download do ICS usa memória. No entanto, essas operações não liberam essa memória. Portanto, quando você executa o ICS em um loop, o programa fica sem memória.

Resolução

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Testes adicionais podem ser realizados nesse hotfix. Portanto, se esse problema não o prejudicar seriamente, é recomendável que você aguarde o próximo service pack que contenha esse hotfix.

Para resolver esse problema, envie uma solicitação para o Atendimento ao Cliente Online Microsoft para obter o hotfix. Para enviar a solicitação online para obter o hotfix, visite o seguinte site da Microsoft:
http://go.microsoft.com/?linkid=6294451 (http://go.microsoft.com/?linkid=6294451)
Observação Se outros problemas ocorrerem ou se uma solução de problemas for requisitada, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem a esse hotfix. Para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Pré-requisitos

Devido às dependências do arquivo, é necessário ter o Microsoft Exchange Server 2003 Service Pack 1 (SP1) instalado para aplicar esse hotfix. Para obter mais informações, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
836993  (http://support.microsoft.com/kb/836993/ ) Como obter os service packs mais recentes para o Exchange Server 2003

Requisitos de reinicialização

Não é necessário reiniciar o computador após a aplicação desse hotfix. No entanto, os seguintes serviços do Exchange são reiniciados automaticamente ao instalar esse hotfix:
  • Pilhas MTA do Microsoft Exchange
  • Armazenamento de Informações do Microsoft Exchange
  • Atendedor do Sistema do Microsoft Exchange

Informações sobre a substituição do hotfix

Esse hotfix não substitui nenhum outro.

Informações sobre o arquivo

A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários destes arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário na ferramenta Data e hora do Painel de Controle.
   Data         Hora   Versão            Tamanho    Nome do arquivo
   --------------------------------------------------------------
   02-out-2004  01:14  6.5.7232.41       975.872  Emsmdb32.dll   

Situação

A Microsoft confirmou que esse é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento Microsoft (alguns artigos podem estar em inglês):
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft
817903  (http://support.microsoft.com/kb/817903/ ) Novo esquema para nomeação de arquivos para os pacotes de atualização de software Exchange Server

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
Palavras-chave: 
kbbug kbfix kbqfe kbexchange2003presp2fix kbhotfixserver KB887828