El escritorio de servicios de Terminal Server está en blanco al iniciar sesión en un equipo remoto basado en Windows 2000

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Síntomas

Utilice Servicios de Terminal Server para iniciar sesión en un equipo que ejecuta Microsoft Windows 2000 con Service Pack 4 (SP4) y la sesión de Terminal Services inicia un programa. Un programa que se ejecuta en la sesión se desconecta. Después de iniciar nuevo en el mismo equipo, el escritorio de sesión de servicios de Terminal Server está en blanco. No ve los iconos o una barra de tareas en el escritorio de sesión de servicios de Terminal Server.

Causa

Este problema se produce porque se presentó un problema cuando se instala la revisión 830869 en el equipo remoto. Este problema se produce cuando se cierra la sesión de Terminal Services y se llama a la función ExitWindowsEx . Cuando se llama a esta función, no se exige el indicador EWX_FORCE. Este indicador obliga a procesos de sesión para salir.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para instalar este hotfix, debe tener Microsoft Windows 2000 Service Pack 3 instalado en el equipo.

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix reemplaza el hotfix 830869.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version              Size  File name
   -----------------------------------------------------------
   24-Mar-2004  02:17  5.0.2195.6876     388,368  Advapi32.dll
   24-Mar-2004  02:17  5.0.2195.6866      69,904  Browser.dll
   24-Mar-2004  02:17  5.0.2195.6824     134,928  Dnsapi.dll
   24-Mar-2004  02:17  5.0.2195.6876      92,432  Dnsrslvr.dll
   24-Mar-2004  02:17  5.0.2195.6883      47,888  Eventlog.dll
   24-Mar-2004  02:17  5.0.2195.6890     143,632  Kdcsvc.dll
   11-Mar-2004  02:37  5.0.2195.6903     210,192  Kerberos.dll
   21-Sep-2003  00:32  5.0.2195.6824      71,888  Ksecdd.sys
   11-Mar-2004  02:37  5.0.2195.6902     520,976  Lsasrv.dll
   25-Feb-2004  23:59  5.0.2195.6902      33,552  Lsass.exe
   11-Mar-2004  02:37  5.0.2195.6897     123,152  Msv1_0.dll
   10-Jun-2004  16:58  5.0.2195.6949     309,008  Netapi32.dll
   24-Mar-2004  02:17  5.0.2195.6891     371,472  Netlogon.dll
   24-Mar-2004  02:17  5.0.2195.6896   1,028,880  Ntdsa.dll
   19-Jun-2003  20:05  5.0.2195.6702      66,320  Ntprint.dll
   11-Mar-2004  21:29  5.0.2195.6906     954,640  Ole32.dll
   19-Jun-2003  20:05  5.0.2195.6702     381,712  Printui.dll
   11-Mar-2004  21:29  5.0.2195.6904     449,808  Rpcrt4.dll
   11-Mar-2004  21:29  5.0.2195.6906     211,728  Rpcss.dll
   24-Mar-2004  02:17  5.0.2195.6897     388,368  Samsrv.dll
   24-Mar-2004  02:17  5.0.2195.6893     111,376  Scecli.dll
   24-Mar-2004  02:17  5.0.2195.6903     253,200  Scesrv.dll
   30-Oct-2004  07:07  5.0.2195.6994   6,140,416  Sp3res.dll
   24-Mar-2004  02:17  5.0.2195.6824      50,960  W32time.dll
   21-Sep-2003  00:32  5.0.2195.6824      57,104  W32tm.exe
   17-Nov-2004  17:11  5.0.2195.7000      57,104  Wlnotify.dll

Solución

Para evitar este problema, siga estos pasos en la sesión de cliente de Terminal Services para desactivar la opción de protector de pantalla protegido por contraseña .

Nota Recomendamos que no utilice un protector de pantalla con la sesión de servicios de Terminal Server debido de ancho de la banda aumento es necesario.
  1. Haga clic en Inicio , haga clic en Panel de control y haga doble clic en el elemento Mostrar .
  2. Haga clic en la ficha Protector de pantalla , haga clic para desactivar protegido por contraseña y, a continuación, haga clic en Aceptar .
Si desea desconectar las sesiones inactivas, establezca el límite de sesión inactiva en servicios de Terminal Server. Para hacer esto para todas las sesiones, siga estos pasos en el equipo que tiene activado los servicios de Terminal Server.
  1. Haga clic en Inicio , seleccione programas , Herramientas administrativas y, a continuación, haga clic en Configuración de servicios de Terminal Server .
  2. En conexiones , haga doble clic en RDP-Tcp y, a continuación, haga clic en la ficha sesiones .
  3. Haga clic para seleccionar Anular configuración de usuario .
  4. En el cuadro de límite de sesión inactiva , haga clic en el límite de sesión inactiva que desee.
  5. Active la segunda casilla de verificación Anular configuración de usuario y, a continuación, haga clic en la opción de Desconectar de la sesión .
  6. Haga clic en Aceptar .
  7. Cierre configuración de servicios de Terminal Server.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener información adicional acerca de la revisión 830869, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
830869Sesión del usuario es forzosamente cuando un programa llama a la función ExitWindowsEx incluso cuando el equipo está bloqueado
Para obtener información adicional acerca del nuevo archivo de esquema de nomenclatura para los paquetes de actualización de software Microsoft Windows de, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura de archivos para los paquetes de actualización de software de Microsoft Windows
Para obtener información adicional acerca de la terminología utilizada en este artículo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 887961 - Última revisión: jueves, 26 de octubre de 2006 - Versión: 1.5
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Professional SP4
Palabras clave: 
kbmt kbautohotfix kbbug kbfix kbwin2000presp5fix kbhotfixserver kbqfe KB887961 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 887961

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