You receive a "The product does not have a prerequisite update installed" error message when you try to install a SQL Server 2000 post-Service Pack 3 hotfix

Article translations Article translations
Article ID: 888007 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

When you try to apply a Microsoft SQL Server 2000 post-Service Pack 3a (SP3a) hotfix that is later than build 2000.80.977, you may receive the following error, and you cannot apply the hotfix:
The product does not have a prerequisite update installed. The installation is dependent on the prerequisite update and cannot be installed. Exit setup and refer to the Knowledge Base article to find the prerequisite patch. Install the prerequisite and rerun the installation.

CAUSE

This problem occurs because SQL Server 2000 post-SP3a hotfix baseline is not installed on the computer.

Important notes:
  • Microsoft Windows 98, Microsoft Windows Millennium Edition, and Microsoft Windows NT have separate hotfix packages for SQL Server 2000 which do not have baseline requirements.
  • SQL Server 2000 Service Pack 4 (SP4) based hotfixes will use SP4 itself as their baseline. However, this may change in the future as updates require.

RESOLUTION

To resolve this problem, determine the version of the SQL Server 2000 SP3 hotfix that you are trying to install. You will find this information in the package name. The information will also be listed in the KB article.

If the hotfix that you are trying to install is in the range from 2000.80.0978 to 2000.80.1006, then you must first install SQL Server 2000 post-SP3a hotfix build 2000.80.977. After you install SQL Server 2000 post-SP3a hotfix build 2000.80.977, you may install a higher-versioned hotfix.

If the hotfix that you are trying to install is greater than 2000.80.1007, then you must first install SQL Server 2000 post-SP3a hotfix build 2000.80.1007. After you install SQL Server 2000 post-SP3a hotfix build 2000.80.1007, you may install a higher-versioned hotfix.

MORE INFORMATION

SQL Server 2000 hotfixes on Microsoft Windows 2000, on Microsoft Windows XP, and on Microsoft Windows Server 2003 changed installers from Hotfix.exe to Update.exe on x86 as of SQL Server 2000 post-SP3a hotfix build 2000.80.977. This change resulted in similar troubleshooting steps, similar logs, and similar command-line parameters across many Microsoft products. This new Update.exe-based hotfix installer let Microsoft enable the uninstallation of hotfixes for SQL Server. This is a new feature that was not available before this time.

Hotfix installation for SQL Server hotfixes involves running scripts. Therefore, hotfix uninstallation must involve running appropriate "anti-scripts" that undo the script changes that are made by the installer. To have a starting position for script uninstallation, a baseline must be created from which the installer works. Therefore, any hotfix that represents a baseline cannot itself be uninstalled. However, any hotfix that applies to any existing baseline can be uninstalled. Multiple hotfixes that are applied in addition to each other can be uninstalled in the same order that they were installed until you have returned to the baseline build.

Because the hotfix installer for Windows 98, Windows Millennium Edition, and Windows NT does not support uninstallation, these operating systems have no baseline requirement. For example, on Windows 98, you do not have to first install hotfix build 2000.80.977 to install a higher-versioned hotfix. For more information about the hotfix installer for Windows 98, Windows Millennium Edition, and Windows NT, click the following article number to view the article in the Microsoft Knowledge Base:
330391 SQL Server hotfix installer


For more information about the hotfix installers, click the following article number to view the article in the Microsoft Knowledge Base:
842960 Description of the 32-bit SQL Server 7.0 and SQL Server 2000 hotfix installer
872912 Description of the 64-bit SQL Server 2000 hotfix installer

If you are installing SQL Server 2000 on a new computer that is running Windows 2000, Windows XP, or Windows Server 2003, install the products in the following order:
  1. SQL Server 2000a (build 8.00.0194.12)
  2. SQL Server 2000 SP3a (build 8.00.0760)
  3. SQL Server 2000 hotfix build 8.00.0977 or SQL Server 2000 hotfix build 8.00.1007, as appropriate
  4. SQL Server 2000 hotfix that is greater than 977 (build 8.00.0xxx) or greater than 1007, as appropriate

Properties

Article ID: 888007 - Last Review: August 31, 2005 - Revision: 5.3
APPLIES TO
  • Microsoft SQL Server 2000 Service Pack 3
  • Microsoft SQL Server 2000 Service Pack 3a
  • Microsoft SQL Server 2000 64-bit Edition
Keywords: 
kbprb kbtshoot KB888007

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com