文書番号: 888019 - 最終更新日: 2005年8月16日 - リビジョン: 2.0

Windows XP にソフトウェアをインストールするときにエラー メッセージ "1607: InstallShield Scripting Runtime をインストールできません" が表示される

目次

すべて展開する | すべて折りたたむ

現象

Microsoft Windows XP ベースのコンピュータにソフトウェアをインストールしようとすると、インストールに失敗し、次のエラー メッセージが表示されることがあります。
1607:InstallShield Scripting Runtime をインストールできません。

原因

この問題は、以下の条件のいずれかに該当する場合に発生することがあります。
  • subst コマンドを使用して作成した仮想ドライブからセットアップ プログラムを実行している。
  • ドライバ IDriver.exe が正しく登録されていない。
  • インストーラ Msiexec.exe が正しく登録されていない。
  • ユーザー アカウントに、C:\Windows\Installer フォルダにアクセスするためのアクセス許可がない。
  • 古いバージョンの Windows インストーラ エンジンが、現在利用できなくなっているネットワーク ドライブからインストールされた。
  • コンピュータにソフトウェアをインストールするためのアクセス許可がユーザー アカウントにない。
  • Msiexec.exe の別のインスタンスが実行されている。
  • Windows インストーラ ベースの別のセットアップ プログラムが実行されている。
  • Windows XP が破損している。

解決方法

この問題を解決するには、以下のいずれかの方法を使用します。

InstallScript エンジンの再インストール

InstallShield Developer から InstallScript エンジンを再インストールするには、以下の手順を実行します。
  1. [スタート] ボタンをクリックし、[すべてのプログラム]、[アクセサリ] の順にポイントし、[エクスプローラ] をクリックします。
  2. C:\Program Files\InstallShield\Developer\Redist\Language Independent\i386 フォルダを開きます。
  3. [Isscrpt.msi] をダブルクリックします。
  4. 画面に表示される指示に従います。

仮想ドライブからのセットアップの実行

SUBST コマンドを使用して作成した仮想ドライブからセットアップ プログラムを実行している場合は、仮想ドライブを削除し、代わりに物理ハード ディスクからセットアップ プログラムを実行できます。仮想ドライブを削除するには、[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、subst drive_letter: /d と入力し、[OK] をクリックします。

Idriver および Msiexec の登録

Idriver および Msiexec を登録するには、以下の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、"C:\Program Files\Common Files\InstallShield\Developer\7\Intel 32\IDriver.exe" /REGSERVER と入力し、[OK] をクリックします。
  2. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、C:\Windows\System32\msiexec.exe /REGSERVER と入力し、[OK] をクリックします。

アクセス許可の変更

管理者のユーザー アカウントで Windows XP コンピュータにログオンし、C:\Windows\Installer フォルダに対する正しいアクセス許可があることを確認します。以下の手順を実行します。
  1. [スタート] ボタンをクリックし、[すべてのプログラム]、[アクセサリ] の順にポイントし、[エクスプローラ] をクリックします。
  2. [ツール] メニューの [フォルダ オプション] をクリックします。
  3. [表示] タブをクリックします。
  4. [すべてのファイルとフォルダを表示する] をクリックし、[OK] をクリックします。
  5. C:\Windows\Installer フォルダに移動します。
  6. [Installer] フォルダを右クリックし、[プロパティ] をクリックします。
  7. [セキュリティ] タブをクリックします。
  8. [SYSTEM] をクリックし、[フル コントロール] の [許可] チェック ボックスがオンになっていることを確認します。
  9. [Administrators] をクリックし、[フル コントロール] の [許可] チェック ボックスがオンになっていることを確認します。
  10. 自分のユーザー名をクリックし、[フル コントロール] の [許可] チェック ボックスがオンになっていることを確認します。

Windows インストーラの他のインスタンスの停止

Windows インストーラの他のインスタンスを停止するには、次の手順を実行します。
  1. タスク バーを右クリックし、[タスク マネージャ] をクリックします。
  2. [プロセス] タブをクリックします。
  3. プロセスの一覧で [Msiexec.exe] をクリックし、[プロセスの終了] をクリックします。
  4. [はい] をクリックします。
  5. Msiexec.exe の各インスタンスについて、手順 3. 〜 4. を繰り返します。
  6. タスク マネージャを閉じます。

Windows XP の再インストール

Windows XP を再インストールする方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
315341? (http://support.microsoft.com/kb/315341/ ) Windows XP のインプレース アップグレード (再インストール) を実行する方法
この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 888019? (http://support.microsoft.com/kb/888019/EN-US/ ) (最終更新日 2005-05-04) を基に作成したものです。

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
キーワード:?
kbsetup kbtshoot kbprb KB888019
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"
 

サポート技術情報の翻訳

 

Related Support Centers