表示されることがあります、"1607年: InstallShield Scripting ランタイムをインストールすることができません"Windows XP にソフトウェアをインストールしようとするとエラー メッセージ

文書翻訳 文書翻訳
文書番号: 888019 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

Microsoft Windows XP ベースのコンピューターにソフトウェアをインストールしようとして、インストールが失敗、次のエラー メッセージを受け取ることがあります。
1607: InstallShield Scripting ランタイムをインストールすることができません

原因

この問題は、次の条件のいずれかに該当する場合に発生します。
  • セットアップ プログラムを実行して、仮想ドライブの createdthrough から、 subst command.
  • IDriver.exe のドライバーは registeredcorrectly ではありません。
  • インストーラーの Msiexec.exe は registeredcorrectly ではありません。
  • ユーザー アカウントには theC:\Windows\Installer フォルダーにアクセスするためのアクセス許可がありません。
  • 以前のバージョンが利用できなくなっているネットワーク ドライブから、Windows インストーラー エンジンの wasinstalled の。
  • ユーザー アカウントには、コンピューター上のアレイへのアクセス許可がありません。
  • Msiexec.exe の別のインスタンスが実行されています。
  • 別の Windows インストーラー ベースのセットアップ プログラム isrunning。
  • Windows XP が破損しています。

解決方法

この問題を解決するには、次の方法のいずれかを使用します。

InstallScript エンジンは、再インストールします。

InstallShield の開発者からの InstallScript エンジンは、再インストール、次の手順に従います。
  1. IsScript7.zip ファイルをダウンロードします。これを行うには、次の InstallShield の Web サイトを参照してください。
    http://support.installshield.com/kb/files/Q108158/IsScript7.zip
  2. IsScript7.zip ファイルを抽出します。
  3. Isscript.msi ファイルをダブルクリックします。

仮想ドライブからセットアップを実行します。

SUBST コマンドを使用して作成した仮想ドライブからセットアップ プログラムを実行している場合は、仮想ドライブを削除し、代わりに物理ハード_ディスクからセットアップ プログラムを実行できます。仮想ドライブを削除、[スタート] ボタン、実行をクリックして型 subst drive_letter:/d、し [ OK] をクリックします。

Idriver と、Msiexec を登録します。

Idriver および Msiexec の登録、次の手順に従います。
  1. [スタート] ボタン、実行をクリックして型 "C:\Program ファイル Files\InstallShield\Driver\<versionnumber></versionnumber>\Intel 32\IDriver.exe"/REGSERVER、し [ OK] をクリックします。

    注: Differentcomputers、<version number="">によって異なります。InstallScript エンジンは、バージョンに依存します</version>。
  2. [スタート] ボタン、実行をクリックして型 C:\Windows\System32\msiexec.exe 名を指定して、し[OK] をクリックします。

アクセス許可の変更

管理者のユーザー アカウントで Windows XP コンピューターにログオンし、C:\Windows\Installer フォルダーに対する適切なアクセス許可があることを確認します。次の手順を実行します。
  1. [スタート] ボタン、シリアルキーをクリックして、アクセサリ、およびWindows エクスプ ローラーをクリックします。
  2. [ツール] メニューのフォルダー オプションをクリックします。
  3. 表示] タブをクリックします。
  4. 隠しファイルとフォルダーの表示] をクリックし[OK] をクリックします。
  5. C:\Windows\Installer フォルダーに移動します。
  6. インストーラーのフォルダー、し [プロパティ] を右クリックします。
  7. [セキュリティ] タブをクリックします。
  8. システムをクリックし、[フル コントロール] チェック ボックスが選択されていることを確認します。
  9. 管理者をクリックし、[フル コントロール] チェック ボックスが選択されていることを確認します。
  10. 自分のユーザー名をクリックし、[フル] チェック ボックスが選択されていることを確認します。

Windows インストーラーの他のインスタンスを停止します。

Windows インストーラーの他のインスタンスを停止して、以下の手順を実行します。
  1. タスク バーを右クリックし、[タスク マネージャー] をクリックします。
  2. [プロセス] タブをクリックします。
  3. Msiexec.exeプロセス] ボックスの一覧をクリックし、[ EndProcess] をクリックします。
  4. [はい]をクリックします。
  5. 各インスタンスの ofMsiexec.exe を手順 3 と 4 を繰り返します。
  6. タスク マネージャーを閉じます。

Windows XP を再インストールします。

Windows XP の再インストールに関する詳細については、次のマイクロソフト サポート技術資料を参照する次の文書番号をクリックしてください。
978788Windows XP のインプレース アップグレード (再インストール) を実行する方法
この資料に記載されているサード パーティ製品は、マイクロソフトに関係しない会社によって製造されています。マイクロソフトは、明示的または黙示的に関わらず、これらの製品に関するパフォーマンスや信頼性について保証しません。

プロパティ

文書番号: 888019 - 最終更新日: 2014年3月26日 - リビジョン: 5.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
キーワード:?
kbsetup kbtshoot kbprb kbmt KB888019 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:888019
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com