คุณอาจได้รับการ " 1607: ไม่สามารถติดตั้งรันไทม์การเขียนสคริปต์ InstallShield " ข้อความแสดงข้อผิดพลาดเมื่อคุณพยายามติดตั้งซอฟต์แวร์ใน Windows XP

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 888019 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณพยายามติดตั้งซอฟต์แวร์บนคอมพิวเตอร์ที่ใช้ Microsoft Windows XP การติดตั้งล้มเหลว และคุณอาจได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้:
1607: ไม่สามารถติดตั้ง InstallShield การเขียนสคริปต์รันไทม์

สาเหตุ

ปัญหานี้อาจเกิดขึ้นได้หากเงื่อนไขใด ๆ ต่อไปนี้เป็นจริง:
  • คุณเรียกใช้โปรแกรมติดตั้งจาก createdthrough เป็นไดรฟ์เสมือนนี้ subst คำสั่ง
  • ไดรเวอร์ IDriver.exe ไม่ใช่ registeredcorrectly
  • โปรแกรมติดตั้ง Msiexec.exe ไม่ได้ registeredcorrectly
  • บัญชีผู้ใช้ไม่มีสิทธิ์ในการเข้าถึงโฟลเดอร์ theC:\Windows\Installer
  • รุ่นเก่ากว่าของ wasinstalled โปรแกรม Windows Installer จากไดรฟ์เครือข่ายที่ไม่พร้อมใช้งาน
  • บัญชีผู้ใช้ที่มีสิทธิ์ในการ installsoftware บนคอมพิวเตอร์
  • อินสแตนซ์อื่นของ Msiexec.exe กำลังทำงานอยู่
  • Isrunning โปรแกรม Windows Installer โดยใช้การตั้งค่าอื่น
  • Windows XP เสียหาย

การแก้ไข

เมื่อต้องแก้ไขปัญหานี้ ใช้หนึ่งในวิธีต่อไปนี้:

ติดตั้งโปรแกรม InstallScript

เมื่อต้องการติดตั้งโปรแกรม InstallScript จากนักพัฒนาของ InstallShield ให้ทำตามขั้นตอนเหล่านี้:
  1. ดาวน์โหลดแฟ้ม IsScript7.zip เมื่อต้องการทำเช่นนี้ เยี่ยมชม InstallShield เว็บไซต์ต่อไปนี้:
    http://support.installshield.com/kb/files/Q108158/IsScript7.zip
  2. แยกแฟ้ม IsScript7.zip
  3. คลิกสองครั้งที่แฟ้ม isscript.msi ใหม่

เรียกใช้โปรแกรมติดตั้งจากไดรฟ์เสมือน

ถ้าคุณกำลังเรียกใช้โปรแกรมติดตั้งจากไดรฟ์เสมือนที่สร้างโดยคำสั่ง SUBST คุณสามารถลบไดรฟ์เสมือน และรันโปรแกรมติดตั้งจากฮาร์ดดิสก์มีอยู่จริง เมื่อต้องการลบไดรฟ์เสมือน คลิกเริ่มคลิกเรียกใช้ชนิด subst drive_letter: /dแล้ว คลิกตกลง

ลงทะเบียน Idriver และ Msiexec

เมื่อต้องการลงทะเบียน Idriver และ Msiexec ให้ทำตามขั้นตอนเหล่านี้:
  1. คลิกเริ่มคลิกเรียกใช้ชนิด "C:\Program Files\Common Files\InstallShield\Driver\<versionnumber></versionnumber>\Intel 32\IDriver.exe"/REGSERVERแล้ว คลิกตกลง

    หมายเหตุ <version number="">แตกต่างกันไปใน differentcomputers ขึ้นอยู่กับรุ่นของโปรแกรม InstallScript</version>
  2. คลิกเริ่มคลิกเรียกใช้ชนิด C:\Windows\System32\msiexec.exe /REGSERVER, andthen คลิกตกลง

เปลี่ยนแปลงสิทธิ์

เข้าสู่ระบบไปยังคอมพิวเตอร์ Windows XP ด้วยแอคเคาท์ผู้ดูแลระบบ และตรวจสอบว่า คุณมีสิทธิ์ที่ถูกต้องสำหรับโฟลเดอร์ C:\Windows\Installer ทำตามขั้นตอนเหล่านี้:
  1. คลิกเริ่มคลิAllProgramsชี้ไปที่เบ็ดเตล็ดและจากนั้น คลิกWindows Explorer
  2. คลิกตัวเลือกโฟลเดอร์บนเมนูเครื่องมือ
  3. คลิกแท็บมุมมอง
  4. คลิกแสดงแฟ้มที่ซ่อนไว้และโฟลเดอร์andthen คลิกตกลง
  5. หาโฟลเดอร์ C:\Windows\Installer
  6. คลิกขวาโฟลเดอร์การติดตั้งและคุณสมบัติthenclick
  7. คลิกแท็บ ความปลอดภัย
  8. คลิกระบบและตรวจสอบว่า ได้เลือกกล่องกาเครื่องหมายควบคุมทั้งหมด
  9. คลิกผู้ดูแลและตรวจสอบว่า ได้เลือกกล่องกาเครื่องหมายควบคุมทั้งหมด
  10. คลิกชื่อผู้ใช้ของคุณ และตรวจสอบว่า ได้เลือกกล่องกาเครื่องหมายFullcontrol

หยุดอินสแตนซ์อื่นของโปรแกรมติดตั้ง Windows

เมื่อต้องการหยุดอินสแตนซ์อื่น ๆ ของ Windows Installer ให้ทำตามขั้นตอนเหล่านี้:
  1. คลิกขวาที่แถบงานแล้ว คลิ กตัวจัดการงาน
  2. คลิกแท็บกระบวนการ
  3. คลิกMsiexec.exeในรายการกระบวนการและจากนั้น คลิกEndProcess
  4. คลิกใช่
  5. ทำซ้ำขั้นตอนที่ 3 และ 4 สำหรับแต่ละ ofMsiexec.exe อินสแตนซ์
  6. ปิดตัวจัดการงาน

ติดตั้ง Windows XP ใหม่

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการติดตั้ง Windows XP คลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
978788วิธีการดำเนินการปรับรุ่นแบบแทนที่ (ติดตั้งใหม่) สำหรับ Windows XP
ผลิตภัณฑ์ของบริษัทอื่นที่กล่าวถึงในบทความนี้ เป็นผลิตภัณฑ์ที่ผลิตโดยบริษัทอื่นๆ ที่ไม่เกี่ยวข้องกับ Microsoft Microsoft ไม่รับประกันไม่ว่าโดยนัยหรือรูปแบบอื่นใด เกี่ยวกับประสิทธิภาพหรือความน่าเชื่อถือของผลิตภัณฑ์เหล่านี้

คุณสมบัติ

หมายเลขบทความ (Article ID): 888019 - รีวิวครั้งสุดท้าย: 26 มีนาคม 2557 - Revision: 2.0
ใช้กับ
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Keywords: 
kbsetup kbtshoot kbprb kbmt KB888019 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:888019

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com