Artigo: 888046 - Última revisão: quinta-feira, 11 de Outubro de 2007 - Revisão: 4.8

Recebe uma mensagem de erro quando tenta instalar uma impressora de rede partilhada num computador baseado no Windows Server 2003 ou baseados no Windows XP SP1

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Se tentar instalar uma impressora de rede partilhada, detectar sintomas se as seguintes condições forem verdadeiras:
  • Tiver uma impressora de rede partilhada instalada num servidor de impressão baseado no Microsoft Windows 2000 Advanced Server.
  • O utilizador tenta instalar a impressora de rede partilhada localmente num computador que faça parte de um domínio do Windows.
  • Tenta instalar a impressora de rede partilhada localmente num computador que esteja a executar um dos seguintes sistemas operativos:
    • Windows XP Service Pack 1 (SP1)
    • Windows Server 2003
Neste cenário, detectar os sintomas seguintes quando tenta instalar uma impressora de rede partilhada:
  • Se tentar instalar a impressora num cliente baseado no Windows XP SP1 utilizando o Assistente para adicionar impressoras ou utilizando o nome de partilha da impressora a \\ PrintServerName \ PrinterShareName localização, receberá a seguinte mensagem de erro:
    Uma política é activada no computador que impede a ligar a esta fila de impressão. Contacte o administrador de sistema.
  • Se utilizar o ' Assistente para adicionar impressoras ' para tentar instalar a impressora num cliente baseado no Windows Server 2003, receberá a seguinte mensagem de erro quando clicar em Concluir para concluir a instalação da impressora:
    Não é possível instalar a impressora. O controlador de impressora não é compatível com uma política activada no computador que bloqueia controladores do Windows NT 4.0. Se pretender utilizar este controlador, contacte o administrador de sistema sobre como desactivar esta política.

Causa

Este problema ocorre se o controlador de impressora que está instalado no servidor de impressão for um controlador de impressora de outros fabricantes. Não pode instalar uma impressora de rede partilhada que tenha um controlador de impressora de outros fabricantes localmente num computador com o Windows XP SP1 se for um utilizador normal ou um membro de utilizadores avançados grupo. Windows XP SP1 não permite que utilizadores normais ou membros do poder grupo de utilizadores para instalar os controladores de outros fabricantes. No Windows XP SP1, apenas as seguintes pessoas têm permissão para instalar um controlador de outros fabricantes:
  • Administrador local
  • Membros do grupo Administradores
  • Membros do grupo Utilizadores avançados com as permissões de política de carregar e descarregar controladores de dispositivo
Se o computador baseado no Windows XP SP1 está associado a um domínio baseado no Microsoft Windows NT 4.0, utilizadores normais e os membros do grupo Utilizadores avançados poderão instalar controladores de impressora de outros fabricantes para o computador cliente baseado no Windows XP SP1. Poderá detectar problemas na instalação de um controlador de impressora de terceiros num computador com o Windows XP SP1, se o computador baseado no Windows XP SP1 for parte de um grupo de trabalho ou parte de um domínio baseado no Microsoft Windows 2000.

No Windows Server 2003, não pode instalar uma impressora de rede partilhada localmente se o controlador de impressora que está instalado no servidor de impressão utiliza controladores de impressora de modo kernel de outros fabricantes. Uma definição de política no Windows Server 2003 impede que os utilizadores instalar impressoras que utilizam controladores de impressão de modo kernel de outros fabricantes.

Este problema também poderá ocorrer se se verificarem as seguintes condições:
  • Pesquisa de zona inversa de DNS não está configurada.
  • DNS está configurado correctamente no servidor de impressão.
  • Problemas DNS no servidor de impressão.

Resolução

Para resolver este problema, modifique as definições de política de grupo para o objecto de política de grupo (GPO, Group Policy Object) que tem impressora políticas definidas para os utilizadores de domínio no controlador de domínio. Para o fazer, utilize um dos seguintes métodos.

Método 1

  1. Configure a definição de política carregar e descarregar controladores de dispositivo para o grupo Utilizadores avançados. Para o fazer, siga estes passos:
    1. Clique em Iniciar , aponte para programas , aponte para Ferramentas administrativas e, em seguida, clique em utilizadores do Active Directory e computadores .
    2. No painel de navegação, clique com o botão direito do rato o nome de domínio e, em seguida, clique em Propriedades .
    3. Clique no separador Política de grupo , clique no GPO que pretende modificar e, em seguida, clique em Editar .
    4. No Editor de objecto de política de grupo, localize e clique na pasta Computador configuração do computador\Definições do Windows\Definições segurança\Políticas Locais\atribuição de direitos .
    5. Localize e faça duplo clique em carregar e descarregar controladores de dispositivo .
    6. Clique para seleccionar a caixa de verificação Definir estas definições de política e, em seguida, clique em Adicionar utilizador ou grupo para adicionar utilizadores avançados grupo de domínio.
    7. Na caixa de diálogo Adicionar utilizador ou grupo , clique em Procurar para localizar utilizadores avançados grupo de domínio. Em Introduza os nomes de objectos para seleccionar , escreva Utilizadores avançados e, em seguida, clique em Verificar nomes para resolver o nome do grupo. Clique três vezes em OK .
  2. Desactive a política não permitir instalação de impressoras utilizando controladores de modo kernel . Para o fazer, siga estes passos:
    1. No painel da esquerda, localize e clique na pasta do Computador do computador\Modelos administrativos\Impressoras .
    2. Localize e, em seguida, faça duplo clique em não permitir instalação de impressoras utilizando controladores de modo kernel , clique em desactivado e, em seguida, clique em OK .
  3. Desactive a política apontar e imprimir restrições . Para o fazer, siga estes passos:
    1. No painel da esquerda, localize e clique na pasta de Utilizador\modelos administrativos\Painel de controlo\Impressoras .
    2. Localize e, em seguida, faça duplo clique em pontos e restrições de impressão , clique em desactivado e, em seguida, clique em OK .
  4. No menu ficheiro , clique em Sair .
  5. Clique em Iniciar , clique em Executar , escreva cmd.exe e, em seguida, clique em OK .
  6. Na linha de comandos, escreva gpupdate /force e, em seguida, prima ENTER.
  7. Repita os passos 5 a 6 nos computadores cliente baseados no Windows XP SP1 e baseado no Windows Server 2003 do domínio.

Método 2

  1. No Windows Server 2003 servidor de impressão, clique em Iniciar , clique em Executar , escreva Cmd e, em seguida, clique em OK .
  2. Na linha de comandos, escreva C:\ e, em seguida, prima ENTER.
  3. Escreva Cd\ e, em seguida, prima ENTER.
  4. Tipo ipconfig/all , e, em seguida, prima ENTER.
  5. Anote o endereço IP do computador servidor de impressão.

    Nota A saída para o Ipconfig /all comandos poderão assemelhar-se a seguinte:
    Windows IP Configuration
       Host Name . . . . . . . . . . . . : MachineName
       Primary Dns Suffix  . . . . . . . : DomainName.com
       DNS Suffix Search List. . . . . . : DomainName.com
    Ethernet adapter LAN:
       IP Address. . . . . . . . . . . . : 169.0.0.10
       Subnet Mask . . . . . . . . . . . : 255.255.252.0
       DNS Servers . . . . . . . . . . . : 169.0.0.1
                                           169.0.0.2
                                           169.0.0.3
    
  6. No computador cliente baseado no Windows XP, clique em Iniciar , clique em Executar , escreva Cmd e, em seguida, clique em OK .
  7. Na linha de comandos, escreva C:\ e, em seguida, prima ENTER.
  8. Escreva Cd\ e, em seguida, prima ENTER.
  9. Escreva Nslookup PrintServer_IP e, em seguida, prima ENTER.

    Nota PrintServer_IP é o endereço IP que anotou no passo 5.
  10. Certifique-se que a saída do comando NsLookup contém o nome de domínio totalmente qualificado (FQDN, Fully Qualified Domain Name) correcto do servidor de impressão. Se estiver incorrecta, terá de contactar o administrador de rede para resolver o problema DNS.

Mais Informação

Quando desactiva a política de apontar e imprimir restrições que se encontra em Utilizador\modelos administrativos\Painel de controlo\Impressoras , os utilizadores podem utilizar a funcionalidade apontar e imprimir para seleccionar qualquer impressora partilhada que têm acesso. Para obter mais informações sobre esta política, consulte o seguinte artigo da base de dados de conhecimento da Microsoft:
319939  (http://support.microsoft.com/kb/319939/ ) Descrição da definição de política apontar e imprimir restrições no Windows Server 2003 e no Windows XP

Como utilizar o registo para definir a política "Ponto impressão restrições e"

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows


A política apontar e imprimir restrições também pode ser definida na seguinte subchave de registo:
HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows NT\Printers\PointAndPrint
Valor: InForest
Tipo: REG_DWORD
Dados: 0 ou 1
Uma definição de 0 desactiva esta entrada. Uma definição de 1 restringe o acesso impressora impressoras na floresta.

Valor: restritos
Tipo: REG_DWORD
Dados: 0 ou 1
Uma definição de 0 desactiva esta entrada. Uma definição de 1 restringe todas as impressoras.

Valor: TrustedServers
Tipo: REG_DWORD
Dados: 0 ou 1
Uma definição de 0 desactiva esta entrada. Uma definição de 1 permite impressoras seja apresentado na caixa de diálogo lista de servidores.

Para obter mais informações sobre instalação de impressora problemas no Windows XP e Windows Server 2003, clique números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft:
326473  (http://support.microsoft.com/kb/326473/ ) É avisado as credenciais de administrador quando tenta instalar uma impressora plug and play
282011  (http://support.microsoft.com/kb/282011/ ) Controlador de impressora não é compatível, se uma política estiver activada no computador
319939  (http://support.microsoft.com/kb/319939/ ) Descrição da definição de política apontar e imprimir restrições no Windows Server 2003 e no Windows XP

Suporte técnico para versões baseadas em 64 do Microsoft Windows x

Se o hardware foi fornecido com uma edição x 64 do Microsoft Windows instalada, o fabricante do hardware fornece suporte técnico e assistência para a edição x 64 do Windows. Neste caso, o fabricante do hardware fornece suporte porque foi incluída com o hardware de uma edição x 64 do Windows. O fabricante do hardware pode ter personalizado a instalação da edição x 64 do Windows utilizando componentes exclusivos. Estes componentes exclusivos podem incluir controladores de dispositivo específicos ou podem incluir definições opcionais para maximizar o desempenho do hardware. A Microsoft fornecerá assistência razoável se necessitar de assistência técnica para uma edição x 64 do Windows. No entanto, poderá ter de contactar o fabricante directamente. O fabricante está melhor qualificado para suportar o software que o fabricante do instalado no hardware. Se tiver adquirido uma edição x 64 do Windows como o um Microsoft Windows Server 2003 x 64 edition, separadamente, contacte a Microsoft para obter suporte técnico.

Para obter informações sobre o Microsoft Windows XP Professional x 64 Edition, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/windowsxp/64bit/default.mspx (http://www.microsoft.com/windowsxp/64bit/default.mspx)
Para obter informações sobre versões baseadas em 64 do Microsoft Windows Server 2003 x, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx (http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx)

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
Palavras-chave: 
kbmt kbwinservperf kbfileprintservices kb3rdparty kbtshoot KB888046 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 888046  (http://support.microsoft.com/kb/888046/en-us/ )