No puede conectarse a una carpeta Web desde un equipo de Windows XP x 64 o Windows Server 2003

Seleccione idioma Seleccione idioma
Id. de artículo: 888123 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando intenta conectarse a una carpeta Web desde un equipo basado en Windows Server 2003 o Windows XP x 64 con Windows Internet Explorer, puede recibir el siguiente mensaje de error:
Internet Explorer no pudo abrir http:// ServerName como una carpeta web.
¿Desea ver su vista predeterminada?
Además, si intenta conectarse a una carpeta Web mediante Mis sitios de red, puede recibir el siguiente mensaje de error:
La carpeta que ha especificado no parece ser válido. Elija otro.

Causa

Este problema se produce cuando intenta conectarse a una carpeta Web mediante un cliente basado en Windows Server 2003 o Windows XP x 64 de cliente. Ni Windows Server 2003 ni Windows XP x 64 incluyen un componente de Microsoft Data Access Internet Publishing Provider. En un entorno de 32 bits, el componente Microsoft Data Access Internet Publishing Provider permite conectarse a un servidor Web como una carpeta Web cuando el servicio de cliente Web nativo no puede. Sin embargo, el proveedor de datos de Microsoft Access Internet Publishing está disponible como sólo una aplicación de 32 bits. Por tanto, el Explorador de Windows y otras aplicaciones de 64 bits no se pueden utilizar el componente Microsoft Data Access Internet Publishing Provider en un equipo basado en 64 x en Windows.

Nota Explorador de Windows incluye el shell del explorador de Windows, cuadros de diálogo comunes de Windows Explorer, Windows Explorer Mis sitios de red y otras aplicaciones de Windows Explorer.

Por tanto, las aplicaciones de 64 bits deben utilizar Web Distributed Authoring and Versioning (WebDAV) mediante el redirector de servicio de cliente Web nativo para conectarse a un servidor Web como una carpeta Web.

Nota
  • Hay actualmente ningún plan para trasladar este componente de datos Access Internet Publishing Provider en desuso para futuras versiones de 64 bits del sistema operativo.
  • El redirector del servicio cliente Web nativo para WebDAV proporciona compatibilidad para sólo puerto TCP 80. Causa de esta restricción, no puede establecer una conexión de carpeta Web en cualquier servidor Web que implementa WebDAV en un puerto alternativo. Por tanto, el redirector de servicio de cliente Web nativo no admite SSL para la comunicación de WebDAV en un servidor Web porque SSL utiliza el puerto TCP 443. Sin embargo, esta limitación no es aplicable para el cliente Web nativo en Windows Vista o en una versión posterior de Windows.
  • El redirector de servicio de cliente Web nativo sólo se comunica mediante WebDAV. Por tanto, no puede establecer una conexión de carpeta Web en cualquier servidor Web que implementa la funcionalidad de la carpeta Web utilizando un componente Web Extender Client, como extensiones de servidor.

Solución

Esta resolución implica algunos componentes de Microsoft Data Access Internet Publishing Provider de 32 bits. Estos componentes se aplican a sólo las aplicaciones de 32 bits que puede utilizar los componentes de 32 bits y que están instalados en un equipo que ejecuta una versión de 64 bits de un sistema operativo Windows. Por ejemplo, esta resolución se aplica a la versión de 32 bits de Windows Internet Explorer cuando se utiliza en un equipo que ejecuta una versión de 64 bits de un sistema operativo Windows.

Nota La versión de 64 bits de Internet Explorer no puede utilizar los componentes de Microsoft Data Access Internet Publishing Provider.

Para resolver este problema, utilice uno de los métodos siguientes.

Método 1: Instalar los componentes de cliente de Microsoft Office SharePoint Portal Server 2003 para bibliotecas de documentos compatible con versiones anteriores

Los usuarios con una licencia de Microsoft SharePoint Portal Server pueden descargar Microsoft Office SharePoint Portal Server 2003 Client Components las bibliotecas de documentos compatibles con versiones anteriores. Para descargar estos componentes de cliente, visite el siguiente sitio Web:
http://www.microsoft.com/downloads/details.aspx?FamilyID=df39e250-f7ae-445a-ac9d-a80c9035ed6b

Método 2: Instalar el paquete de webfldrs.msi que está disponible con Windows 2000 o Windows XP

Instale el paquete de webfldrs.msi disponible con Windows 2000 o Windows XP. Para ello, siga estos pasos:
  1. Copie el paquete de Webfldrs.msi Windows Installer que se encuentra en la carpeta \System32 C:\ WindowsFolder desde un equipo basado en Windows 2000 o desde un equipo basado en Windows XP a la carpeta \System32 C:\ WindowsFolder está en la Windows XP x 64 o equipo basado en Windows Server 2003.
  2. En el equipo basado en Windows Server 2003 o Windows XP x 64, haga clic en Inicio, haga clic en Ejecutar, escriba webfldrs.msi y, a continuación, haga clic en Aceptar.
  3. Haga clic en siguiente cuatro veces y, a continuación, haga clic en instalar.
  4. Haga clic en Aceptar para completar la instalación de webfldrs.msi.

Más información

Para obtener más información acerca de los problemas de carpetas Web que se resuelven en la actualización de software para carpetas Web fechada el 18 de mayo de 2007, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
907306Descripción de la actualización de software para carpetas Web: 18 de mayo de 2007

Propiedades

Id. de artículo: 888123 - Última revisión: martes, 05 de enero de 2010 - Versión: 8.0
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional x64 Edition
Palabras clave: 
kbmt kbtshoot kbprb KB888123 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 888123

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com