Mensaje de error "Explorer.EXE ? No se encuentra el punto de entrada - No se encuentra el punto de entrada del procedimiento %SHCreateThreadRef en la biblioteca de vínculos dinámicos Shlwapi.dll" después de instalar la actualiz...

Seleccione idioma Seleccione idioma
Id. de artículo: 888162 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

En este artículo se describe cómo recuperar un equipo que informa de un error después de aplicar la actualización de seguridad MS04-038.

Síntomas

Cuando instala la actualización de seguridad MS04-038 en Microsoft Windows XP, recibe el mensaje de error siguiente después de iniciar el equipo:
Explorer.EXE ? No se encuentra el punto de entrada - No se encuentra el punto de entrada del procedimiento %SHCreateThreadRef en la biblioteca de vínculos dinámicos SHLWAPI.dll

Causa

Este error se produce cuando se instala MS04-038 en un equipo con una instalación no realizada correctamente del Service Pack 2 (SP2) de Windows XP. Normalmente, si un instalación del SP2 de Windows XP se realiza incorrectamente, se produce automáticamente una vuelta a versiones anteriores, que devuelve el equipo a un estado de instalación anterior al SP2 de Windows XP. Si no se produce la vuelta automática a la versión anterior, el proceso de recuperación del Service Pack desinstalará parcialmente el SP2 de Windows XP después de reiniciar el equipo. (Por ejemplo, la vuelta automática a versión anterior puede no producirse si ha habido un corte de corriente durante la instalación del SP2 de Windows XP.) Después de reiniciar de nuevo el equipo, puede recibir un mensaje que le pide que use Agregar o quitar programas del Panel de control para quitar manualmente los restos de la instalación incorrecta.

Si no sigue esta recomendación, y no usa Agregar o quitar programas para quitar los restos de la instalación fallida, el equipo tendrá archivos anteriores al SP2 de Windows XP y el Registro contendrá información del SP2 de Windows XP.

Si su equipo tiene archivos anteriores al SP2 de Windows XP y su Registro contiene información del SP2 de Windows XP, Windows Update o Actualizaciones automáticas ofrece la versión del SP2 de Windows XP de la actualización de seguridad MS04-038.

Solución

Para recuperar su equipo, siga estos pasos:
  1. Inicie el equipo e inicie sesión como lo hace normalmente:

    Nota: si el equipo no se inicia correctamente, hágalo en el Modo a prueba de errores. Para obtener información adicional al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    315222 Descripción de las opciones de inicio en modo seguro en Windows XP
  2. Cuando reciba el mensaje de error, presione CTRL+MAYÚS+ESC para abrir el Administrador de tareas. Puede ignorar cualquier mensaje de error adicional que aparezca.
  3. En el menú Archivo, haga clic en Nueva tarea (Ejecutar...).
  4. En el cuadro Abrir, escriba control appwiz.cpl y haga clic en Aceptar. Puede ignorar cualquier mensaje de error adicional que aparezca.

    Nota: si la herramienta Agregar o quitar programas (Appwiz.cpl) no se abre, escriba la línea siguiente en el cuadro Nueva tarea (Ejecutar...) para quitar la revisión de Internet Explorer y vaya al paso 5:
    %windir%\$NtUninstallKB834707$\spuninst\spuninst.exe
  5. En la ventana Agregar o quitar programas, haga clic en Revisión de Windows XP ? KB834707, haga clic en Quitar y siga las instrucciones.
  6. Cuando esté disponible el botón Finalizar, haga clic en Finalizar y deje que se reinicie el equipo, incluso aunque parezca que no se ha completado el proceso de eliminación. Puede ignorar cualquier mensaje acerca de software o revisiones adicionales instalados durante este proceso.

    Advertencia: aunque el equipo se puede iniciar correctamente sin mensajes de error, sigue en un estado incompleto del SP2 de Windows XP. Debe completar los pasos restantes y reinstalar el SP2 de Windows XP.
  7. Después de reiniciar el equipo, haga clic en Inicio y, a continuación, haga clic en Panel de control.
  8. Haga clic sucesivamente en Agregar o quitar programas, Service Pack 2 de Windows XP y Quitar, y siga las instrucciones. Si recibe un mensaje acerca del software que pueda haber instalado después de la instalación del SP2 de Windows XP, tome nota de los títulos. Quizás tenga que reinstalar estos productos después de reinstalar el SP2 de Windows XP.

    Nota: si no tiene acceso a Agregar o quitar programas, use el Administrador de tareas tal como se describió en los pasos 1, 2 y 3. Quite el Service Pack 2 de Windows XP, para lo que debe escribir lo siguiente en el cuadro Nueva tarea (Ejecutar...):
    %windir%\$NtServicePackUninstall$\spuninst\spuninst.exe
  9. Después de reiniciar el equipo, visite el sitio Web Windows Update. Reinstale el Service Pack 2 de Windows XP.

    Para obtener información acerca de cómo instalar el SP2 de Windows XP, y acerca de los pasos que puede dar para asegurarse de que Windows XP se instaló correctamente, visite el siguiente sitio Web de Microsoft:
    http://technet.microsoft.com/es-es/library/bb629420.aspx
  10. Después de haber instalado correctamente el SP2 de Windows XP, visite el sitio Web Windows Update e instale todas las actualizaciones críticas.
Si este procedimiento no funciona, puede realizar una reinstalación en contexto. Para obtener información adicional al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
315341 Cómo realizar una actualización en contexto (reinstalación) de Windows XP

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a".

Más información

P1: No creo que mi equipo se encuentre en un "estado incompleto del SP2 de Windows XP". ¿Cómo puedo saberlo con seguridad?

R1:. Después de quitar correctamente la Revisión de Windows XP ? KB834707, use uno de los métodos siguientes para determinar si el equipo está en un estado incompleto del SP2 de Windows XP.

Método 1

  1. Compruebe si en Agregar o quitar programas está presente el SP2 de Windows XP. Si el SP2 de Windows XP está en la lista, vaya al paso 2. Si no está en la lista, el Service Pack 2 de Windows XP no está instalado.
  2. Determine la versión del archivo Lsass.exe que está en la carpeta %Windir%\System32. Para ello:
    1. Haga clic en Inicio y en Buscar y, después, haga clic en Todos los archivos y carpetas.
    2. En el cuadro Todo o parte del nombre de archivo, escriba %windir%\system32\lsass.exe y haga clic en Búsqueda.
    3. Haga clic con el botón secundario del mouse (ratón) en el archivo Lsass.exe, haga clic en Propiedades y, después, haga clic en la ficha Versión.

      Nota: el archivo Lsass.exe puede aparecer como "Lsass" sin extensión.
Si el número de versión del archivo Lsass.exe es anterior a 5.1.2600.2096, y el Service Pack 2 de Windows XP aparece en la herramienta Agregar o quitar programas, su equipo se encuentra en un estado incompleto del SP2 de Windows XP.

Método 2

Haga clic en Inicio y en Ejecutar, escriba winver y haga clic en Aceptar.

Si la versión aparece como "Version 5.1 (Build 2600.xpsp_sp2_rtm.040803-2158: Service Pack 2" o una versión posterior, tiene la instalación correcta del SP2 de Windows XP. Sin embargo, si la versión es un número que empieza con 01, 02 ó 03, el equipo se encuentra en un estado incompleto del SP2 de Windows XP. Además, si después de "xpsp2" aparece cualquier número inferior a 040803, como "Build 2600.xpsp2.030422-1633: Service Pack 2", el equipo se encuentra en un estado incompleto del SP2 de Windows XP.

Referencias

Para obtener información adicional acerca del SP2 de Windows XP, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389 Cómo obtener el Service Pack más reciente para Windows XP

Propiedades

Id. de artículo: 888162 - Última revisión: miércoles, 25 de septiembre de 2013 - Versión: 7.0
La información de este artículo se refiere a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Palabras clave: 
kbhotfixserver kbqfe kbtshoot KB888162

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com