文書番号: 888206 - 最終更新日: 2007年2月8日 - リビジョン: 1.4

印刷スプーラ サービスが頻繁に停止することがあって、プリント Windows 2000 ベースのサーバー サーバー上のプリンタにアクセスしようとすると、ワトソン博士のエラー メッセージを表示することがあります。

目次

すべて展開する | すべて折りたたむ

現象

Microsoft Windows 2000 ベースのプリント サーバー上のプリンタにアクセスしようとすると、印刷スプーラ サービスが頻繁に停止することがあります。 次のワトソン博士のエラー メッセージを表示することもあります。
エラーが発生したため、Spoolsv.exe を終了します。
ワトソン博士のログ ファイルには、次に類似するテキスト エントリが含まれます。
App: spoolsv.exe (pid=1992)
        When: 5/28/2002 @ 16:09:54.109
        Exception number: c0000005 (access violation)

*----> System Information <----*
        Computer Name: Name
        User Name: Name
        Number of Processors: 2
        Processor Type: x86 Family 6 Model 8 Stepping 10
        Windows 2000 Version: 5.0
        Current Build: 2195
        Service Pack: 2
        Current Type: Multiprocessor Free
        Registered Organization: Name
        Registered Owner: Name

*----> Stack Back Trace <----*

FramePtr ReturnAd Param#1  Param#2  Param#3  Param#4  Function Name
01AEE3D0 76A87106 000DCD18 017D9148 0000000F 01AEE408 tcpmon!ConfigPortUIEx 
00000FEC 00000000 00000000 00000000 00000000 00000000 tcpmon!WritePort 

1ba0000 38ff8ff2 Apr 20 16:17:06 2000 C:\WINNT\system32\XRXLM.DLL

またシステム イベント ログには、次に類似するイベント メッセージが含まれる可能性があります。

イベント ID: 7016
ソース :Service Control Manage
説明
Xerox Advanced Windows サービス サービスは、 0 から現在の無効な状態を報告しました。

イベント ID: 2510
ソース: サーバー
説明
サーバー サービスは、エラー コード 1722 をマップすることができませんでした。

イベント ID: 7031
ソース :Service Control Manage
説明
印刷スプーラ サービスは、不正に終了しました。 3 この回行いました。 次の修正操作何もアクションが 60000 のミリ秒単位で実行されません。

原因

Xerox 印刷言語モニタがこの問題はコンピュータにインストールされる場合、発生することがあります。

解決方法

この問題を解決するには、次のいずれかの手順に従います。

方法 1: レジストリ エントリをレジストリ エディタでの Xerox 言語モニタの削除します。

重要: セクションまたはメソッドまたはタスクにレジストリを変更する方法を指示する手順が含まれます。 ただし、重大な問題がレジストリを誤って変更する場合、発生することがあります。 したがって、次の手順に慎重に従うことを確認します。 変更する前に、追加された保護にレジストリのバックアップ。 問題が発生する場合、レジストリが次に復元できます。 どのようにバックアップとどのようにレジストリを復元するかについて、詳細は、サポート技術情報(Microsoft Knowledge Base)の資料を表示するために、次の文書番号をクリックします。
322756? (http://support.microsoft.com/kb/322756/ ) バックアップと Windows でレジストリの復元方法

注意:印刷言語モニタを削除する場合、プリンタはプリンタとホスト コンピュータ双方向の通信をサポートしません。 双方向のプリンタの通信にサポートを復元するために、印刷言語モニタを再インストールする必要があります。
  1. 開始をクリックし、 ファイル名を指定して実行をクリックする ファイルを開くボックスに regedit を入力して、 OK を次にクリックします。
  2. レジストリ エディタで、次のレジストリ サブキーに移動して、キーをクリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\Xerox Language Monitor
  3. 編集メニューで、レジストリ サブキーを削除するために、 Del をクリックします。
  4. 削除を確認するために、プロンプトが表示されたら、 はい(Y)をクリックします。
  5. 終了 レジストリ エディタ.
  6. コンピュータを再起動します。

方法 2: プリンタの プリンタ .inf ファイルの言語モニタ エントリを無効にします。

  1. エクスプローラを起動します。
  2. 左側のペインで、クリックします。 Drive:\Windows \inf フォルダ。

    注意:この手順で、の Drive:\Windowsは、 Windows 2000 がインストールされるフォルダのパスです。
  3. 右ペインで右クリック。 プリンタ .infファイルを開くをファイルし、次にクリックします。

    注意:この手順で、の プリンタは、プリンタの名前です。

    ならば プリンタ .inf ファイルが表示されず、次の手順に従います。
    1. ツール メニューで、 フォルダ オプションをクリックします。
    2. 表示タブをクリックし すべてのファイルとフォルダを表示するをクリックして、 OK を次にクリックします。
  4. セミコロンの()を追加します。; 次のテキストの開始エントリのうち、)
    LanguageMonitor=
    注意: セミコロンは、エントリを無効にします。
  5. プリンタ .inf ファイルを閉じて、ファイルを保存するために、 OK を次にクリックします。
  6. エクスプローラを終了します。

詳細

Windows 2000 ベースのコンピュータにプリンタ ドライバをインストールすると、言語モニタをインストールするのが選択できます。 言語モニタは、プリント サーバーとプリンタ双方向の通信を有効にします。 プリント サーバーが要求を送信するたび、プリンタの状態に関するプリント サーバーに通知するために、印刷言語モニタが使用できます。

関連情報

言語モニタについての詳細は、次のマイクロソフト Web サイトを参照してください。
http://msdn2.microsoft.com/en-us/library/ms802190.aspx (http://msdn2.microsoft.com/en-us/library/ms802190.aspx)

印刷スプーラ サービス問題の詳細については、サポート技術情報(Microsoft Knowledge Base)の資料を表示するために、次の文書番号をクリックします。
312052? (http://support.microsoft.com/kb/312052/ ) Spoolsv.exe がエラーを生成し、 Windows によって閉じられます。
303407? (http://support.microsoft.com/kb/303407/ ) Arial Unicode TrueType フォントで印刷するとき、スプーラのワトソン博士のエラー
199915? (http://support.microsoft.com/kb/199915/ ) Spoolss.exe は、ワトソン博士のログを生成します。
この資料で説明するサードパーティ製品は、 Microsoft に依存しない会社によって製造されます。 Microsoft は、これらの製品パフォーマンスまたは信頼性に関する暗黙またはさもないとの保証を何も行いません。

この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
キーワード:?
kbtshoot KB888206 KbMtja kbmt
機械翻訳機械翻訳
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。もし誤訳を発見された場合には、この KB 下部よりフィードバックをお寄せください。
英語版 KB:888206? (http://support.microsoft.com/kb/888206/en-us/ )
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"
 

サポート技術情報の翻訳

 

Related Support Centers