FIX: Some party aliases may not be created when you run the BizTalk Deployment Wizard in BizTalk Server 2004

Article translations Article translations
Article ID: 888320 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

In Microsoft BizTalk Server 2004, you run the BizTalk Deployment Wizard to import a BizTalk assembly binding file that has multiple child Alias elements specified in the PartyAlias element. When you import the file, some party aliases that are specified in the file may not be created.

CAUSE

This problem occurs because of a logic problem in the import code of the BizTalk Deployment Wizard.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have BizTalk Server 2004 Service Pack 1 (SP1) installed on your computer.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date        Time   Version     Size     File name
   -------------------------------------------------------------------------
   3-Feb-2005  14:30  3.0.6100.0  273,432  Microsoft.BizTalk.Deployment.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about party aliases, visit the following Microsoft Developer Network (MSDN) Web site:
http://msdn2.microsoft.com/en-us/library/ms943995.aspx
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 888320 - Last Review: November 15, 2007 - Revision: 2.10
APPLIES TO
  • Microsoft BizTalk Server 2004 Service Pack 1
  • Microsoft BizTalk Server 2004 Standard Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Developer Edition
Keywords: 
kbautohotfix kbbiztalk2004sp2fix kbbiztalk2004-2006swept kbbug kbfix kbprb kbhotfixserver kbqfe KB888320

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com