Chyba "Žádný aktuální záznam" při tisku nebo náhledu sestavy v Accessu

Původní číslo KB: 888635

Poznámka

Nováček: Vyžaduje znalost uživatelského rozhraní na počítačích s jedním uživatelem. Tento článek se týká databáze aplikace Microsoft Office Access (.mdb a .accdb) a projektu aplikace Microsoft Office Access (.adp).

Příznaky

Při pokusu o tisk nebo náhled sestavy pomocí příkazu Tisk nebo náhledu se v aplikaci Microsoft Access zobrazí chybová zpráva "Žádný aktuální záznam" a pak se přesunete mezi stránkami sestavy.

Příčina

K tomuto problému může dojít, pokud jsou splněny následující podmínky:

  • Sestava je seskupována do více polí.
  • V seznamu vlastností Skupiny pro jste vybrali Možnost Každá hodnota.
  • V seznamu vlastností skupiny Zápatí skupiny jste vybrali Ano.
  • V zápatí skupiny máte výpočty.

Řešení

Chcete-li tento problém vyřešit, použijte jednu z následujících metod:

  • U jedné ze skupin polí změňte vlastnost Group On na Interval .
  • U jedné ze skupin polí změňte vlastnost skupiny zápatí skupiny na Ne .
  • Odeberte výpočty ze zápatí skupiny.

Poznámka

Pokud chcete vyřešit přesnou příčinu tohoto problému, vyzkoušejte každou z těchto metod jednu po druhé, dokud se chybová zpráva nezobrazí.

Stav

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Odkazy

Další informace o tom, jak seskupit a seřadit v sestavě, získáte kliknutím na příkaz Nápověda k aplikaci Microsoft Office Access v nabídce Nápověda , do pole Hledat v podokně Pomoc zadejte změnit úrovně řazení a seskupení a potom kliknutím na Tlačítko Spustit vyhledávání zobrazte téma.