Erreur « Aucun enregistrement actif » lorsque vous imprimez ou affichez un aperçu d’un rapport dans Access

Numéro de la base de connaissances d’origine : 888635

Remarque

Novice : requiert la connaissance de lʼinterface utilisateur sur les ordinateurs mono-utilisateur. Cet article s’applique à une base de données Microsoft Office Access (.mdb et .accdb) et à un projet Microsoft Office Access (.adp).

Symptômes

Vous recevez un message d’erreur « Aucun enregistrement actif » dans Microsoft Access lorsque vous essayez d’imprimer ou d’afficher un aperçu d’un rapport à l’aide de la commande Imprimer ou Aperçu avant impression , puis vous passez d’une page à l’autre.

Cause

Ce problème peut se produire lorsque les conditions suivantes sont remplies :

  • Votre rapport est regroupé sur plusieurs champs.
  • Dans la liste des propriétés Grouper sur le groupe, vous avez sélectionné Chaque valeur.
  • Dans la liste des propriétés du groupe Pied de page de groupe, vous avez sélectionné Oui.
  • Vous avez des calculs dans le pied de page de groupe.

Solution de contournement

Pour contourner ce problème, utilisez l’une des méthodes suivantes :

  • Remplacez la propriété Group On group par Interval pour l’un des groupes de champs.
  • Remplacez la propriété group Footer group par Non pour l’un des groupes de champs.
  • Supprimez les calculs du pied de page du groupe.

Remarque

Pour résoudre la cause précise de ce problème, essayez chacune de ces méthodes une par une jusqu’à ce que vous ne receviez plus le message d’erreur.

État

Microsoft a confirmé l’existence de ce problème dans les produits Microsoft répertoriés dans la section « Produits concernés ».

References

Pour plus d’informations sur la façon de regrouper et de trier dans un rapport, cliquez sur Aide de Microsoft Office Access dans le menu Aide , tapez modifier les niveaux de tri et de regroupement dans la zone Rechercher dans le volet Assistance, puis cliquez sur Démarrer la recherche pour afficher la rubrique.