Jak používat společné rozhraní API dialogové okno v databázi aplikace Access 2003 a Access 2007

Překlady článku Překlady článku
ID článku: 888695 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

ÚVOD

Tento článek popisuje, jak použít v aplikaci Microsoft Office Access 2003 nebo Microsoft Office Access 2007 společné rozhraní API dialogové okno Nahradit funkce běžné dialogové okno, které jsou zahrnuty pouze v systému Microsoft Office 2000 Developer Edition nebo Microsoft Office XP Developer Edition.

Další informace

Společnost Microsoft poskytuje ukázky programování pouze pro ilustraci bez žádné záruky výslovně uvedené nebo předpokládané. To zahrnuje, ale není omezen pouze na předpokládaných záruk obchodovatelnosti nebo vhodnosti pro určitý účel. Tento článek předpokládá, že jste obeznámeni s programovacím jazykem, který je předmětem ukázky a s nástroji, které slouží k vytvoření a ladění skriptu. Pracovníci podpory společnosti Microsoft mohou vysvětlit funkce určitého postupu, ale nemohou tyto příklady rozšířit o další funkce nebo konstrukce podle konkrétních požadavků.

Kroky k nahrazení běžných dialogové okno funkce

Aplikace Microsoft Office Access 2003

  1. V aplikaci Access otevřete ukázkovou databázi Northwind.mdb s názvem.

    Poznámka: Databázi Northwind.mdb pro aplikaci Access 2003 je obvykle umístěn ve složce C:\Program Files\Microsoft Office\OFFICE11\Samples složky.
  2. Ve skupinovém rámečku Objekty v okně databáze Northwind klepněte na tlačítko Formuláře.
  3. V Okno databáze panel nástrojů, klepněte na tlačítko Nový.
  4. V Nový formulář Dialogové okno, klepněte na tlačítko Návrhové zobrazenía klepněte na tlačítko OK.
  5. Přidání textového pole do formuláře Form1, klepněte pravým tlačítkem myši na textové pole a klepněte na tlačítko Vlastnosti.
  6. Klepněte Všechny karta, klepněte na tlačítko Název, typ Text1a pak zavřete Vlastnosti Dialogové okno.
  7. Klepněte pravým tlačítkem myši na ovládací prvek popisek, který je spojen s Text1 textové pole, klepněte na tlačítkoVlastnostia klepněte Všechny na kartě.
  8. Klepněte na tlačítko Titulek, typ Text1a pak zavřete Vlastnosti Dialogové okno.
  9. Přidat tlačítko příkazu Formulář1, klepněte pravým tlačítkem myši příkazové tlačítko, klepněte na tlačítko Vlastnosti, klepněte na tlačítkoNázev, typ Command1, klepněte na tlačítkoTituleka potom zadejteCommand1.
  10. Klepněte Událost karta, klepněte na tlačítko [Událostní procedura] v Při klepnutí seznam a potom klepněte na tlačítko elipsy spustit Microsoft Visual Základní Editor.
  11. Upravte kód v Command1_Click postupu následující:
    Private Sub Command1_Click()
        Me!Text1 = LaunchCD(Me)
    End Sub
  12. V Vložit nabídky, klepněte na tlačítkoModula potom vložte následující kód do modul 1:
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _
    "GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As Long
    
    Private Type OPENFILENAME
        lStructSize As Long
        hwndOwner As Long
        hInstance As Long
        lpstrFilter As String
        lpstrCustomFilter As String
        nMaxCustFilter As Long
        nFilterIndex As Long
        lpstrFile As String
        nMaxFile As Long
        lpstrFileTitle As String
        nMaxFileTitle As Long
        lpstrInitialDir As String
        lpstrTitle As String
        flags As Long
        nFileOffset As Integer
        nFileExtension As Integer
        lpstrDefExt As String
        lCustData As Long
        lpfnHook As Long
        lpTemplateName As String
    End Type
    
    Function LaunchCD(strform As Form) As String
        Dim OpenFile As OPENFILENAME
        Dim lReturn As Long
        Dim sFilter As String
        OpenFile.lStructSize = Len(OpenFile)
        OpenFile.hwndOwner = strform.hwnd
        sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _
          "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)
        OpenFile.lpstrFilter = sFilter
        OpenFile.nFilterIndex = 1
        OpenFile.lpstrFile = String(257, 0)
        OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1
        OpenFile.lpstrFileTitle = OpenFile.lpstrFile
        OpenFile.nMaxFileTitle = OpenFile.nMaxFile
        OpenFile.lpstrInitialDir = "C:\"
        OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"
        OpenFile.flags = 0
        lReturn = GetOpenFileName(OpenFile)
            If lReturn = 0 Then
                MsgBox "A file was not selected!", vbInformation, _ 
                  "Select a file using the Common Dialog DLL"
             Else
                LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1)) 
             End If
    End Function
    
  13. V Ladění nabídky, klepněte na tlačítko Kompilace Northwinda pak zavřete Editor jazyka Visual Basic.
  14. V Zobrazení nabídky, klepněte na tlačítko Formulář Zobrazení.
  15. Klepněte na tlačítko Command1a klepněte na soubor v okno se otevře.

    Cesta souboru se zobrazí vText1 textové pole.

Aplikace Microsoft Office Access 2007

  1. V aplikaci Access 2007 otevřete ukázkovou databázi s názvem Northwind.accdb.
  2. V Vytvořit karta, klepněte na tlačítko Formulář v Formuláře skupina.
  3. V Formát karta, klepněte na šipku dolů Zobrazenía klepněte na tlačítko Návrhové zobrazení.
  4. Přidání textového pole do formuláře Form1, klepněte pravým tlačítkem myši na textové pole a klepněte na tlačítko Vlastnosti.
  5. Klepněte Všechny karta, klepněte na tlačítko Názeva potom zadejte Text1.
  6. Klepněte pravým tlačítkem myši na ovládací prvek popisek, který je spojen s Text1 textové pole, klepněte na tlačítkoVlastnostia klepněte Všechny na kartě.
  7. Klepněte na tlačítko Tituleka potom zadejte Text1.
  8. Přidat tlačítko příkazu Formulář1, klepněte pravým tlačítkem myši příkazové tlačítko, klepněte na tlačítko Vlastnosti, klepněte na tlačítkoNázev, typ Command1, klepněte na tlačítkoTituleka potom zadejteCommand1.
  9. Klepněte Událost karta, klepněte na tlačítko [Událostní procedura] v Při klepnutí seznam a klepněte na tlačítko (třemi tečkami...) spusťte Microsoft Visual Základní Editor.
  10. Upravte kód v Command1_Click postupu Následující příklad kódu vypadat.
    Private Sub Command1_Click()
        Me!Text1 = LaunchCD(Me)
    End Sub
  11. V Vložit nabídky, klepněte na tlačítkoModula potom vložte kód, který se podobá následující příklad kódu do modul 1.
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _
    "GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As Long
    
    Private Type OPENFILENAME
        lStructSize As Long
        hwndOwner As Long
        hInstance As Long
        lpstrFilter As String
        lpstrCustomFilter As String
        nMaxCustFilter As Long
        nFilterIndex As Long
        lpstrFile As String
        nMaxFile As Long
        lpstrFileTitle As String
        nMaxFileTitle As Long
        lpstrInitialDir As String
        lpstrTitle As String
        flags As Long
        nFileOffset As Integer
        nFileExtension As Integer
        lpstrDefExt As String
        lCustData As Long
        lpfnHook As Long
        lpTemplateName As String
    End Type
    
    Function LaunchCD(strform As Form) As String
        Dim OpenFile As OPENFILENAME
        Dim lReturn As Long
        Dim sFilter As String
        OpenFile.lStructSize = Len(OpenFile)
        OpenFile.hwndOwner = strform.hwnd
        sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _
          "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)
        OpenFile.lpstrFilter = sFilter
        OpenFile.nFilterIndex = 1
        OpenFile.lpstrFile = String(257, 0)
        OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1
        OpenFile.lpstrFileTitle = OpenFile.lpstrFile
        OpenFile.nMaxFileTitle = OpenFile.nMaxFile
        OpenFile.lpstrInitialDir = "C:\"
        OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"
        OpenFile.flags = 0
        lReturn = GetOpenFileName(OpenFile)
            If lReturn = 0 Then
                MsgBox "A file was not selected!", vbInformation, _ 
                  "Select a file using the Common Dialog DLL"
             Else
                LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1)) 
             End If
    End Function
    
  12. V Ladění nabídky, klepněte na tlačítko Kompilace Northwinda pak zavřete Editor jazyka Visual Basic.
  13. V Formát karta, klepněte na šipku dolů Zobrazenía klepněte na tlačítko Formulářové zobrazení.
  14. Klepněte na tlačítko Command1a klepněte na soubor v okno se otevře.

    Cesta souboru se zobrazí vText1 pole.

Vlastnosti

ID článku: 888695 - Poslední aktualizace: 22. května 2011 - Revize: 6.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
Klíčová slova: 
kbsampledatabase kbprogramming kbautomation kbexpertiseinter kbhowto kbmt KB888695 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:888695

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com