Come utilizzare l'API di finestra di dialogo comuni in un database in Access 2003 o Access 2007

Traduzione articoli Traduzione articoli
Identificativo articolo: 888695 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

INTRODUZIONE

In questo articolo viene descritto come utilizzare l'API di finestra di dialogo comuni pi¨ in Microsoft Office Access 2003 o in Microsoft Office Access 2007 per sostituire la funzionalitÓ di finestra di dialogo comuni che Ŕ incluso solo in Microsoft Office 2000 Developer Edition o in Microsoft Office XP Developer Edition.

Informazioni

Microsoft fornisce esempi di programmazione a scopo puramente illustrativo, senza alcuna garanzia espressa o implicita. Questo include, ma non Ŕ limitato a, le garanzie implicite di commerciabilitÓ o idoneitÓ per uno scopo specifico. Questo articolo si presuppone che conosca il linguaggio di programmazione in questione e gli strumenti utilizzati per creare ed eseguire il debug di procedure. Tecnici del supporto Microsoft possono spiegare la funzionalitÓ di una particolare procedura, ma in nessun sono caso a modificare questi esempi per fornire funzionalitÓ aggiuntive o creare procedure per soddisfare specifiche esigenze.

Procedura per sostituire la funzionalitÓ della finestra di dialogo comune

Microsoft Office Access 2003

  1. In Access, aprire il database di esempio denominato Northwind.mdb.

    Nota Il database Northwind.mdb per Access 2003 trova in genere il Office\OFFICE11\Samples di C:\Program Files\Microsoft nella cartella.
  2. Fare clic su Form nell'elenco oggetti nella finestra del database.
  3. Fare clic su Nuovo sulla barra degli strumenti finestra database .
  4. Nella finestra di dialogo Nuova maschera , fare clic su Visualizzazione struttura e scegliere OK .
  5. Aggiungere una casella di testo a Form1, fare clic con il pulsante destro del mouse sulla casella di testo e quindi scegliere ProprietÓ .
  6. Fare clic sulla scheda tutte , fare clic su Nome , digitare Testo1 e chiudere la finestra di dialogo ProprietÓ .
  7. Clic col pulsante destro del mouse sul controllo etichetta Ŕ associato la casella di testo Testo1 , fare clic su ProprietÓ , quindi scegliere la scheda tutte .
  8. Fare clic su didascalia , digitare Testo1 e chiudere la finestra di dialogo ProprietÓ .
  9. Aggiungere un pulsante di comando a Form1 , fare clic con il pulsante destro del mouse sul pulsante comando, fare clic su ProprietÓ , fare clic su nome , digitare Command1 , fare clic su didascalia e digitare Command1 .
  10. Fare clic sulla scheda evento , fare clic su [Routine evento] nell'elenco Al clic del mouse e quindi fare clic sul pulsante con i puntini di sospensione per avviare Microsoft Visual Basic Editor.
  11. Modificare il codice nella procedura Command1_Click al seguente:
    Private Sub Command1_Click()
        Me!Text1 = LaunchCD(Me)
    End Sub
  12. On the Insert menu, click Module, and then insert the following code into Module1:
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _
    "GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As Long
    
    Private Type OPENFILENAME
        lStructSize As Long
        hwndOwner As Long
        hInstance As Long
        lpstrFilter As String
        lpstrCustomFilter As String
        nMaxCustFilter As Long
        nFilterIndex As Long
        lpstrFile As String
        nMaxFile As Long
        lpstrFileTitle As String
        nMaxFileTitle As Long
        lpstrInitialDir As String
        lpstrTitle As String
        flags As Long
        nFileOffset As Integer
        nFileExtension As Integer
        lpstrDefExt As String
        lCustData As Long
        lpfnHook As Long
        lpTemplateName As String
    End Type
    
    Function LaunchCD(strform As Form) As String
        Dim OpenFile As OPENFILENAME
        Dim lReturn As Long
        Dim sFilter As String
        OpenFile.lStructSize = Len(OpenFile)
        OpenFile.hwndOwner = strform.hwnd
        sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _
          "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)
        OpenFile.lpstrFilter = sFilter
        OpenFile.nFilterIndex = 1
        OpenFile.lpstrFile = String(257, 0)
        OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1
        OpenFile.lpstrFileTitle = OpenFile.lpstrFile
        OpenFile.nMaxFileTitle = OpenFile.nMaxFile
        OpenFile.lpstrInitialDir = "C:\"
        OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"
        OpenFile.flags = 0
        lReturn = GetOpenFileName(OpenFile)
            If lReturn = 0 Then
                MsgBox "A file was not selected!", vbInformation, _ 
                  "Select a file using the Common Dialog DLL"
             Else
                LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1)) 
             End If
    End Function
    
  13. Dal menu debug scegliere Compila Northwind e chiudere l'editor di Visual Basic.
  14. Scegliere dal menu Visualizza , Form visualizza .
  15. Fare clic sul pulsante Command1 e quindi fare clic su un file nella finestra visualizzata.

    Il percorso del file verrÓ visualizzato nella casella di testo Testo1 .

Microsoft Office Access 2007

  1. In Access 2007 aprire il database di esempio denominato Northwind.accdb.
  2. Nella scheda Crea , fare clic su modulo nel gruppo +++ maschere .
  3. Nella scheda formato , fare clic sulla freccia sotto visualizzazione verso il basso e quindi scegliere Visualizzazione struttura .
  4. Aggiungere una casella di testo a Form1, fare clic con il pulsante destro del mouse sulla casella di testo e quindi scegliere ProprietÓ .
  5. Fare clic sulla scheda tutte , fare clic su Nome e quindi digitare Testo1 .
  6. Clic col pulsante destro del mouse sul controllo etichetta Ŕ associato la casella di testo Testo1 , fare clic su ProprietÓ , quindi scegliere la scheda tutte .
  7. Fare clic su didascalia e quindi digitare Testo1 .
  8. Aggiungere un pulsante di comando a Form1 , fare clic con il pulsante destro del mouse sul pulsante comando, fare clic su ProprietÓ , fare clic su nome , digitare Command1 , fare clic su didascalia e digitare Command1 .
  9. Fare clic sulla scheda evento , fare clic su [Routine evento] nell'elenco Al clic del mouse e quindi fare clic sul pulsante con i puntini di sospensione (... ) per avviare Microsoft Visual Basic Editor.
  10. Modificare il codice nella procedura Command1_Click simile a quella il seguente esempio di codice.
    Private Sub Command1_Click()
        Me!Text1 = LaunchCD(Me)
    End Sub
  11. On the Insert menu, click Module, and then insert code that resembles the following code example into Module1.
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _
    "GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As Long
    
    Private Type OPENFILENAME
        lStructSize As Long
        hwndOwner As Long
        hInstance As Long
        lpstrFilter As String
        lpstrCustomFilter As String
        nMaxCustFilter As Long
        nFilterIndex As Long
        lpstrFile As String
        nMaxFile As Long
        lpstrFileTitle As String
        nMaxFileTitle As Long
        lpstrInitialDir As String
        lpstrTitle As String
        flags As Long
        nFileOffset As Integer
        nFileExtension As Integer
        lpstrDefExt As String
        lCustData As Long
        lpfnHook As Long
        lpTemplateName As String
    End Type
    
    Function LaunchCD(strform As Form) As String
        Dim OpenFile As OPENFILENAME
        Dim lReturn As Long
        Dim sFilter As String
        OpenFile.lStructSize = Len(OpenFile)
        OpenFile.hwndOwner = strform.hwnd
        sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _
          "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)
        OpenFile.lpstrFilter = sFilter
        OpenFile.nFilterIndex = 1
        OpenFile.lpstrFile = String(257, 0)
        OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1
        OpenFile.lpstrFileTitle = OpenFile.lpstrFile
        OpenFile.nMaxFileTitle = OpenFile.nMaxFile
        OpenFile.lpstrInitialDir = "C:\"
        OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"
        OpenFile.flags = 0
        lReturn = GetOpenFileName(OpenFile)
            If lReturn = 0 Then
                MsgBox "A file was not selected!", vbInformation, _ 
                  "Select a file using the Common Dialog DLL"
             Else
                LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1)) 
             End If
    End Function
    
  12. Dal menu debug scegliere Compila Northwind e chiudere l'editor di Visual Basic.
  13. Nella scheda formato , fare clic sulla freccia sotto visualizzazione , quindi Visualizzazione del form .
  14. Fare clic sul pulsante Command1 e quindi fare clic su un file nella finestra visualizzata.

    Il percorso del file verrÓ visualizzato nella casella Text1 .

ProprietÓ

Identificativo articolo: 888695 - Ultima modifica: lunedý 4 giugno 2007 - Revisione: 4.3
Le informazioni in questo articolo si applicano a:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
Chiavi:á
kbmt kbsampledatabase kbprogramming kbautomation kbexpertiseinter kbhowto KB888695 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 888695
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com