Access 2003 또는 Access 2007 데이터베이스 공용 대화 API를 사용하는 방법

기술 자료 번역 기술 자료 번역
기술 자료: 888695 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

소개

이 문서에서는 공용 대화 상자 API Microsoft Office Access 2003 또는 Microsoft Office Access 2007 Microsoft Office 2000 Developer Edition에서 또는 Microsoft Office XP Developer Edition에 포함되어 있는 공용 대화 상자 기능을 대체할 방법을 설명합니다.

추가 정보

Microsoft는 묵시적인 보증 없이 목적으로만 프로그래밍 예제를 제공합니다. 이 포함되지만, 상품성 또는 특정 목적에의 적합성에 대한 묵시적인된 보증이 제한되지 않습니다. 이 문서에서는 만들려면 및 프로시저를 디버깅하는 데 사용되는 도구 및 여기서 설명하는 프로그래밍 언어에 익숙한 사용자를 대상으로 합니다. Microsoft 지원 엔지니어는 사용자에게 도움이 되도록 특정 절차에 대한 기능을 설명할 수 있지만 추가 기능을 제공하거나 특정 요구 사항에 맞도록 프로시저를 구성하지는 이 예제를 수정하지 않습니다.

공용 대화 상자 기능을 대체할 단계

Microsoft Office Access 2003

  1. Access에서 라는 Northwind.mdb 예제 데이터베이스를 엽니다.

    참고 Access 2003 Northwind.mdb 데이터베이스의 대개 C:\Program Files\Microsoft Office\OFFICE11\Samples 있는 폴더.
  2. 개체 에서 Northwind 데이터베이스 창에서 을 클릭하십시오.
  3. 데이터베이스 창 도구 모음에서 새로 만들기 를 클릭하십시오.
  4. 새 폼 대화 상자에서 디자인 보기 를 클릭한 다음 확인 을 누릅니다.
  5. Form1에 텍스트 상자를 추가하고 텍스트 상자를 마우스 오른쪽 단추로 클릭한 다음 속성 을 클릭하십시오.
  6. 모두 탭을, 이름텍스트1 을 입력한 속성 대화 상자를 닫습니다.
  7. 텍스트1 텍스트 상자에 연결된 레이블 컨트롤을 마우스 오른쪽 단추로, 속성 을 클릭한 다음 모두 탭을 클릭하십시오.
  8. 캡션텍스트1 을 입력한 속성 대화 상자를 닫습니다.
  9. Form1에 명령 단추를 추가하는, 명령 단추를 마우스 오른쪽 단추로, 속성 을 클릭합니다. 그리고 이름 을, Command1, 캡션 을 입력한 다음 Command1.
  10. 이벤트 탭을 클릭할 목록에서 [이벤트 프로시저] 차례로 클릭한 다음 Microsoft Visual Basic Editor 시작 줄임표 (...) 단추를 클릭하십시오.
  11. Command1_Click 프로시저에 다음 코드를 수정하여:
    Private Sub Command1_Click()
        Me!Text1 = LaunchCD(Me)
    End Sub
  12. On the Insert menu, click Module, and then insert the following code into Module1:
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _
    "GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As Long
    
    Private Type OPENFILENAME
        lStructSize As Long
        hwndOwner As Long
        hInstance As Long
        lpstrFilter As String
        lpstrCustomFilter As String
        nMaxCustFilter As Long
        nFilterIndex As Long
        lpstrFile As String
        nMaxFile As Long
        lpstrFileTitle As String
        nMaxFileTitle As Long
        lpstrInitialDir As String
        lpstrTitle As String
        flags As Long
        nFileOffset As Integer
        nFileExtension As Integer
        lpstrDefExt As String
        lCustData As Long
        lpfnHook As Long
        lpTemplateName As String
    End Type
    
    Function LaunchCD(strform As Form) As String
        Dim OpenFile As OPENFILENAME
        Dim lReturn As Long
        Dim sFilter As String
        OpenFile.lStructSize = Len(OpenFile)
        OpenFile.hwndOwner = strform.hwnd
        sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _
          "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)
        OpenFile.lpstrFilter = sFilter
        OpenFile.nFilterIndex = 1
        OpenFile.lpstrFile = String(257, 0)
        OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1
        OpenFile.lpstrFileTitle = OpenFile.lpstrFile
        OpenFile.nMaxFileTitle = OpenFile.nMaxFile
        OpenFile.lpstrInitialDir = "C:\"
        OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"
        OpenFile.flags = 0
        lReturn = GetOpenFileName(OpenFile)
            If lReturn = 0 Then
                MsgBox "A file was not selected!", vbInformation, _ 
                  "Select a file using the Common Dialog DLL"
             Else
                LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1)) 
             End If
    End Function
    
  13. 디버그 메뉴에서 컴파일 Northwind 를 클릭한 다음 VBA 편집기를 닫습니다.
  14. 보기 메뉴에서 폼 보기.
  15. Command1 를 클릭한 다음 열려 있는 창의 파일에서 클릭하십시오.

    파일의 경로를 텍스트1 텍스트 상자에 나타납니다.

Microsoft Office Access 2007

  1. Access 2007에서 Northwind.accdb 라는 예제 데이터베이스를 엽니다.
  2. 만들기 탭의 그룹에서 을 클릭하십시오.
  3. 서식 탭의 보기 아래에 있는 아래쪽 화살표를 클릭한 다음 디자인 보기 를 클릭하십시오.
  4. Form1에 텍스트 상자를 추가하고 텍스트 상자를 마우스 오른쪽 단추로 클릭한 다음 속성 을 클릭하십시오.
  5. 모두 탭을 이름 을 클릭한 다음 텍스트1 입력하십시오.
  6. 텍스트1 텍스트 상자에 연결된 레이블 컨트롤을 마우스 오른쪽 단추로, 속성 을 클릭한 다음 모두 탭을 클릭하십시오.
  7. 캡션 을 클릭한 다음 텍스트1 입력하십시오.
  8. Form1에 명령 단추를 추가하는, 명령 단추를 마우스 오른쪽 단추로, 속성 을 클릭합니다. 그리고 이름 을, Command1, 캡션 을 입력한 다음 Command1.
  9. 이벤트 탭을 클릭할 목록에서 [이벤트 프로시저] 차례로 클릭한 다음 Microsoft Visual Basic Editor 시작 줄임표 단추 (...)를 클릭하십시오.
  10. 다음 코드 예제에서는. 유사한 Command1_Click 프로시저 코드를 수정하여
    Private Sub Command1_Click()
        Me!Text1 = LaunchCD(Me)
    End Sub
  11. On the Insert menu, click Module, and then insert code that resembles the following code example into Module1.
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _
    "GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As Long
    
    Private Type OPENFILENAME
        lStructSize As Long
        hwndOwner As Long
        hInstance As Long
        lpstrFilter As String
        lpstrCustomFilter As String
        nMaxCustFilter As Long
        nFilterIndex As Long
        lpstrFile As String
        nMaxFile As Long
        lpstrFileTitle As String
        nMaxFileTitle As Long
        lpstrInitialDir As String
        lpstrTitle As String
        flags As Long
        nFileOffset As Integer
        nFileExtension As Integer
        lpstrDefExt As String
        lCustData As Long
        lpfnHook As Long
        lpTemplateName As String
    End Type
    
    Function LaunchCD(strform As Form) As String
        Dim OpenFile As OPENFILENAME
        Dim lReturn As Long
        Dim sFilter As String
        OpenFile.lStructSize = Len(OpenFile)
        OpenFile.hwndOwner = strform.hwnd
        sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _
          "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)
        OpenFile.lpstrFilter = sFilter
        OpenFile.nFilterIndex = 1
        OpenFile.lpstrFile = String(257, 0)
        OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1
        OpenFile.lpstrFileTitle = OpenFile.lpstrFile
        OpenFile.nMaxFileTitle = OpenFile.nMaxFile
        OpenFile.lpstrInitialDir = "C:\"
        OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"
        OpenFile.flags = 0
        lReturn = GetOpenFileName(OpenFile)
            If lReturn = 0 Then
                MsgBox "A file was not selected!", vbInformation, _ 
                  "Select a file using the Common Dialog DLL"
             Else
                LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1)) 
             End If
    End Function
    
  12. 디버그 메뉴에서 컴파일 Northwind 를 클릭한 다음 VBA 편집기를 닫습니다.
  13. 서식 탭의 보기, 아래의 아래쪽 화살표를 클릭한 다음 폼 보기 를 클릭하십시오.
  14. Command1 를 클릭한 다음 열려 있는 창의 파일에서 클릭하십시오.

    파일의 경로를 텍스트1 상자에 나타납니다.

속성

기술 자료: 888695 - 마지막 검토: 2007년 6월 4일 월요일 - 수정: 4.3
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
키워드:?
kbmt kbsampledatabase kbprogramming kbautomation kbexpertiseinter kbhowto KB888695 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com