Jak używać wspólnego okna dialogowego API w bazie danych w programie Access 2003 lub Access 2007

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 888695 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

WPROWADZENIE

W tym artykule opisano sposób używania wspólnego okna dialogowego API programu Microsoft Office Access 2003 lub Microsoft Office Access 2007 zamienić funkcje wspólne okno dialogowe uwzględnione tylko w pakiecie Microsoft Office 2000 Developer Edition lub Microsoft Office XP Developer Edition.

Więcej informacji

Firma Microsoft podaje przykłady programowania wyłącznie, bez jakichkolwiek gwarancji wyrażonych wprost lub domyślnie. Obejmuje, ale nie jest ograniczona do domniemanych gwarancji jakości lub przydatności do określonego celu. W tym artykule założono, że czytelnik jest obeznany z językiem programowania, przy czym obrazuje i narzędzia, które są używane do tworzenia i debugowania procedur. Wykwalifikowani pracownicy pomocy technicznej firmy Microsoft mogą pomóc w wyjaśnieniu jak działa określona procedura, ale nie będą modyfikować tych przykładów ani dodawać żadnej funkcji i konstruować nowych procedur w celu spełnienia szczególnych wymagań.

Kroki, aby zamienić funkcje wspólne okno dialogowe

Program Microsoft Office Access 2003

  1. W programie Access otwórz przykładową bazę danych, która nosi nazwę Northwind.mdb.

    Uwaga Bazy danych Northwind.mdb programu Access 2003 znajduje się w folderze C:\Program Files\Microsoft Office\OFFICE11\Samples folderu.
  2. W obszarze Obiekty Kliknij w oknie Baza danych Northwind Formularze.
  3. W Okno bazy danych pasek narzędzi, kliknij przycisk Nowy.
  4. W Nowy formularz okno dialogowe, kliknij przycisk Widok projektu, a następnie kliknij przycisk OK.
  5. Dodaj pole tekstowe do formularza Form1, kliknij prawym przyciskiem myszy pole tekstowe, a następnie kliknij przycisk Właściwości.
  6. Kliknij przycisk Wszystkie Kliknij pozycję Nazwa, wpisz Tekst1, a następnie zamknij Właściwości okno dialogowe.
  7. Kliknij prawym przyciskiem myszy formant etykiety, który jest skojarzony z Tekst1 pole tekstowe, kliknij przyciskWłaściwości, a następnie kliknij przycisk Wszystkie Karta.
  8. Kliknij przycisk Podpis, wpisz Tekst1, a następnie zamknij Właściwości okno dialogowe.
  9. Dodawanie przycisku polecenia Formularz Form1, kliknij prawym przyciskiem myszy przycisk polecenia, kliknij przycisk Właściwości, kliknij przyciskNazwa, wpisz Polecenia, kliknij przyciskPodpis, a następnie wpiszPolecenia.
  10. Kliknij przycisk Zdarzenia Kliknij pozycję [Procedura zdarzenia] w Po kliknięciu listy, a następnie kliknij przycisk wielokropka, aby uruchomić program Microsoft Visual Podstawowy edytor.
  11. Zmodyfikuj kod w procedurze Command1_Click do następujące czynności:
    Private Sub Command1_Click()
        Me!Text1 = LaunchCD(Me)
    End Sub
  12. Na Wstaw menu, kliknij przyciskModuł, a następnie wstawić następujący kod do Module1:
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _
    "GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As Long
    
    Private Type OPENFILENAME
        lStructSize As Long
        hwndOwner As Long
        hInstance As Long
        lpstrFilter As String
        lpstrCustomFilter As String
        nMaxCustFilter As Long
        nFilterIndex As Long
        lpstrFile As String
        nMaxFile As Long
        lpstrFileTitle As String
        nMaxFileTitle As Long
        lpstrInitialDir As String
        lpstrTitle As String
        flags As Long
        nFileOffset As Integer
        nFileExtension As Integer
        lpstrDefExt As String
        lCustData As Long
        lpfnHook As Long
        lpTemplateName As String
    End Type
    
    Function LaunchCD(strform As Form) As String
        Dim OpenFile As OPENFILENAME
        Dim lReturn As Long
        Dim sFilter As String
        OpenFile.lStructSize = Len(OpenFile)
        OpenFile.hwndOwner = strform.hwnd
        sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _
          "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)
        OpenFile.lpstrFilter = sFilter
        OpenFile.nFilterIndex = 1
        OpenFile.lpstrFile = String(257, 0)
        OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1
        OpenFile.lpstrFileTitle = OpenFile.lpstrFile
        OpenFile.nMaxFileTitle = OpenFile.nMaxFile
        OpenFile.lpstrInitialDir = "C:\"
        OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"
        OpenFile.flags = 0
        lReturn = GetOpenFileName(OpenFile)
            If lReturn = 0 Then
                MsgBox "A file was not selected!", vbInformation, _ 
                  "Select a file using the Common Dialog DLL"
             Else
                LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1)) 
             End If
    End Function
    
  13. Na Program Debug menu, kliknij przycisk Skompiluj Northwind, a następnie zamknij Edytor Visual Basic.
  14. Na Widok menu, kliknij przycisk Formularz Widok.
  15. Kliknij przycisk Polecenia, a następnie kliknij plik w okno zostanie otwarte.

    Ścieżka pliku pojawia się wTekst1 pole tekstowe.

Program Microsoft Office Access 2007

  1. W programie Access 2007 Otwórz przykładową bazę danych o nazwie Northwind.accdb.
  2. Na Tworzenie Kliknij pozycję Formularz w Formularze Grupa.
  3. Na Format Karta, kliknij strzałkę w dół poniżej Widok, a następnie kliknij przycisk Widok projektu.
  4. Dodaj pole tekstowe do formularza Form1, kliknij prawym przyciskiem myszy pole tekstowe, a następnie kliknij przycisk Właściwości.
  5. Kliknij przycisk Wszystkie Kliknij pozycję Nazwa, a następnie wpisz Tekst1.
  6. Kliknij prawym przyciskiem myszy formant etykiety, który jest skojarzony z Tekst1 pole tekstowe, kliknij przyciskWłaściwości, a następnie kliknij przycisk Wszystkie Karta.
  7. Kliknij przycisk Podpis, a następnie wpisz Tekst1.
  8. Dodawanie przycisku polecenia Formularz Form1, kliknij prawym przyciskiem myszy przycisk polecenia, kliknij przycisk Właściwości, kliknij przyciskNazwa, wpisz Polecenia, kliknij przyciskPodpis, a następnie wpiszPolecenia.
  9. Kliknij przycisk Zdarzenia Kliknij pozycję [Procedura zdarzenia] w Po kliknięciu listy, a następnie kliknij przycisk wielokropka (przycisk...) aby uruchomić program Microsoft Visual Podstawowy edytor.
  10. Zmodyfikuj kod w procedurze Command1_Click do podobne poniższy przykład kodu.
    Private Sub Command1_Click()
        Me!Text1 = LaunchCD(Me)
    End Sub
  11. Na Wstaw menu, kliknij przyciskModuł, a następnie wstawić kod, który jest podobny do następującego kodu źródłowego do Module1.
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _
    "GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As Long
    
    Private Type OPENFILENAME
        lStructSize As Long
        hwndOwner As Long
        hInstance As Long
        lpstrFilter As String
        lpstrCustomFilter As String
        nMaxCustFilter As Long
        nFilterIndex As Long
        lpstrFile As String
        nMaxFile As Long
        lpstrFileTitle As String
        nMaxFileTitle As Long
        lpstrInitialDir As String
        lpstrTitle As String
        flags As Long
        nFileOffset As Integer
        nFileExtension As Integer
        lpstrDefExt As String
        lCustData As Long
        lpfnHook As Long
        lpTemplateName As String
    End Type
    
    Function LaunchCD(strform As Form) As String
        Dim OpenFile As OPENFILENAME
        Dim lReturn As Long
        Dim sFilter As String
        OpenFile.lStructSize = Len(OpenFile)
        OpenFile.hwndOwner = strform.hwnd
        sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _
          "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)
        OpenFile.lpstrFilter = sFilter
        OpenFile.nFilterIndex = 1
        OpenFile.lpstrFile = String(257, 0)
        OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1
        OpenFile.lpstrFileTitle = OpenFile.lpstrFile
        OpenFile.nMaxFileTitle = OpenFile.nMaxFile
        OpenFile.lpstrInitialDir = "C:\"
        OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"
        OpenFile.flags = 0
        lReturn = GetOpenFileName(OpenFile)
            If lReturn = 0 Then
                MsgBox "A file was not selected!", vbInformation, _ 
                  "Select a file using the Common Dialog DLL"
             Else
                LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1)) 
             End If
    End Function
    
  12. Na Program Debug menu, kliknij przycisk Skompiluj Northwind, a następnie zamknij Edytor Visual Basic.
  13. Na Format Karta, kliknij strzałkę w dół poniżej Widok, a następnie kliknij przycisk Widok formularza.
  14. Kliknij przycisk Polecenia, a następnie kliknij plik w okno zostanie otwarte.

    Ścieżka pliku pojawia się wTekst1 pole.

Właściwości

Numer ID artykułu: 888695 - Ostatnia weryfikacja: 17 września 2011 - Weryfikacja: 3.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
Słowa kluczowe: 
kbsampledatabase kbprogramming kbautomation kbexpertiseinter kbhowto kbmt KB888695 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł nie został przetłumaczony przez człowieka, tylko przez oprogramowanie do tłumaczenia maszynowego firmy Microsoft. Firma Microsoft oferuje zarówno artykuły tłumaczone przez ludzi, jak i artykuły tłumaczone maszynowo, dzięki czemu każdy użytkownik może uzyskać dostęp do całej zawartości bazy wiedzy Knowledge Base we własnym języku. Prosimy jednak pamiętać, że artykuły przetłumaczone maszynowo nie zawsze są doskonałe. Mogą zawierać błędy słownictwa, składni i gramatyki, przypominające błędy robione przez osoby, dla których język użytkownika nie jest językiem ojczystym. Firma Microsoft nie odpowiada za wszelkie nieścisłości, błędy lub szkody spowodowane nieprawidłowym tłumaczeniem zawartości oraz za wykorzystanie tej zawartości przez klientów. Oprogramowanie do tłumaczenia maszynowego jest często aktualizowane przez firmę Microsoft.
Anglojęzyczna wersja tego artykułu to:888695

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com