Como usar a API de caixa de diálogo comuns em um banco de dados no Access 2003 ou no Access 2007

Traduções deste artigo Traduções deste artigo
ID do artigo: 888695 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

INTRODUÇÃO

Este artigo descreve como usar a API de caixa de diálogo comuns no Microsoft Office Access 2003 ou no Microsoft Office Access 2007 para substituir a funcionalidade de caixa de diálogo comuns que está incluída somente no Microsoft Office 2000 Developer Edition ou no Microsoft Office XP Developer.

Mais Informações

Microsoft fornece exemplos de programação apenas para ilustração, sem garantia expressa ou implícita. Isso inclui, mas não está limitado a, garantias implícitas de comercialização ou adequação para uma finalidade específica. Este artigo presume que você está familiarizados com a linguagem de programação que está sendo demonstrada e com as ferramentas que são usadas para criar e depurar procedimentos. Engenheiros de suporte podem ajudar a explicar a funcionalidade de um determinado procedimento, mas eles não modificarão esses exemplos para fornecer funcionalidades adicionais ou construir procedimentos para atender às suas necessidades.

Etapas para substituir a funcionalidade de caixa de diálogo comum

Microsoft Office Access 2003

  1. No Access, abra o banco de dados exemplo que é denominado Northwind.mdb.

    Observação O banco de dados Northwind.mdb para Access 2003 está localizado normalmente na C:\Program Files\Microsoft Office\OFFICE11\Samples pasta.
  2. Em objetos na janela banco de dados Northwind, clique em formulários .
  3. Na barra de ferramentas janela banco de dados , clique em novo .
  4. Na caixa de diálogo Novo formulário , clique em Modo de design e, em seguida, clique em OK .
  5. Adicionar uma caixa de texto para Form1, clique com o botão direito do mouse na caixa texto e, em seguida, clique em Propriedades .
  6. Clique na guia Tudo , clique em nome , digite Text1 e feche a caixa de diálogo Propriedades .
  7. Clique com o botão direito do controle de rótulo que é associado com a caixa de texto Texto1 , clique em Propriedades e, em seguida, clique na guia All .
  8. Clique em legenda , digite Text1 e feche a caixa de diálogo Propriedades .
  9. Adicionar um botão de comando para Form1 , clique com o botão direito do mouse o botão de comando, clique em Propriedades , clique em nome , digite Command1 , clique em legenda e, em seguida, digite Command1 .
  10. Clique na guia evento , clique em [Procedimento de evento] na lista Ao clicar em e em seguida, clique no botão reticências para iniciar o Editor do Microsoft Visual Basic.
  11. Modificar o código no procedimento Command1_Click à seguinte:
    Private Sub Command1_Click()
        Me!Text1 = LaunchCD(Me)
    End Sub
  12. On the Insert menu, click Module, and then insert the following code into Module1:
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _
    "GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As Long
    
    Private Type OPENFILENAME
        lStructSize As Long
        hwndOwner As Long
        hInstance As Long
        lpstrFilter As String
        lpstrCustomFilter As String
        nMaxCustFilter As Long
        nFilterIndex As Long
        lpstrFile As String
        nMaxFile As Long
        lpstrFileTitle As String
        nMaxFileTitle As Long
        lpstrInitialDir As String
        lpstrTitle As String
        flags As Long
        nFileOffset As Integer
        nFileExtension As Integer
        lpstrDefExt As String
        lCustData As Long
        lpfnHook As Long
        lpTemplateName As String
    End Type
    
    Function LaunchCD(strform As Form) As String
        Dim OpenFile As OPENFILENAME
        Dim lReturn As Long
        Dim sFilter As String
        OpenFile.lStructSize = Len(OpenFile)
        OpenFile.hwndOwner = strform.hwnd
        sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _
          "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)
        OpenFile.lpstrFilter = sFilter
        OpenFile.nFilterIndex = 1
        OpenFile.lpstrFile = String(257, 0)
        OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1
        OpenFile.lpstrFileTitle = OpenFile.lpstrFile
        OpenFile.nMaxFileTitle = OpenFile.nMaxFile
        OpenFile.lpstrInitialDir = "C:\"
        OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"
        OpenFile.flags = 0
        lReturn = GetOpenFileName(OpenFile)
            If lReturn = 0 Then
                MsgBox "A file was not selected!", vbInformation, _ 
                  "Select a file using the Common Dialog DLL"
             Else
                LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1)) 
             End If
    End Function
    
  13. No menu Debug , clique em Compilar Northwind e feche o Editor do Visual Basic.
  14. No menu Exibir , clique em formulário Exibir .
  15. Clique em Command1 e, em seguida, clique em um arquivo na janela que abre.

    O caminho do arquivo aparece na caixa de texto Texto1 .

Microsoft Office Access 2007

  1. No Access 2007, abra o banco de dados exemplo que é chamado Northwind.accdb.
  2. Na guia criar , clique em formulário no grupo de formulários .
  3. Na guia Formatar , clique na seta para baixo abaixo Exibir e, em seguida, clique em Modo de design .
  4. Adicionar uma caixa de texto para Form1, clique com o botão direito do mouse na caixa texto e, em seguida, clique em Propriedades .
  5. Clique na guia Tudo , clique em nome e digite Texto1 .
  6. Clique com o botão direito do controle de rótulo que é associado com a caixa de texto Texto1 , clique em Propriedades e, em seguida, clique na guia All .
  7. Clique em legenda e, em seguida, digite Texto1 .
  8. Adicionar um botão de comando para Form1 , clique com o botão direito do mouse o botão de comando, clique em Propriedades , clique em nome , digite Command1 , clique em legenda e, em seguida, digite Command1 .
  9. Clique na guia evento , clique em [Procedimento de evento] na lista Ao clicar e clique no botão de reticências (... ) para iniciar o Editor do Visual Basic.
  10. Modificar o código no procedimento de Command1_Click para lembrar o seguinte exemplo de código.
    Private Sub Command1_Click()
        Me!Text1 = LaunchCD(Me)
    End Sub
  11. On the Insert menu, click Module, and then insert code that resembles the following code example into Module1.
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _
    "GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As Long
    
    Private Type OPENFILENAME
        lStructSize As Long
        hwndOwner As Long
        hInstance As Long
        lpstrFilter As String
        lpstrCustomFilter As String
        nMaxCustFilter As Long
        nFilterIndex As Long
        lpstrFile As String
        nMaxFile As Long
        lpstrFileTitle As String
        nMaxFileTitle As Long
        lpstrInitialDir As String
        lpstrTitle As String
        flags As Long
        nFileOffset As Integer
        nFileExtension As Integer
        lpstrDefExt As String
        lCustData As Long
        lpfnHook As Long
        lpTemplateName As String
    End Type
    
    Function LaunchCD(strform As Form) As String
        Dim OpenFile As OPENFILENAME
        Dim lReturn As Long
        Dim sFilter As String
        OpenFile.lStructSize = Len(OpenFile)
        OpenFile.hwndOwner = strform.hwnd
        sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _
          "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)
        OpenFile.lpstrFilter = sFilter
        OpenFile.nFilterIndex = 1
        OpenFile.lpstrFile = String(257, 0)
        OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1
        OpenFile.lpstrFileTitle = OpenFile.lpstrFile
        OpenFile.nMaxFileTitle = OpenFile.nMaxFile
        OpenFile.lpstrInitialDir = "C:\"
        OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"
        OpenFile.flags = 0
        lReturn = GetOpenFileName(OpenFile)
            If lReturn = 0 Then
                MsgBox "A file was not selected!", vbInformation, _ 
                  "Select a file using the Common Dialog DLL"
             Else
                LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1)) 
             End If
    End Function
    
  12. No menu Debug , clique em Compilar Northwind e feche o Editor do Visual Basic.
  13. Na guia Formatar , clique na seta para baixo abaixo Exibir e clique em Modo formulário .
  14. Clique em Command1 e, em seguida, clique em um arquivo na janela que abre.

    O caminho do arquivo aparece na caixa Texto1 .

Propriedades

ID do artigo: 888695 - Última revisão: segunda-feira, 4 de junho de 2007 - Revisão: 4.3
A informação contida neste artigo aplica-se a:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
Palavras-chave: 
kbmt kbsampledatabase kbprogramming kbautomation kbexpertiseinter kbhowto KB888695 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 888695

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com