Bir veritabanını Access 2003 veya Access 2007'de ortak iletişim API nasıl kullanılır

Makale çevirileri Makale çevirileri
Makale numarası: 888695 - Bu makalenin geçerli olduğu ürünleri görün.
Hepsini aç | Hepsini kapa

Bu Sayfada

Giriş

Bu makalede, ortak iletişim API veya Microsoft Office Access 2007 Microsoft Office Access 2003'te, yalnızca Office 2000 Developer Edition veya Microsoft Office XP Developer Edition bulunan ortak iletişim kutusu işlevini değiştirmek için nasıl kullanılacağını açıklar.

Daha fazla bilgi

Microsoft, programlama örneklerini yalnızca gösterim amacıyla sağlar; örtülü veya açık garanti vermez. Buna satılabilirlik veya belirli bir amaca uygunluk zımni garantileri de dahildir, ancak bunlarla sınırlı değildir. Bu makale, gösterilen programlama dilini ve yordamları oluşturmak ve hata ayıklamak amacıyla kullanılan araçları kullanmayı bildiğinizi varsayar. Microsoft destek mühendisleri, belirli bir yordamın işlevselliğinin açıklanmasına yardımcı olabilir, ancak gereksinimlerinizi karşılamaya yönelik olarak ek işlevsellik sağlamak veya yordamlar geliştirmek amacıyla bu örnekleri değiştirmezler.

Ortak iletişim işlevlerini değiştirmek için gereken adımları

Microsoft Office Access 2003

  1. Access'te, Northwind.mdb adlı örnek veritabanını açın.

    Not Northwind.mdb veritabanını Access 2003 genellikle C:\Program Files\Microsoft Office\OFFICE11\Samples ' bulunan klasör.
  2. Northwind Veritabanı penceresinde nesne ' in altında Formlar ' ı tıklatın.
  3. Veritabanı penceresi araç çubuğunda, Yeni ' yi tıklatın.
  4. Yeni form iletişim kutusunda, Tasarım görünümü ' nü tıklatın ve sonra Tamam ' ı tıklatın.
  5. Form1'e bir metin kutusu ekleyin, metin kutusunu sağ tıklatın ve sonra da Properties ' i tıklatın.
  6. Tümü sekmesini tıklatın, adı tıklatın, Metin1 yazın ve sonra Özellikler iletişim kutusunu kapatın.
  7. Metin1 metin kutusuyla ilişkilendirilmiş bir etiket denetimi sağ tıklatın, Özellikler ' i tıklatın ve sonra tüm sekmesini tıklatın.
  8. Resim yazısı ' nı tıklatın, Metin1 yazın ve sonra Özellikler iletişim kutusunu kapatın.
  9. Form1 ' için bir komut düğmesi ekleyin, komut düğmesini sağ tıklatın, Özellikler ' i tıklatın, adı tıklatın, Command1 yazın, resim yazısı ' nı tıklatın ve sonra Command1 yazın.
  10. Olay sekmesini tıklatın, Tıklatınca listesinde [Olay Yordamının]'ı tıklatın ve Microsoft Visual Basic Düzenleyicisi'ni başlatmak için üç nokta düğmesini tıklatın.
  11. Aşağıdaki Command1_Click yordamın kodu değiştirin:
    Private Sub Command1_Click()
        Me!Text1 = LaunchCD(Me)
    End Sub
  12. On the Insert menu, click Module, and then insert the following code into Module1:
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _
    "GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As Long
    
    Private Type OPENFILENAME
        lStructSize As Long
        hwndOwner As Long
        hInstance As Long
        lpstrFilter As String
        lpstrCustomFilter As String
        nMaxCustFilter As Long
        nFilterIndex As Long
        lpstrFile As String
        nMaxFile As Long
        lpstrFileTitle As String
        nMaxFileTitle As Long
        lpstrInitialDir As String
        lpstrTitle As String
        flags As Long
        nFileOffset As Integer
        nFileExtension As Integer
        lpstrDefExt As String
        lCustData As Long
        lpfnHook As Long
        lpTemplateName As String
    End Type
    
    Function LaunchCD(strform As Form) As String
        Dim OpenFile As OPENFILENAME
        Dim lReturn As Long
        Dim sFilter As String
        OpenFile.lStructSize = Len(OpenFile)
        OpenFile.hwndOwner = strform.hwnd
        sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _
          "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)
        OpenFile.lpstrFilter = sFilter
        OpenFile.nFilterIndex = 1
        OpenFile.lpstrFile = String(257, 0)
        OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1
        OpenFile.lpstrFileTitle = OpenFile.lpstrFile
        OpenFile.nMaxFileTitle = OpenFile.nMaxFile
        OpenFile.lpstrInitialDir = "C:\"
        OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"
        OpenFile.flags = 0
        lReturn = GetOpenFileName(OpenFile)
            If lReturn = 0 Then
                MsgBox "A file was not selected!", vbInformation, _ 
                  "Select a file using the Common Dialog DLL"
             Else
                LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1)) 
             End If
    End Function
    
  13. Hata ayıklama) menüsünde, Northwind Derle'yi tıklatın ve sonra Visual Basic Düzenleyicisi'ni kapatın.
  14. Görünüm menüsünde Form görünümü.
  15. Command1 ' ı tıklatın ve açılan pencerede bir dosyada</a1>'ı tıklatın.

    Dosya yolunun Metin1 metin kutusunda görünür.

Microsoft Office Access 2007

  1. Access 2007'de, Northwind.accdb adlı örnek veritabanını açın.
  2. Oluştur</a0> sekmesinde, Formlar grubunda formu tıklatın.
  3. Biçim sekmesinde, Görüntüle altındaki aşağı okunu tıklatın ve sonra da Tasarım görünümü ' nü tıklatın.
  4. Form1'e bir metin kutusu ekleyin, metin kutusunu sağ tıklatın ve sonra da Properties ' i tıklatın.
  5. Tümü sekmesini tıklatın, adı tıklatın ve sonra Metin1 yazın.
  6. Metin1 metin kutusuyla ilişkilendirilmiş bir etiket denetimi sağ tıklatın, Özellikler ' i tıklatın ve sonra tüm sekmesini tıklatın.
  7. Resim yazısı ' nı tıklatın ve sonra da Metin1 yazın.
  8. Form1 ' için bir komut düğmesi ekleyin, komut düğmesini sağ tıklatın, Özellikler ' i tıklatın, adı tıklatın, Command1 yazın, resim yazısı ' nı tıklatın ve sonra Command1 yazın.
  9. Olay sekmesini tıklatın, [Olay Yordamının]'ıTıklatınca listede tıklatın ve sonra Microsoft Visual Basic Düzenleyicisi'ni başlatmak için üç nokta düğmesini (...) tıklatın.
  10. Aşağıdaki kod örneği. benzer Command1_Click yordamın kodu değiştirmek
    Private Sub Command1_Click()
        Me!Text1 = LaunchCD(Me)
    End Sub
  11. On the Insert menu, click Module, and then insert code that resembles the following code example into Module1.
    Private Declare Function GetOpenFileName Lib "comdlg32.dll" Alias _
    "GetOpenFileNameA" (pOpenfilename As OPENFILENAME) As Long
    
    Private Type OPENFILENAME
        lStructSize As Long
        hwndOwner As Long
        hInstance As Long
        lpstrFilter As String
        lpstrCustomFilter As String
        nMaxCustFilter As Long
        nFilterIndex As Long
        lpstrFile As String
        nMaxFile As Long
        lpstrFileTitle As String
        nMaxFileTitle As Long
        lpstrInitialDir As String
        lpstrTitle As String
        flags As Long
        nFileOffset As Integer
        nFileExtension As Integer
        lpstrDefExt As String
        lCustData As Long
        lpfnHook As Long
        lpTemplateName As String
    End Type
    
    Function LaunchCD(strform As Form) As String
        Dim OpenFile As OPENFILENAME
        Dim lReturn As Long
        Dim sFilter As String
        OpenFile.lStructSize = Len(OpenFile)
        OpenFile.hwndOwner = strform.hwnd
        sFilter = "All Files (*.*)" & Chr(0) & "*.*" & Chr(0) & _
          "JPEG Files (*.JPG)" & Chr(0) & "*.JPG" & Chr(0)
        OpenFile.lpstrFilter = sFilter
        OpenFile.nFilterIndex = 1
        OpenFile.lpstrFile = String(257, 0)
        OpenFile.nMaxFile = Len(OpenFile.lpstrFile) - 1
        OpenFile.lpstrFileTitle = OpenFile.lpstrFile
        OpenFile.nMaxFileTitle = OpenFile.nMaxFile
        OpenFile.lpstrInitialDir = "C:\"
        OpenFile.lpstrTitle = "Select a file using the Common Dialog DLL"
        OpenFile.flags = 0
        lReturn = GetOpenFileName(OpenFile)
            If lReturn = 0 Then
                MsgBox "A file was not selected!", vbInformation, _ 
                  "Select a file using the Common Dialog DLL"
             Else
                LaunchCD = Trim(Left(OpenFile.lpstrFile, InStr(1, OpenFile.lpstrFile, vbNullChar) - 1)) 
             End If
    End Function
    
  12. Hata ayıklama) menüsünde, Northwind Derle'yi tıklatın ve sonra Visual Basic Düzenleyicisi'ni kapatın.
  13. Biçim sekmesinde, Görüntüle altındaki aşağı okunu tıklatın ve sonra Formu görüntüle ' yi tıklatın.
  14. Command1 ' ı tıklatın ve açılan pencerede bir dosyada</a1>'ı tıklatın.

    Dosya yolunun Metin1 kutusunda görünür.

Özellikler

Makale numarası: 888695 - Last Review: 4 Haziran 2007 Pazartesi - Gözden geçirme: 4.3
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
Anahtar Kelimeler: 
kbmt kbsampledatabase kbprogramming kbautomation kbexpertiseinter kbhowto KB888695 KbMttr
Machine-translated Article
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:888695

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com