How to convert Visio drawings to CAD format in Visio 2003

Article translations Article translations
Article ID: 888700 - View products that this article applies to.
For a Microsoft Visio 2000 version of this article, see 272753.
Expand all | Collapse all

INTRODUCTION

This article describes how to convert Microsoft Visio drawings to CAD format by using the Save As command on the File menu in Microsoft Office Visio 2003. This article also contains information about some things to consider when you convert Visio drawings to CAD format.

You can use the Save As command on the File menu to convert or to export Visio drawings to CAD format. For example, if you work with engineers or with customers who have a CAD drawing program, you can create drawings in Visio 2003. Then, you can convert the drawings to CAD format when you send the drawings for review. You can convert Visio 2003 drawings to the following CAD formats:
  • AutoCAD Drawing format (.dwg file)
  • AutoCAD Interchange format (.dxf file)

MORE INFORMATION

Converting drawings works best in one direction. That is, convert a drawing from CAD format to Visio format, or convert the drawing from Visio format to CAD format. Each file format supports capabilities that are unique to its program. Therefore, to best maintain the integrity of the data in the file, convert a file only one time. For example, if you convert CAD dimension lines to Visio format, the dimension lines lose their formatting. Fonts, line styles, and fill patterns are not retained.

Visio 2003 converts only the drawing page that is currently in focus to CAD format. If you have a multi-page Visio drawing, you must convert each page separately.

To convert a Visio drawing page to CAD format, follow these steps:
  1. Start Visio 2003, and then open the drawing that you want to convert.
  2. On the File menu, click Save As.
  3. In the Save As dialog box, type a file name in the File name box, and then click one of the following CAD formats in the Save as type box:
    • AutoCAD Drawing (*.dwg)
    • AutoCAD Interchange (*.dxf)
  4. Click Save.
When you save a Visio drawing as a .dwg file or as a .dxf file, the drawing is saved with fills and hatches turned off. To turn on the fills and hatches in AutoCAD, set the FILLMODE system variable to 1, and then use the REGEN command to regenerate the drawing.

REFERENCES

For more information about how to configure settings in AutoCAD, see the documentation that is included with your AutoCAD program.

For more information about how to work with CAD drawings in Visio 2003, see Visio 2003 Help. To do this, click Microsoft Office Visio Help on the Help menu, type CAD drawings in the Search for box, and then press ENTER to view the topics that are returned.

For additional information about CAD drawings and Visio 2003, visit the following Microsoft Web site:
http://office.microsoft.com/en-us/assistance/CH010315511033.aspx
For additional information about how to troubleshoot issues when you work with CAD drawings in Visio 2003, click the following article numbers to view the articles in the Microsoft Knowledge Base:
829233 Documents are not correctly scaled when you save a Visio 2003 document as a CAD Display Object
829231 Only one CAD display object is displayed in your drawing after you save your drawing as a .dxf file in Visio 2003
829232 Cropped CAD display objects in your Visio 2003 drawing are no longer cropped after you save your drawing as a .dxf file
829725 CAD drawing objects that have fill patterns do not convert as expected in Visio 2003
827864 MBCS characters in a .dwg file are displayed as alphanumeric characters when you open the file in AutoCAD MText Editor
830251 Text is positioned incorrectly when you open an AutoCAD drawing
873426 Only objects on the foreground page appear when you save a multi-page Visio drawing as a .dwg file or as a .dxf file and then view the drawing in AutoCAD
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Properties

Article ID: 888700 - Last Review: January 28, 2005 - Revision: 1.2
APPLIES TO
  • Microsoft Office Visio Professional 2003
  • Microsoft Office Visio Standard 2003
Keywords: 
kbsavefile kbopenfile kbinfo KB888700

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com