You cannot install the SMS 2003 Advanced Client

Article translations Article translations
Article ID: 888936 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

After the Microsoft Systems Management Server (SMS) 2003 Advanced Client is installed on a computer, you may experience the following symptoms:
  • If you open the client computer's the Systems Management item in Control Panel, and then you click the Actions tab, only two actions are listed:
    • Machine Policy Retrieval & Evaluation Cycle
    • User Policy Retrieval & Evaluation Cycle o
  • On the computer where you want to install the SMS 2003 Advanced Client, the Ccmexec.log file contains information that resembles one of the following messages.

    Note The Ccmexec.log file is located in the %Windir%\System32\CCM\Logs folder.

    Message 1
    Request failed: 404 Object Not Found $$<CCMEXEC><DateTime><ThreadID>
    Message 2
    Request failed: 404 Not Found CcmExec
  • On the management point computer, the Iis.log file contains information that resembles the following.

    Note The Iis.log file is located in the %Windir%\System32\Logfiles\W3svc folder.
    DateTimeSourceIP - DestinationIPPortNumber GET /<Rejected-By-URLScan> ~/ccm_system/request 404 ccmhttp
  • On the computer where you want to install the SMS 2003 Advanced Client, the CAS.log file contains information that resembles the following.

    Note The CAS.log file is located in the %Windir%\System32\Ccm\Logs folder or the %Windir%\SMS_CCM\Logs folder.
    Software Distribution Site Settings for the client are missing from WMI. CacheConfig::InitializeFromWmi - GetSWDistSiteSettings failed with 0x80004005.
Note On a management point computer, the SMS 2003 Advanced Client log files are located in the DriveLetter:\SMS_CCM\Logs folder. On other computers, the SMS 2003 Advanced Client log files are located in the %Windir%\System32\CCM\Logs folder.

CAUSE

This issue occurs if the following conditions are true:
  • The client computer has the URLScan security tool installed.
  • An SMS 2003 Toolkit 2 URLScan template is not applied on the client computer.
  • The server that is hosting the SMS management point is also hosting Microsoft Internet Information Services (IIS).

WORKAROUND

To work around this issue, apply an SMS 2003 Toolkit 2 URLScan template to any computer that has SMS 2003 installed and that uses the URLScan security tool. To do this, obtain and then install SMS 2003 Toolkit 2.

For information about how to obtain SMS 2003 Toolkit 2, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/sms/bb676787.aspx
For information about how to apply an SMS 2003 Toolkit 2 URLScan template, see the SMS 2003 Toolkit 2 documentation that is installed with the toolkit.

MORE INFORMATION

The URLScan security tool is an Internet Server API (ISAPI) filter that restricts the types of HTTP requests that Microsoft Internet Information Services (IIS) processes. By blocking specific HTTP requests, the URLScan security tool helps prevent potentially harmful requests from reaching the server.

Apply an SMS 2003 Toolkit 2 URLScan template if the following conditions are true:
  • The computer is an SMS 2003 site system such as the following:
    • A management point
    • A Background Intelligent Transfer Service (BITS)-enabled distribution point
    • A server locator point
  • The URLScan security tool is installed on the computer.
SMS 2003 Toolkit 2 provides the following URLScan templates for computers that have SMS 2003 installed and that use the URLScan security tool:
  • URLScan 2.5 template
    This template is for SMS 2003 systems that use IIS 6.0 on Microsoft Windows Server 2003-based computers.
  • IIS Lockdown 2.1 template
    This template is for SMS 2003 systems that use IIS 5.0 on Microsoft Windows 2000 Server-based computers.

Properties

Article ID: 888936 - Last Review: November 27, 2007 - Revision: 3.2
APPLIES TO
  • Microsoft Systems Management Server 2003
Keywords: 
kbtshoot kbsmsmp kbsmsinstall kbsmsdeploy kbsmsclients kbprb KB888936

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com