You receive the "Error, a required file wkwinuni.dll could not be found" error message if Microsoft Works has been removed from the computer

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Article ID: 888948 - View products that this article applies to.
This article has been archived. It is offered "as is" and will no longer be updated.
This article may contain a link to the Windows Installer Cleanup utility (MSICUU2.exe). If you were directed to this article to solve a problem by using the Windows Installer Cleanup utility, please contact your software manufacturer for installation support on the product, or see the following Microsoft Knowledge Base article for steps to troubleshoot uninstallation issues with products that use Windows Installer:

2438651 How to troubleshoot problems that may occur when you install, uninstall, or upgrade a program on a Windows-based computer
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Symptoms

When you start your computer, you may receive the following error message:
Error, a required file wkwinuni.dll could not be found.
Additionally, you may receive one or more of the following error messages:
Ms Works caused an Invalid Page Fault in Module Wkwinuni.dll.
MS Word has Encountered an Error and Needs to Close.
Wkssb Caused an Invalid Page Fault in Module Wkwinuni.dll.

Cause

This problem may occur if Microsoft Works has been removed from the computer, but the calendar reminders shortcut is still in the Startup group. This problem may also occur if the Microsoft Works installation is damaged or corrupted.

Resolution

To resolve this problem, use one of the following methods.
Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

Remove Calendar Reminder shortcuts

  1. Click Start, point to All Programs, point to Startup, and then right-click Microsoft Works Calendar Reminders.
  2. Click Delete.

Replace the WkWinUni.dll file

  1. Insert the Works Setup CD into your CD drive or DVD drive.
  2. Open one of the following folders in Microsoft Windows Explorer:
    • For Microsoft Works 8.0 and Microsoft Works Suite 2005:
      C:\Program Files\Common Files\Microsoft Shared\Works Shared
    • For Microsoft Works 7.0 and Microsoft Works Suite 2004 and earlier versions:
      C:\Program Files\MSWorks\Common\MSShared\WkShared
  3. Delete the WkWinUni.dll file.
  4. Open the following folder on the Works CD:
    CD_Drive:\MSWorks\Common\MSShared\WkShared
  5. Right-click the WkWinUni.dll file, and then click Copy.
  6. Open one of the following folders:
    • For Microsoft Works 8.0 and Microsoft Works Suite 2005:
      C:\Program Files\Common Files\Microsoft Shared\Works Shared
    • For Microsoft Works 7.0 and Microsoft Works Suite 2004 and earlier versions:
      C:\Program Files\MSWorks\Common\MSShared\WkShared
  7. On the Edit menu, click Paste.

Reinstall Works

  1. Click Start, click Run, type appwiz.cpl, and then click OK.
  2. Locate the version of Works that is installed on your computer, and then click the entry in the Program list.
  3. Click Remove, and then follow the instructions that appear on the screen.
  4. Start Microsoft Windows in Safe Mode. To do this, follow these steps:
    1. Restart the computer.
    2. Press the F8 key. On a computer that is configured to start multiple operating systems, press F8 when the Startup menu appears.
    3. Use the arrow keys to select a Safe Mode option, and then press ENTER.
  5. Install your copy of Works from the Works Setup CD.
  6. Restart the computer.

Properties

Article ID: 888948 - Last Review: October 26, 2013 - Revision: 5.0
Applies to
  • Microsoft Works 6.0
  • Microsoft Works 7.0
  • Microsoft Works Suite 2002
  • Microsoft Works Suite 2003
  • Microsoft Works Suite 2004
  • Microsoft Works Suite 2005
  • Microsoft Works Suite 2006
Keywords: 
kbnosurvey kbarchive kbmsicuu2 kbtshoot kbprb KB888948

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