You receive the "Microsoft Works has encountered a problem and needs to close" error message when you try to start the Works Task Launcher

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Article ID: 888949 - View products that this article applies to.
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This article may contain a link to the Windows Installer Cleanup utility (MSICUU2.exe). If you were directed to this article to solve a problem by using the Windows Installer Cleanup utility, please contact your software manufacturer for installation support on the product, or see the following Microsoft Knowledge Base article for steps to troubleshoot uninstallation issues with products that use Windows Installer:

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SYMPTOMS

When you try to start the Microsoft Works Task Launcher, you may receive the following error message:
Microsoft Works has encountered a problem and needs to close.
The error signature refers to the following files:
  • Msworks.exe
  • Kernel32.dll
Additionally, the Works Task Launcher stops responding, and you must restart the computer.

CAUSE

This problem may occur if the Works Calendar (Mswkscal.wcd) database is marked as read only or if the database is corrupted.

RESOLUTION

To resolve this problem, use the following methods in the order that they appear in.

Click to clear the Read Only check box for Mswkscal.wcd

  1. Open the following folder in Microsoft Windows Explorer:
    C:\Documents and Settings\All Users\Application Data\Microsoft\Works\
  2. Right-click the Mswkscal.wcd file, and then click Properties.
  3. If the Read Only check box is selected, click to clear the Read Only check box.
  4. Try to start the Works Task Launcher.

Replace Mswkscal.wcd

  1. Insert the Works CD or the Works Suite CD 1 into your CD or DVD drive.
  2. Open the following folder in Windows Explorer:
    C:\Documents and Settings\All Users\Application Data\Microsoft\Works
  3. Rename the Mswkscal.wcd file, to Old_mswkscal.wcd.
  4. Open one of the following folders on the CD:
    • For Works 8.0:
      CD_drive:\Common\CommApp
    • For Works Suite 2005:
      CD_drive:\MSWorks\Common\CommApp
  5. Right-click the Mswkscal.wcd file, and then click Copy.
  6. Open the following folder:
    C:\Documents and Settings\All Users\Application Data\Microsoft\Works
  7. On the Edit menu, click Paste.
  8. Right-click the Mswkscal.wcd file, and then click Properties.
  9. On the General tab, click to clear the Read Only check box, and then click OK.

Remove and reinstall Works

  1. Restart Microsoft Windows in clean boot mode. There is a different clean-boot procedure for each version of Windows. Select the article that corresponds to your version of Windows from the following table, and then follow the instructions to clean-boot your computer.

    Collapse this tableExpand this table
    Operating systemArticle
    Microsoft Windows 98
    281965 How to troubleshoot using the Msconfig utility with Windows 98
    Microsoft Windows Millennium Edition (Me)
    267288 How to perform a clean boot in Windows Millennium Edition
    Microsoft Windows XP
    310353 How to perform a clean boot in Windows XP
    Microsoft Windows 2000
    281770 How to perform clean-boot troubleshooting for Windows 2000
  2. Click Start, and then click Control Panel.
  3. Double-click Add or Remove Programs.
  4. Select any version of Microsoft Works from the list of installed programs, and then click to remove it. Follow the instructions that appear on the screen to remove Works.
  5. Repeat step 4 for each version of Works that you have installed on your computer.
  6. If you receive an error message in step 4, use the appropriate Microsoft Works Cleanup utility to remove each version of Works. Use the following table to determine which utility to use.

    Collapse this tableExpand this table
    VersionOperating systemUtility
    Microsoft Works 7.0, Microsoft Works Suite 2003, Microsoft Works Suite 2005Windows 98 and Windows Millennium Edition (Me)Wks7rm.exe
    Windows 2000 and Windows XPWks7rmxp.exe
    Microsoft Works 8.0, Microsoft Works Suite 2005Windows 98 and Windows Millennium Edition (Me)Wks8rm9x.exe
    Microsoft Windows 2000 and Microsoft Windows XPWks8xp.exe
    The files are located on the Works CD or on CD1 for Works Suite in the following folder:
    CD_drive :\MSWORKS\PSS
    Note You can also obtain these files from the Microsoft Download Center. To download a file, visit the following Microsoft Web site, and then type the file name in the Keywords box:
    http://www.microsoft.com/downloads
    For example, to download the Microsoft Works 6.0 Cleanup Utility for Windows 98 and Windows Millennium Edition (Me), Search for WKS6.exe.
  7. When the Works Cleanup utility finishes restart your computer.
  8. Install the later version of Works on your computer.

Properties

Article ID: 888949 - Last Review: February 18, 2011 - Revision: 4.1
APPLIES TO
  • Microsoft Works 7.0
  • Microsoft Works Suite 2003
  • Microsoft Works Suite 2004
  • Microsoft Works Suite 2005
  • Microsoft Works Suite 2006
Keywords: 
kbmsicuu2 kbtshoot kbprb KB888949

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