Recibe mensajes de error "Parámetro no válido (0 x 80041008)" en la consola de operador de Microsoft Operations Manager

Seleccione idioma Seleccione idioma
Id. de artículo: 889054 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando utiliza Microsoft Operations Manager (MOM) 2000 o MOM 2005 para supervisar un controlador de dominio de Microsoft Windows 2000 o Microsoft Windows Server 2003 que tiene el MOM Active Directory Management Pack instalado, puede fallar la supervisión de estado de replicación de MOM. Cuando se produce este problema, el controlador de dominio basado en Windows Server 2003 devuelve un evento de error con el servidor de administración MOM y los sucesos siguientes aparecen en el panel de alertas de la consola de operaciones de MOM:
La secuencia de comandos ? AD supervisión de réplica ? encontró un error en tiempo de ejecución. No se pudo determinar si el proveedor de replicación de WMI está instalado. Devolvió el error: ? parámetro no válido ? (0 x 80041008)
Detección de topología remota de AD no puede determinar si el proveedor de replicación de WMI está instalado. Devolvió el error: ? parámetro no válido ? (0 x 80041008).

Causa

Este problema se produce cuando el archivo Replprov.dll intenta obtener acceso a un puntero que no es válido. El archivo Replprov.dll es utilizado por el paquete de administración de Active Directory de MOM para recuperar Active Directory información relativa a la replicación, incluido el estado de la replicación. Cuando se produce este problema, el archivo Replprov.dll no puede determinar el estado de replicación del controlador de dominio y se generan mensajes de error.

Solución

Información sobre hotfix de Windows Server 2003

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.

IA-64
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Oct-2004  00:15  5.2.3790.228      108,032  Replprov.dll     IA-64


x 86
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Oct-2004  23:13  5.2.3790.228       47,104  Replprov.dll      

Instrucciones de instalación de revisiones

  1. Crear una carpeta compartida en una ubicación que está disponible para los controladores de dominio de su dominio.
  2. Copia la WindowsServer2003 el archivo de revisión de-KB889054-Platform - enu.exe en la nueva carpeta compartida.
  3. Utilice una cuenta que tenga credenciales administrativas para iniciar sesión en cada controlador de dominio que tiene el MOM Active Directory Management Pack instalado.
  4. Conectarse a la carpeta compartida que contenga la revisión, haga doble clic en el WindowsServer2003 - KB889054-Platform - enu.exe revisión archivo y, a continuación, siga las instrucciones del asistente.
  5. Repita estos pasos en todos los controladores de dominio basado en Windows Server 2003 que están en su dominio y que están supervisados por MOM.

Información sobre hotfix de Windows 2000

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Jul-2005  19:04  5.2.3790.1830      56,544  Replprov.dll     
   22-Feb-2003  02:48                     14,206  Replprov.mof

Instrucciones de instalación de revisiones

  1. Crear una carpeta compartida en una ubicación que está disponible para los controladores de dominio de su dominio.
  2. Copie el archivo de revisión ReplProv.msi a la nueva carpeta compartida.
  3. Utilice una cuenta que tenga credenciales administrativas para iniciar sesión en cada controlador de dominio que tiene el MOM Active Directory Management Pack instalado.
  4. Conectarse a la carpeta compartida que contenga la revisión, doble clic en el archivo de revisión ReplProv.msi y, a continuación, siga las instrucciones del asistente.
  5. Ejecute el comando siguiente en el símbolo del sistema después de instalar el archivo de revisión ReplProv.msi:
    rundll32.exe %systemroot%\system32\replprov.dll,DoMofComp
  6. Repita estos pasos en todos los controladores de dominio basado en Windows 2000 que están en su dominio y que están supervisados por MOM.

.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 889054 - Última revisión: martes, 24 de julio de 2007 - Versión: 5.7
La información de este artículo se refiere a:
  • Microsoft Operations Manager 2000 Enterprise Edition sobre las siguientes plataformas
    • Microsoft Windows 2000 Server
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Operations Manager 2005 Enterprise Edition sobre las siguientes plataformas
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Server
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Palabras clave: 
kbmt kbautohotfix kbqfe kbhotfixserver kbwinserv2003presp1fix kbbug kbfix KB889054 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 889054

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com