Update: Sie können ein System Sperren auftreten, wenn Sie versuchen zum Abbrechen einer COM+-Methode mit die CoCancelCall-Methode, während eine COM+-Objekt, das die CoCreateInstanceEx-Methode verwendet, die in Windows XP Professional instanziiert wird

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Problembeschreibung

Stellen Sie sich das folgende Szenario vor. In Windows XP Professional ist ein Microsoft COM+-Objekt, das die CoCreateInstanceEX -Funktion verwendet, in eine COM+-Anwendung instanziiert. Wenn Sie versuchen, eine COM+-Methode mithilfe der Funktion CoCancelCall abzubrechen, können Sie System fixieren-ähnliche Symptome auftreten.

Hinweis: Dieses Problem tritt nach dem Neustart der Serverseite der COM+-Anwendung.

Ursache

Dieses Problem tritt das Vorhandensein eine Racebedingung zwischen den folgenden:
  • Der End-Aufruf, der auf dem Server verweist
  • Der Server, der die Antwort sendet
Daher tritt ein schwerer Fehler in der DCOM auf. Dieser schwerwiegende Fehler bewirkt, dass der Computer reagiert.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Microsoft Windows XP Service Pack 2 (SP2)

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools ? Datum und Uhrzeit in der Systemsteuerung.
   Date         Time   Version        Size       File name
   --------------------------------------------------------
   24-Mar-2005  21:14  5.1.2600.2621  1,241,088  Ole32.dll        
   24-Mar-2005  21:11  5.1.2600.2621    555,520  Rpcrt4.dll       
   24-Mar-2005  21:14  5.1.2600.2621    256,000  Rpcss.dll

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Die folgende Sequenz von Ereignissen tritt zwischen dem Client und Server:
  1. COM+-Anwendung-Client eine Verbindung herstellt, der Remote Procedure Call Service (RPCSS) und sendet dann eine Anforderung.
  2. Der RPCSS startet die Verarbeitung der Anforderung.
  3. Der Client-Anwendung ruft die RpcAsyncCancelCa -Funktion zum Abbrechen einer COM+-Methode. Die folgende Kommunikation findet zwischen dem COM+-Anwendung-Client und der COM+-Anwendung-Server:
    1. Der RPCSS sendet eine Abbrechen-Anforderung mit dem Anwendungsserver mithilfe der Funktion NtRequestPort . Diese Funktion wartet nicht auf eine Antwort zurückzukehren.
    2. Der Application Server kennzeichnet den Aufruf der RpcAsyncCancelCa -Funktion als Abbrechen ausstehende.
    3. Der Application Server schlägt der Aufruf der RpcAsyncCancelCa -Funktion fehl. Anschließend benachrichtigt die Anwendung dem OLE-Prozess, dass der Aufruf abgeschlossen ist.
    4. Die Anwendung Client Ruft die Funktionen I_RpcReceive und I_RpcFreeBuffer . Dieses Verhalten bewirkt, dass den Aufruf der Funktion RpcAsyncCancelCa bereinigt werden und die Client-Zuordnung entfernt.
  4. Der Application Server sendet eine Antwort an den Client.
  5. Der Client empfängt die Antwort. Dann lehnt er die Antwort mit Fehler 1727 (RPC_S_CALL_FAILED_DNE) ab, da es diesem Aufruf der RpcAsyncCancelCa -Funktion nicht mehr bekannt.
  6. Der Application Server erhält die Fehlermeldung und schließt dann den Anschluss Local Procedure Call (LPC).
  7. Der Client-Anwendung bemerkt LPC-Port wird geschlossen, und der Client bereinigt die Zuordnung. Diese Schritt ist, wenn der Kontext Rundown auftritt.
Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 889178 - Geändert am: Mittwoch, 29. August 2007 - Version: 2.2
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Professional
Keywords: 
kbmt kbautohotfix kbrpc kbbug kbfix kbhotfixserver kbqfe KB889178 KbMtde
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 889178
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