管理者の権限を持たないユーザーがリモート コンピュータから TSShutdn.exe コマンドを使用して Windows XP Service Pack 1 ベースのコンピュータをシャットダウンできる

文書翻訳 文書翻訳
文書番号: 889323 - 対象製品
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

目次

現象

管理者の権限を持たないユーザーが、リモート コンピュータから TSShutdn.exe コマンドを使用して Microsoft Windows XP Service Pack 1 (SP1) ベースのコンピュータをシャットダウンすることができます。

原因

この問題は、ユーザー権利 "リモート コンピュータからの強制シャットダウン" がリモート デスクトップによってチェックされないことが原因で発生します。

解決方法

Service Pack の情報

この問題を解決するには、Microsoft Windows XP の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
322389 最新の Windows XP Service Pack を入手する方法

修正プログラムの情報

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを行う場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次の Windows XP Service Pack がリリースされるまで待つことを推奨します。

この問題を解決するには、Microsoft Product Support Services にお問い合わせのうえ、修正プログラムを入手してください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/contactus/
: Microsoft Support 担当者が、特定の更新プログラムを適用することにより問題が解決されると判断した場合、まれに通常サポート依頼にかかる料金が免除されることがあります。ただし、特定の更新プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。

必要条件

Windows XP SP1

再起動の必要性

この修正プログラムの適用後、コンピュータを再起動する必要があります。

修正プログラムの置き換えに関する情報

この修正プログラムを適用しても、他の修正プログラムが置き換えられることはありません。

ファイル情報

修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。 Windows XP (32 ビット版)
   日付            時刻     バージョン          サイズ     ファイル名
   --------------------------------------------------------------
   16-Mar-2005  17:36  5.1.2600.1646      32,768  Cfgbkend.dll     
   16-Mar-2005  17:36  5.1.2600.1646      30,720  Pchsvc.dll       
   16-Mar-2005  17:36  5.1.2600.1646      39,424  Racpldlg.dll     
   16-Mar-2005  17:36  5.1.2600.1646      44,544  Regapi.dll       
   16-Mar-2005  17:36  5.1.2600.1646      41,472  Safrslv.dll      
   16-Mar-2005  01:44  5.1.2600.1646     130,560  Sessmgr.exe      
   16-Mar-2005  17:36  5.1.2600.1646     200,192  Termsrv.dll      
   16-Mar-2005  17:36  5.1.2600.1646      88,064  Tscfgwmi.dll     
   16-Mar-2005  01:46  5.1.2600.1646     594,432  Xpsp2res.dll     
   25-Feb-2005  03:53  6.1.22.4          371,936  Updspapi.dll     
Windows XP (64 ビット版)
   日付            時刻    バージョン           サイズ    ファイル名    プラットフォーム
   ----------------------------------------------------------------------
   16-Mar-2005  16:33  5.1.2600.1646     104,448  Cfgbkend.dll   IA-64
   16-Mar-2005  16:33  5.1.2600.1646     110,592  Pchsvc.dll     IA-64
   16-Mar-2005  16:33  5.1.2600.1646     106,496  Racpldlg.dll   IA-64
   16-Mar-2005  16:33  5.1.2600.1646     127,488  Regapi.dll     IA-64
   16-Mar-2005  16:33  5.1.2600.1646     111,616  Safrslv.dll    IA-64
   16-Mar-2005  00:58  5.1.2600.1646     423,424  Sessmgr.exe    IA-64
   16-Mar-2005  16:33  5.1.2600.1646     622,592  Termsrv.dll    IA-64
   16-Mar-2005  16:33  5.1.2600.1646     326,144  Tscfgwmi.dll   IA-64
   16-Mar-2005  01:06  5.1.2600.1646     593,920  Xpsp2res.dll   IA-64
   16-Mar-2005  16:36  5.1.2600.1646      44,544  Wregapi.dll    X86
   16-Mar-2005  00:46  5.1.2600.1646     594,432  Wxpsp2res.dll  X86
   25-Feb-2005  02:50  6.1.22.4          639,712  Updspapi.dll  IA-64

重要 : この問題は、Microsoft Windows XP Service Pack 2 (SP2) で修正済みです。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
824684 マイクロソフトのソフトウェアの更新で使用される一般的な用語の説明

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 889323 (最終更新日 2005-04-05) を基に作成したものです。

プロパティ

文書番号: 889323 - 最終更新日: 2006年8月2日 - リビジョン: 3.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
キーワード:?
kbbug kbfix kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver KB889323
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com