V případě, že vás v počítači se systémem Windows XP Service Pack 2 přesměruje web na jinou webovou stránku, může se zobrazit chybová zpráva o odepření přístupu (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Překlady článku Překlady článku
ID článku: 889386 - Produkty, které se vztahují k tomuto článku.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem obnovení registru v případě, že nastane problém. Další informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Procházení webu pomocí aplikace Microsoft Internet Explorer v počítači se systémem Windows XP Service Pack 2 (SP2) se může zobrazit chybová zpráva "přístup odepřen". Chybová zpráva může dojít, pokud webový server přesměruje na webovou stránku obsahující skript, který přistupuje k document.all kolekce.

Příčina

Tento problém může nastat, protože pokud kód skriptu přistupuje k kolekce document.all po přesměrovat skriptu na straně klienta, dojde ke ztrátě kontextu dřívější document.all kolekce.

Řešení

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
   Date         Time   Version         Size       File name
   ---------------------------------------------------------
   07-Dec-2004  20:21  6.00.2900.2577  3,006,976  Mshtml.dll

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

Upozornění Při nesprávných úpravách registru pomocí Editoru registru nebo jiným způsobem může dojít k vážným problémům. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nezaručuje, že tyto problémy bude možné vyřešit. Úpravy registru provádíte na vlastní nebezpečí.

Tato chybová zpráva pouze pokud počítač se systémem Windows XP SP2. Po použití této opravy hotfix restartujte počítač a potom postupujte takto.

Poznámka: Tato oprava hotfix je zahrnuta v MS05-038 kumulativní aktualizace aplikace Internet Explorer. Následující kroky nastavit hodnotu klíče registru nejsou požadována při MS05-038 nainstalována v počítači povolit tuto opravu hotfix.
  1. Ukončete aplikaci Internet Explorer.
  2. Klepněte na tlačítko Start, klepněte na příkaz Spustit, do pole Otevřít zadejte příkaz regedit a klepněte na tlačítko OK.
  3. Vyhledejte následující klíč registru a klepněte na něj:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main
  4. Vytvořit nový klíč s názvem FeatureControl klíči uvedeny v kroku 3.
  5. Vytvořit nový klíč s názvem FEATURE_REDIRECT_COLLECTIONCACHE_KB889386 pod klíčem je uveden v kroku 4.
  6. Vyberte klíč
    FEATURE_REDIRECT_COLLECTIONCACHE_KB889386
    .
  7. V nabídce Úpravy přejděte na příkaz Nový a klepněte na příkaz Hodnota DWORD.
  8. Zadejte iexplore.exe a stiskněte klávesu ENTER.
  9. Klepněte pravým tlačítkem myši iexplore.exe a potom klepněte na příkaz změnit.
  10. V poli údaj hodnoty zadejte 00000001 a potom klepněte na tlačítko OK.
  11. V nabídce soubor klepněte na příkaz Konec.

Odkazy

Další informace o ukládání do mezipaměti objektu Internet Explorer naleznete na následujícím webu:
http://technet.microsoft.com/en-us/library/bb457150.aspx

Vlastnosti

ID článku: 889386 - Poslední aktualizace: 29. srpna 2007 - Revize: 7.1
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
Klíčová slova: 
kbmt kbautohotfix kbinetdev kbqfe kbfix kbbug kbhotfixserver KB889386 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:889386

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com