Puede recibir un mensaje de error "acceso denegado" cuando un sitio Web le redirige a otra página Web en un equipo que está ejecutando Windows XP Service Pack 2

Seleccione idioma Seleccione idioma
Id. de artículo: 889386 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Compruebe que ha hecho una copia de seguridad del Registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando explora un sitio Web utilizando Microsoft Internet Explorer en un equipo que está ejecutando Microsoft Windows XP Service Pack 2 (SP2), puede recibir un mensaje de error "acceso denegado". El mensaje de error puede producirse cuando un sitio Web le redirige a una página Web que contiene la secuencia de comandos que tiene acceso a la colección document.all .

Causa

Este problema puede producirse porque, cuando el código de secuencia de comandos tiene acceso a la colección document.all después de redirigir la secuencia de comandos de cliente, se pierde el contexto de la colección document.all anterior.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version         Size       File name
   ---------------------------------------------------------
   07-Dec-2004  20:21  6.00.2900.2577  3,006,976  Mshtml.dll

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Recibirá este mensaje de error sólo si el equipo se está ejecutando Windows XP SP2. Después de aplicar este hotfix, reinicie el equipo y, a continuación, siga estos pasos.

Nota Esta revisión se incluye en MS05-038 actualización acumulativa de Internet Explorer. Los pasos siguientes para establecer el valor de clave del registro no son necesarios habilitar esta revisión cuando MS05-038 está instalado en el equipo.
  1. Salga de Internet Explorer.
  2. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit en el cuadro Abrir y, a continuación, haga clic en Aceptar .
  3. Busque la siguiente clave del Registro y haga clic en ella:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main
  4. Crear una nueva clave que se denomina FeatureControl bajo la clave que aparece en el paso 3.
  5. Crear una nueva clave que se denomina FEATURE_REDIRECT_COLLECTIONCACHE_KB889386 bajo la clave que aparece en el paso 4.
  6. Seleccione la clave
    FEATURE_REDIRECT_COLLECTIONCACHE_KB889386
    .
  7. En el menú Edición , seleccione nuevo y, a continuación, haga clic en valor DWORD .
  8. Escriba iexplore.exe y, a continuación, presione ENTRAR.
  9. Haga clic con el botón secundario del mouse en iexplore.exe y, a continuación, haga clic en Modificar .
  10. En el cuadro de datos de valor , escriba 00000001 y, a continuación, haga clic en Aceptar .
  11. En el menú archivo , haga clic en Salir .

Referencias

Para obtener más información acerca de la caché de objeto de Internet Explorer, visite el siguiente sitio Web:
http://technet.microsoft.com/en-us/library/bb457150.aspx

Propiedades

Id. de artículo: 889386 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 7.1
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
Palabras clave: 
kbmt kbautohotfix kbinetdev kbqfe kbfix kbbug kbhotfixserver KB889386 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 889386

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com