Windows XP Service Pack 2 を実行しているコンピュータで、Web サイトから別の Web ページにリダイレクトされるときに "アクセスが拒否されました" というエラー メッセージが表示されることがある

文書翻訳 文書翻訳
文書番号: 889386 - 対象製品
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

目次

現象

Microsoft Windows XP Service Pack 2 (SP2) を実行しているコンピュータで、Microsoft Internet Explorer を使用して Web サイトを参照すると、"アクセスが拒否されました" というエラー メッセージが表示されることがあります。このエラー メッセージは、Web サイトから、document.all コレクションにアクセスするスクリプトが含まれている Web ページにリダイレクトされるときに発生することがあります。

原因

この問題は、クライアント側のスクリプトによりリダイレクトされた後、スクリプト コードが document.all コレクションにアクセスするときに以前の document.all コレクションのコンテキストが失われているために発生することがあります。

解決方法

修正プログラムの情報

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを行う場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次の Service Pack がリリースされるまで待つことを推奨します。

この問題を解決するには、Microsoft Online Customer Services にオンライン リクエストを送信し、修正プログラムを入手します。オンライン リクエストを送信して修正プログラムを入手するには、次のマイクロソフト Web ページを参照してください。
http://go.microsoft.com/?linkid=6294451
: 別の問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストを作成することが必要になる場合があります。特定の修正プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。別のサービス リクエストを作成するには、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/contactus/?ws=support

ファイル情報

   日付           時刻    バージョン        サイズ      ファイル名

   ------------------------------------------------------------
   2004/12/08  05:21  6.0.2900.2577  3,005,440  mshtml.dll      

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

警告 : レジストリ エディタまたは別の方法を使用してレジストリを誤って変更すると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリの変更により発生した問題に関しては、一切責任を負わないものとします。レジストリの変更は、自己の責任において行ってください。

このエラー メッセージは、コンピュータで Windows XP SP2 が実行されている場合にのみ表示されます。この修正プログラムを適用した後、コンピュータを再起動し、次の手順を実行します。

: この修正プログラムは、Internet Explorer の累積的な更新プログラム (MS05-038) に含まれています。MS05-038 がコンピュータにインストールされている場合は、次の手順を実行してレジストリ キーの値を設定して、この修正プログラムを有効にする必要はありません。
  1. Internet Explorer を終了します。
  2. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに regedit と入力し、[OK] をクリックします。
  3. 次のレジストリ キーを見つけてクリックします。
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main
  4. 手順 3. に記載されているキーの下に FeatureControl という名前の新しいキーを作成します。
  5. 手順 4. に記載されているキーの下に FEATURE_REDIRECT_COLLECTIONCACHE_KB889386 という名前の新しいキーを作成します。
  6. FEATURE_REDIRECT_COLLECTIONCACHE_KB889386
    キーを選択します。
  7. [編集] メニューの [新規] をポイントし、[DWORD 値] をクリックします。
  8. iexplore.exe と入力し、Enter キーを押します。
  9. [iexplore.exe] を右クリックし、[修正] をクリックします。
  10. [値のデータ] ボックスに 00000001 と入力し、[OK] をクリックします。
  11. [ファイル] メニューの [レジストリ エディタの終了] をクリックします。

関連情報

Internet Explorer のオブジェクト キャッシングの詳細については、以下のマイクロソフト Web サイトを参照してください。
http://www.microsoft.com/japan/technet/prodtechnol/winxppro/maintain/sp2brows.mspx#EFAA

プロパティ

文書番号: 889386 - 最終更新日: 2007年9月14日 - リビジョン: 7.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
キーワード:?
kbbug kbfix kbinetdev kbqfe kbhotfixserver KB889386
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com