Vous recevez un message d'erreur « Accès refusé » lorsque vous ouvrez une page Web qui exécute un script dans un jeu de cadres dans Internet Explorer 6

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Numéro d'article: 889407 - Voir les produits auxquels s'applique cet article
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Sommaire

Symptômes

Vous ouvrez une page Web qui contient un jeu de cadres dans Microsoft Internet Explorer 6. Si un script s'exécute dans le cadre de gauche du jeu de cadres, vous recevez le message d'erreur suivantes :
Problèmes liés à cette page Web peuvent empêcher pas s'afficher correctement ou fonctionne correctement. À l'avenir, vous pouvez afficher ce message en double-cliquant sur l'icône d'avertissement affiché dans la barre d'état.

Ligne: 6
CHAR: 2
Erreur : accès refusé.
Code: 0
URL : http:// URLpath /frameset.html

Cause

Ce problème se produit lorsque les conditions suivantes sont remplies :
  • La propriété de domaine est explicitement définie dans un script inter-cadres. Par exemple, la propriété de domaine est Microsoft.com.
  • Une des opérations suivantes est remplie :
    • Vous avoir Microsoft Windows XP Service Pack 2 (SP2) installé.
    • Vous possédez Internet Explorer 6 Service Pack 1 (SP1) installé, et que vous installez la mise à jour de sécurité cumulative pour Internet Explorer (MS04-025).

      Pour plus d'informations sur la mise à jour de sécurité cumulative pour Internet Explorer, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
      867801 MS04-025 : mise à jour de sécurité cumulative pour Internet Explorer

Résolution

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Conditions préalables

Windows XP SP2 pour appliquer ce correctif doit être.

Redémarrez les informations

Vous devez redémarrer votre ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement de correctif

Ce correctif est n'remplacé par aucun correctif ultérieur.

Informations de Registre

important Cette section, la méthode ou la tâche, contient des étapes qui vous indiquent comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si modification incorrecte du Registre. Par conséquent, assurez-vous que ces étapes avec soin. Pour la protection supplémentaire, sauvegarder le Registre avant de le modifier. Ensuite, vous pouvez restaurer le Registre si un problème se produit. Pour plus d'informations sur la façon sauvegarder et restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756 Comment faire pour sauvegarder et restaurer le Registre dans Windows


Pour activer ce correctif, procédez comme suit :
  1. Quittez Internet Explorer 6.
  2. Cliquez sur Démarrer , cliquez sur Exécuter , tapez regedit et cliquez sur OK .
  3. Recherchez et cliquez dessus pour sélectionner la sous-clé de Registre suivante :
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
  4. Dans le menu Edition , pointez sur Nouveau , puis cliquez sur clé .
  5. Tapez FEATURE_DOC_WRITE_DOMAIN_KB886184 et puis appuyez sur ENTRÉE.
  6. Avec la sous-clé
    FEATURE_DOC_WRITE_DOMAIN_KB886184
    sélectionnée, dans le menu Edition , pointez sur Nouveau , puis cliquez sur valeur DWORD .
  7. Tapez iexplore.exe , puis appuyez sur ENTRÉE.
  8. Cliquez avec le bouton droit sur Iexplore.exe , puis cliquez sur Modifier .
  9. Dans la zone données de la valeur , tapez 1 et puis cliquez sur OK .
  10. Dans le menu Fichier , cliquez sur Quitter pour quitter l'Éditeur du Registre.

Informations sur le fichier de correctif

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'outil Date et heure du Panneau de configuration.
   Date         Time   Version         Size       File name
   ---------------------------------------------------------
   10-Feb-2005  17:19  6.00.2900.2608  3,008,000  Mshtml.dll 
				

Statut

Microsoft a confirmé que c'est un problème dans la version d'Internet Explorer 6 qui est inclus dans Microsoft Windows XP SP2.

Plus d'informations

Pour plus d'informations sur la propriété de domaine , reportez-vous au site de Web Microsoft suivant :
http://msdn2.microsoft.com/en-us/library/ms533740.aspx

Propriétés

Numéro d'article: 889407 - Dernière mise à jour: mercredi 29 août 2007 - Version: 3.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
Mots-clés : 
kbmt kbautohotfix kbfix kbwinxppresp3fix kbqfe kbbug kbhotfixserver KB889407 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 889407
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