Comment faire pour gérer les modèles Office 2003 dans les programmes Office 2003

Traductions disponibles Traductions disponibles
Numéro d'article: 889495 - Voir les produits auxquels s'applique cet article
Pour vous procurer une version Microsoft Office XP de cet article, consultez l'article 290232.
Important Cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
256986 Description du Registre de Microsoft Windows
Agrandir tout | Réduire tout

Sommaire

INTRODUCTION

Cet article décrit les problèmes Microsoft Office 2003 suivants :
  • Emplacement des modèles qui figurent dans Office 2003.
  • Comment la boîte de dialogue Modèles affiche les modèles disponibles.
  • Paramètres du Registre qui contrôlent où rechercher vos modèles personnalisés.

Plus d'informations

Office 2003 enregistre tous les nouveaux fichiers de modèles personnalisés que vous créez dans les programmes Office 2003 dans un même emplacement.

Il existe quatre catégories de modèle dans Office 2003. Lorsque vous cliquez sur Sur mon ordinateur dans le volet Nouvelle tâche, le programme Office 2003 que vous utilisez recherche aux emplacements suivants les modèles qui appartiennent à ce programme :
  • emplacement des fichiers des modèles utilisateur ;
  • emplacement des fichiers des modèles de groupe de travail ;
  • emplacement des fichiers des modèles publiés et installés ;
  • emplacement des fichiers des modèles non basés sur des fichiers.

Emplacement des fichiers des modèles utilisateur

Les modèles nouvellement créés ou modifiés sont enregistrés dans un dossier dans votre répertoire de profil. Les dossiers qui figurent sous votre profil contiennent vos options et préférences de configuration. Tout ce qui doit vous suivre est stocké dans ces répertoires et fait partie de votre profil.

Par défaut, les fichiers modèles utilisateur sont stockés à l'emplacement suivant :
C:\Documents and Settings\nom_utilisateur\Application Data\Microsoft\Templates
Remarque Vous pouvez modifier l'emplacement des fichiers modèles utilisateur.

Procédure pour modifier l'emplacement des modèles

Vous pouvez utiliser Microsoft Office Word 2003 pour modifier l'emplacement d'enregistrement de vos nouveaux modèles. Pour cela, procédez comme suit.

Remarque Si vous utilisez Word 2003 pour modifier l'emplacement dans lequel vos nouveaux modèles sont enregistrés, vous devez également modifier l'emplacement d'enregistrement de tous les modèles des programmes Office 2003.
  1. Démarrez Word 2003.
  2. Dans le menu Outils, cliquez sur Options.
  3. Sous l'onglet Emplacement des fichiers, cliquez sur Modèles de l'utilisateur, puis sur Modifier.
  4. Dans la boîte de dialogue Changer de dossier, modifiez le paramètre de la zone Nom de dossier ou de la liste Regarder dans de façon à ce qu'elle contienne le dossier dans lequel vous souhaitez enregistrer vos nouveaux modèles, puis cliquez sur OK.
  5. Cliquez sur OK ou sur Fermer pour fermer la boîte de dialogue Options.
Le chemin d'accès modifié est noté dans le Registre Windows et sera utilisé la prochaine fois que vous enregistrerez un nouveau modèle. Pour plus d'informations, reportez-vous à la section « Modifications des paramètres du Registre Windows pour les modèles de l'utilisateur et de groupe de travail » plus loin dans cet article.

Remarque Un administrateur réseau peut modifier l'emplacement dans lequel vos nouveaux modèles sont enregistrés à l'aide des modèles de stratégie compris dans le Kit de ressources de Microsoft Office 2003. Pour plus d'informations, contactez votre administrateur réseau.

Vous pouvez également créer des onglets personnalisés qui apparaissent dans la boîte de dialogue Modèles en créant un nouveau dossier dans le dossier Modèles de votre profil. Les onglets portant le même nom que votre nouveau dossier apparaissent dans la boîte de dialogue Modèles. Ces onglets vous permettent de catégoriser encore davantage vos nouveaux modèles.

Pour afficher la boîte de dialogue Modèles, utilisez l'une des méthodes suivantes selon le programme Office 2003 que vous utilisez :
  • Dans Microsoft Office Access 2003, cliquez sur Nouveau dans le menu Fichier, puis cliquez sur Sur mon ordinateur dans le volet Office Nouveau fichier.
  • Dans Microsoft Office Excel 2003, cliquez sur Nouveau dans le menu Fichier, puis cliquez sur Sur mon ordinateur dans le volet Office Nouveau classeur.
  • Dans Microsoft Office FrontPage 2003, cliquez sur Nouveau dans le menu Fichier, puis cliquez sur Autres modèles de pages ou sur Autres modèles de site Web.
  • Dans Microsoft Office PowerPoint 2003, cliquez sur Nouveau dans le menu Fichier, puis sur Sur mon ordinateur dans le volet Office Nouvelle présentation.
  • Dans Microsoft Office Publisher 2003, cliquez sur Nouveau dans le menu Fichier, puis sur Modèles dans le volet Office Nouvelle publication.

    Remarque Il n'y a pas de boîte de dialogue Modèles dans Publisher 2003. À la place, votre nouveau dossier modèle personnalisé apparaîtra sous Modèles dans le volet Office Nouvelle publication.
  • Dans Word 2003, cliquez Nouveau dans le menu Fichier, puis sur Sur mon ordinateur dans le volet Office Nouveau document.

Emplacement des fichiers des modèles de groupe de travail

Les modèles enregistrés à cet emplacement sont les mêmes que ceux enregistrés dans Modèles de l'utilisateur, à la seule différence que l'emplacement est généralement un dossier partagé sur un lecteur réseau. Par défaut, l'emplacement du fichier de modèles de groupe de travail n'est pas défini sur un dossier spécifique et est vide.

Remarque Votre administrateur réseau peut définir un emplacement partagé comme source pour fournir les modèles utilisés dans votre groupe de travail ou votre société. L'emplacement des fichiers de modèles de groupe de travail est généralement un dossier réseau partagé en lecture seule.

Les programmes Office 2003 recherchent les fichiers de modèles existants dans l'emplacement par défaut Modèles de l'utilisateur, ainsi que tout autre modèle supplémentaire dans l'emplacement des fichiers modèles de groupe de travail.

Pour plus d'informations sur l'emplacement des fichiers modèles de groupe de travail et sur le partage d'un modèle avec votre groupe de travail ou votre société, contactez votre administrateur réseau.

Emplacement des fichiers des modèles publiés et installés

Les modèles publiés sont les modèles qui sont inclus avec Office 2003. Ces modèles apparaissent dans la boîte de dialogue Modèles. Selon le type d'installation, vous pouvez ne pas avoir tous les modèles installés sur votre ordinateur. Toutefois, chaque programme Office 2003 affiche les modèles disponibles dans la boîte de dialogue Modèles.

Lorsque vous sélectionnez un modèle à utiliser, le programme Office 2003 détermine si ce modèle est installé. S'il est installé, un nouveau document basé sur ce modèle est ouvert. Si le modèle est publié mais non installé, vous recevez un message du programme pour installer le modèle.

Vous pouvez supprimer des modèles installés en démarrant le programme d'installation Office 2003 et en définissant le groupe de modèles avec la valeur Installé lors de la première utilisation. Ceci supprime les modèles de l'ordinateur, et ils redeviennent des modèles publiés. Par défaut, tous les modèles installés Microsoft Office figurent dans le dossier suivant :
C:\Program Files\Microsoft Office\Templates\Numéro d'ID de la langue##########
Remarque Le numéro d'ID de la langue est un code à quatre chiffres représentant les types de langue installés actuellement. Par exemple, la version anglaise (États-Unis) d'Office 2003 installe un dossier « 1033 », la version arabe installe un dossier « 1025 » et la version allemande installe un dossier « 1031 ». Office 2003 prend en charge beaucoup d'autres langues, et plusieurs langues peuvent être installés en même temps. Par conséquent, vous aurez peut-être un dossier Modèles contenant plusieurs dossiers de numéros d'ID.

Modèles non basés sur des fichiers

Les programmes Office 2003 utilisent des modèles non basés sur des fichiers pour créer de nouveaux classeurs, documents, de nouvelles bases de données et diapositives. Comme leur nom l'indique, ces fichiers spéciaux ne sont pas créés à partir d'un modèle physique défini. Chaque programme Office 2003 dispose des informations nécessaires pour créer un nouveau fichier du type correct.

Par exemple, dans le cas du modèle global (Normal.dot) utilisé par Microsoft Word pour créer un document vide, Word utilise ses paramètres internes pour créer un nouveau document vide.

Modifications des paramètres du Registre Windows pour les modèles de l'utilisateur et de groupe de travail

Avertissement Toute utilisation incorrecte de l'Éditeur du Registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.
Office 2003 utilise deux clés de Registre pour enregistrer l'emplacements des fichiers de modèles de l'utilisateur et des fichiers de modèles de groupe de travail. Ces deux paramètres sont enregistrés dans la clé du Registre suivante :
HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\General
L'emplacement des modèles de l'utilisateur est enregistré dans la valeur de chaîne UserTemplates.

L'emplacement des modèles de groupe de travail est stocké dans la valeur de chaîne SharedTemplates.

Ces valeurs de chaînes n'existent pas ; elles sont créées lorsque vous apportez une modification aux emplacements par défaut pour vos modèles personnalisés. Par défaut, tous les programmes Office 2003 recherchent leurs modèles installés. Par conséquent, aucune valeur de chaîne n'est requise pour l'emplacement des programmes Office 2003.

Si vous modifiez l'emplacement par défaut des modèles de l'utilisateur comme indiqué dans la section « Emplacement des fichiers modèles de l'utilisateur », la valeur de chaîne UserTemplates est supprimée du Registre. Toutefois, si vous modifiez l'emplacement par défaut des modèles de groupe de travail, la valeur de chaîne SharedTemplates est conservée dans le Registre.

Propriétés

Numéro d'article: 889495 - Dernière mise à jour: mercredi 16 mai 2007 - Version: 1.4
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Édition Professionnelle 2003
  • Microsoft Office Access 2003
  • Microsoft Office Excel 2003
  • Microsoft Office FrontPage 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Word 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office Standard Edition 2003
  • Microsoft Office Student and Teachers Edition 2003
  • Microsoft Office Édition PME 2003
  • Microsoft Office Édition Basique 2003
Mots-clés : 
kbtemplate kbhowto KB889495
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com