V počítači Exchange Server 2003 SP1 nelze úspěšně provést online zálohu databází úložiště informací a je zaznamenána událost ID 217

Překlady článku Překlady článku
ID článku: 889528 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Při pokusu provést online zálohu databází úložiště informací na vašem Microsoft Exchange Server 2003 Service Pack 1 (SP1) počítač zálohy není úspěšná. Do protokolu aplikací zaznamenána následující událost:

ID události: 217
Zdroj: ESE
Typ: Chyba
Kategorie: Protokolování a zotavení
POPIS:
Chyba-4001 během zálohování databáze location. Databázi nelze obnovit.

Poznámka: Kód chyby-4001 odpovídá JET_errFileIOBeyondEOF chybovou podmínku.

Příčina

Za určitých okolností může selhat zálohy úložiště informací z důvodu podmínka „ za koncem souboru (EOF)". Extensible Storage Engine (ESE) v Exchange Server 2003 SP1 pre-extends jako funkce optimalizace databáze úložiště informací.

Řešení

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Instalaci této opravy hotfix, musí mít počítač systémem Exchange Server 2003 SP1. Další informace o získání Exchange Server 2003 Service Pack 1 klepněte na následující číslo článku databáze Microsoft Knowledge Base:
836993Získání nejnovějších aktualizací Service Pack pro Exchange Server 2003

Požadavek na restartování

V počítači bez clusterů, samostatné 2003 Exchange Server nemáte k restartování počítače nainstalovat tuto opravu hotfix. Však Exchange jsou služby automaticky zastaveny a restartování během instalace opravy hotfix. Seskupený počítačích Exchange Server 2003 je třeba restartovat uzly clusteru. Další informace o instalaci této opravy hotfix naleznete v části "Pokyny k instalaci hotfix".

Informace o nahrazení opravy hotfix

Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující (nebo pozdější) atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Nov-2004  00:49  6.5.7232.54     2,115,072  Ese.dll     

Pokyny k instalaci hotfix bez clusterů počítačů 2003 Exchange Server

Chcete-li nainstalovat tuto opravu hotfix bez clusterů, samostatný počítač Exchange Server 2003 použijte následující metodu.

Při použití této metody musí nejprve odpojit všechna úložiště informace není potížím. Před instalací opravy hotfix, pak musíte zastavit nuceně služby Microsoft Exchange Information Store. Chcete-li použít tuto metodu, postupujte takto:
  1. Odpojit všechna úložiště informací dochází problém popsaný v části "Příznaky". Další informace o odpojení úložiště naleznete v tématu "Odpojit úložiště" v nápovědě 2003 Exchange Server.

    Důležité: Není dismount úložišť informací uvedených v událost ID 217. Proces Store.exe musí dezaktivační s připojenou vynutit databáze Exchange v události 217 do stavu Měkký obnovení databáze. Stav obnovení Měkký potřebné pro následující kroky pracovat.
  2. Použijte nástroj Kill.exe nebo nástroj TaskKill.exe nuceně zastavení služby Microsoft Exchange Information Store.
    • Pokud Exchange Server 2003 jsou spuštěny v počítači se systémem Microsoft Windows 2000 Server, zastavení služby úložiště informací serveru Exchange pomocí nástroje Kill.exe. Nástroj Kill.exe je součástí nástrojů podpory systému Windows 2000 na disku CD-ROM systému Windows 2000 Server. Použití nástroje Kill.exe, postupujte takto:
      1. Instalaci nástrojů podpory systému Windows 2000. Další informace o instalaci nástrojů pro podporu klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
        301423Instalace nástrojů podpory systému Windows 2000 do počítače se systémem Windows 2000 Server (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
      2. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz cmd a klepněte na tlačítko OK.
      3. Zadejte dezaktivační store.exe -f a potom stiskněte klávesu ENTER.

        Poznámka: Další informace o syntaxi příkazu Kill.exe zadejte dezaktivační /? příkazového řádku.
    • Pokud Exchange Server 2003 jsou spuštěny v počítači se systémem Windows Server 2003, zastavte službu Microsoft Exchange Information Store použít nástroj TaskKill.exe. Nástroj TaskKill.exe je součástí Windows Server 2003. Nástroj je umístěn ve složce % Windir%\System32. Použití nástroje TaskKill.exe, postupujte takto:
      1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz cmd a klepněte na tlačítko OK.
      2. Zadejte taskkill /f /im store.exe a stiskněte klávesu ENTER.

        Poznámka: Další informace o syntaxi příkazu TaskKill zadejte taskkill /? na příkazovém řádku nebo na následujícím webu:
        http://technet2.microsoft.com/windowsserver/en/library/c1db6dae-41c3-4c94-a038-d87baa0fee091033.mspx
  3. Nainstalujte opravu hotfix.
  4. Po instalaci opravy hotfix automaticky restartuje služby Microsoft Exchange Information Store. Ujistěte se, že služba správně spuštěna, zobrazit stav služby služby snap-in. Postupujte takto:
    1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz services.msc a pak klepněte na tlačítko OK.
    2. Vyhledejte službu Microsoft Exchange Information Store.
    3. Zkontrolujte, zda sloupec Stav označuje stav spuštěno.

      Poznámka: Povolit čas pro obnovení úložiště informací dojít.
  5. Připojení úložišť informací odpojený v kroku 1. Další informace o tom, jak připojit úložiště, viz téma "Připojit úložiště" v nápovědě 2003 Exchange Server.

Pokyny k instalaci hotfix pro prostředí s clustery 2003 Exchange Server

Chcete-li nainstalovat tuto opravu hotfix v clusterovém prostředí Exchange Server 2003, postupujte takto:
  1. Ujistěte se, že Exchange nebo skupiny zdrojů Skupina clusteru není vlastníkem uzlu na pasivní uzel.
  2. V pasivním uzlu klepněte na tlačítko Start, klepněte na příkaz programy, klepněte na položku Nástroje pro správu a potom klepněte na položku služby.
  3. Klepněte pravým tlačítkem myši Clusterová služba a klepněte na tlačítko Zastavit.

    Poznámka: To způsobí, že Správce clusteru seznam pasivní uzel jako nedostupné. Zobrazí se ikona uzlu s červený křížek (X) nad ním.
  4. Instalaci této opravy hotfix na pasivní uzel.
  5. Pasivní uzel restartujte.
  6. Po restartování, počkejte, dokud Správce clusteru v aktivním uzlu na pasivní uzel zobrazí jako člen clusteru aktivní. Zobrazí se ikona uzlu bez červený křížek (X) nad ním.
  7. V aktivním uzlu klepněte na tlačítko Start, klepněte na příkaz programy, klepněte na položku Nástroje pro správu a klepněte na položku Správce clusteru.
  8. Rozbalte kontejner skupiny, klepněte na skupiny prostředků Exchange a potom klepněte pravým tlačítkem myši Exchange Information Store Instance. Klepněte na tlačítko Vlastnosti, klepněte na kartu Upřesnit a potom klepněte na tlačítko nerestartuje počítač.
  9. Klepněte na tlačítko OK zavřete dialogové okno.
  10. Odpojit všechna úložiště informací dochází problém popsaný v části "Příznaky". Další informace o odpojení úložiště naleznete v tématu "Odpojit úložiště" v nápovědě 2003 Exchange Server.

    Důležité: Není dismount úložišť informací uvedených v událost ID 217.
  11. Použijte nástroj Kill.exe nebo nástroj TaskKill.exe nuceně zastavení služby Microsoft Exchange Information Store.
    • Pokud Exchange Server 2003 jsou spuštěny v počítači se systémem Microsoft Windows 2000 Server, zastavení služby úložiště informací serveru Exchange pomocí nástroje Kill.exe. Nástroj Kill.exe je součástí nástrojů podpory systému Windows 2000 na disku CD-ROM systému Windows 2000 Server. Použití nástroje Kill.exe, postupujte takto:
      1. Instalaci nástrojů podpory systému Windows 2000.

        Další informace o instalaci nástrojů pro podporu klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
        301423Instalace nástrojů podpory systému Windows 2000 do počítače se systémem Windows 2000 Server (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
      2. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz cmd a klepněte na tlačítko OK.
      3. Zadejte dezaktivační store.exe -f a potom stiskněte klávesu ENTER.

        Poznámka: Další informace o syntaxi příkazu Kill.exe zadejte dezaktivační /? příkazového řádku.
    • Pokud Exchange Server 2003 jsou spuštěny v počítači se systémem Windows Server 2003, zastavte službu Microsoft Exchange Information Store použít nástroj TaskKill.exe. Nástroj TaskKill.exe je součástí Windows Server 2003. Nástroj je umístěn ve složce % Windir%\System32. Použití nástroje TaskKill.exe, postupujte takto:
      1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz cmd a klepněte na tlačítko OK.
      2. Zadejte taskkill /f /im store.exe a stiskněte klávesu ENTER.

        Poznámka: Další informace o syntaxi příkazu TaskKill zadejte taskkill /? na příkazovém řádku nebo na následujícím webu:
        http://technet2.microsoft.com/windowsserver/en/library/c1db6dae-41c3-4c94-a038-d87baa0fee091033.mspx
  12. V aktivním uzlu klepněte na položku Správce clusteru, rozbalte kontejner skupiny, klepněte pravým tlačítkem myši skupiny prostředků Exchange a klepněte na příkaz Přesunout skupinu mít skupiny přesunuty do jiného pasivní uzel.

    Poznámka: To bude spusťte databáze Exchange již opravenou uzlu a jejich připojení.
  13. Klepněte pravým tlačítkem myši skupině prostředků clusteru skupina a klepněte na příkaz Přesunout skupinu mít skupiny přesunuty do jiného pasivní uzel.
  14. Pomocí konzoly pro správu služby zastavit Clusterová služba na místním uzlu.
  15. Nainstalujte opravu hotfix na místním uzlu.
  16. Restartujte místním uzlu.

    Poznámka: Virtuální Server Exchange je nyní spuštěna v uzlu, než jaký byl dříve aktivní uzel. Pokud je vyžadováno, můžete přesunout skupiny zpět do dříve aktivní uzel.
  17. Rozbalte kontejner skupiny, klepněte na tlačítko skupiny prostředků Exchange, klepněte pravým tlačítkem myši Exchange Information Store Instance, klepněte na příkaz Vlastnosti klepněte na kartu Upřesnit a potom klepněte na tlačítko restartovat.
  18. Klepněte na tlačítko OK zavřete dialogové okno.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Další informace

Vytvořením nové úložiště informací a přesunutím uživatelů do nového úložiště nelze bohužel sloužit jako řešení tohoto problému. Existuje několik důvodů, nastane chyba-4001. Mnoho důvodů způsobit chyby legitimní. Je například legitimní Chyba při jeden nebo oba následující nastat:
  • Zhroucení úložiště informací.
  • Nastat problémy disku.
V případě zhroucení úložiště informací nebo nastat problémy disku Tato oprava hotfix nebude bránit tyto chyby vyskytují znovu. Ačkoli chyby jsou stejné, netýkají se EOF problém popsaný v tomto článku. V případě zhroucení úložiště informací nebo nastat problémy disku bude mít tyto problémy opravit. Potom pravděpodobně úložiště informací obnovit z předchozí zálohy.

Musíte spustit nástroj Kill.exe nebo nástroj Taskkill.exe proti vyřešit tento problém služby úložiště informací serveru Exchange. Po spuštění buď tyto nástroje všechny připojené databáze příznakem pro zotavení.

Poznámka: Všechny úložišť informací jsou úspěšně odpojeno před spuštěním nástroje Kill.exe nebo nástroj Taskkill.exe nebude být vliv těchto nástrojů.

Další informace o aktualizacích softwaru společnosti Microsoft naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft
817903Nové schéma přidělování názvů balíčkům aktualizací softwaru pro Exchange Server (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Vlastnosti

ID článku: 889528 - Poslední aktualizace: 30. října 2007 - Revize: 9.3
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Exchange Server 2003 Service Pack 1
Klíčová slova: 
kbmt kbautohotfix kbqfe kbhotfixserver kbexchange2003presp2fix kbfix kbbug KB889528 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:889528

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com