Non Ŕ possibile eseguire correttamente un backup in linea di database dell'archivio informazioni su computer Exchange Server 2003 SP1 e viene registrato l'evento ID 217

Traduzione articoli Traduzione articoli
Identificativo articolo: 889528 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si tenta di eseguire un backup in linea di database dell'archivio informazioni di Microsoft Exchange Server 2003 Service Pack 1 (SP1) computer, il backup non Ŕ riuscita. Nel registro applicazione viene registrato il seguente evento:

ID evento: 217
Origine: ESE
Tipo: errore
Categoria: Registrazione/ripristino
Descrizione:
Errore-4001 durante il backup di un location del database. VerrÓ Impossibile ripristinare il database.

Nota Il codice di errore-4001 corrisponde a una condizione di errore JET_errFileIOBeyondEOF .

Cause

In alcuni casi, i backup dell'archivio informazioni potrebbero non riuscire a causa di una condizione di "oltre la fine del file (EOF)". In Exchange Server 2003 SP1, ESE (Extensible Storage Engine) pre-extends database dell'archivio informazioni come una funzionalitÓ di ottimizzazione.

Risoluzione

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Prerequisiti

Per installare questo aggiornamento rapido (hotfix), Ŕ essere necessario un computer che esegue Exchange Server 2003 SP1. Per ulteriori informazioni su come ottenere Exchange Server 2003 Service Pack 1, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
836993Come ottenere il service pack pi¨ recenti per Exchange Server 2003

NecessitÓ di riavvio

In un computer Exchange Server 2003 non cluster, autonomo, Ŕ necessario riavviare il computer per installare questo aggiornamento rapido (hotfix). Tuttavia, in Exchange vengono automaticamente arrestati e riavvio durante l'installazione di aggiornamento rapido (hotfix) dei servizi. Sui computer del cluster Exchange Server 2003, Ŕ necessario riavviare i nodi del cluster. Per ulteriori informazioni su come installare questo aggiornamento rapido (hotfix), vedere la sezione "Istruzioni di installazione dell'hotfix".

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Date e ore dei file sono elencate di in ora UTC (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Nov-2004  00:49  6.5.7232.54     2,115,072  Ese.dll     

Istruzioni di installazione dell'aggiornamento rapido per computer Exchange Server 2003 non cluster

Per installare questo aggiornamento rapido (hotfix) in un non cluster, computer Exchange Server 2003 autonomo, utilizzare il metodo riportato di seguito.

Quando si utilizza questo metodo, Ŕ innanzitutto necessario disinstallare tutti gli archivi informazioni non si verificano il problema. Quindi, Ŕ necessario arrestare in modo forzato il servizio Archivio informazioni Microsoft prima di installare l'aggiornamento rapido. Per utilizzare questo metodo, attenersi alla procedura descritta di seguito:
  1. Disinstallare tutti gli archivi informazioni non verificano il problema Ŕ descritto nella sezione "Sintomi". Per ulteriori informazioni su come disinstallare un archivio, vedere "Disinstallazione archivio un" in Exchange Server 2003 Guida per.

    importante Non Ŕ disinstallare gli archivi informazioni citate in evento 217 ID. Con il database installato affinchÚ il database di Exchange nell'evento 217 in uno stato di ripristino software, Ŕ necessario interrompere il processo Store.exe. Lo stato di ripristino di software Ŕ necessario per la procedura seguente per il lavoro.
  2. ╚ possibile utilizzare l'utilitÓ kill.exe o l'utilitÓ TaskKill.exe in modo forzato arrestare il servizio di archivio informazioni Microsoft.
    • Se si esegue Exchange Server 2003 in un computer basato su Microsoft Windows 2000 Server, utilizzare l'utilitÓ di kill.exe per arrestare il servizio Archivio informazioni Microsoft. L'utilitÓ Kill.exe Ŕ incluso in Windows 2000 supporto Tools sul CD di Windows 2000 Server. Per utilizzare l'utilitÓ kill.exe, attenersi alla seguente procedura:
      1. Installare gli strumenti di supporto di Windows 2000. Per ulteriori informazioni su come installare gli strumenti di supporto, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
        301423HOW TO: Installare gli strumenti di supporto di Windows 2000 in un computer basato su Windows 2000 Server
      2. Fare clic su Start , scegliere Esegui , digitare cmd e quindi fare clic su OK .
      3. Digitare kill -f store.exe e quindi premere INVIO.

        Nota Per ulteriori informazioni sulla sintassi dei comandi kill.exe, digitare kill /? al prompt dei comandi.
    • Se si esegue Exchange Server 2003 in un computer basato su Windows Server 2003, utilizzare l'utilitÓ di TaskKill.exe per arrestare il servizio Archivio informazioni Microsoft. L'utilitÓ TaskKill.exe Ŕ incluso in Windows Server 2003. L'utilitÓ Ŕ disponibile nella cartella % Windir%\System32. Per utilizzare l'utilitÓ TaskKill.exe, attenersi alla seguente procedura:
      1. Fare clic su Start , scegliere Esegui , digitare cmd e quindi fare clic su OK .
      2. Digitare taskkill /f /im store.exe e quindi premere INVIO.

        Nota Per ulteriori informazioni sulla sintassi del comando TaskKill, digitare taskkill /? al prompt dei comandi oppure visitare il seguente sito Web Microsoft:
        http://technet2.microsoft.com/windowsserver/en/library/c1db6dae-41c3-4c94-a038-d87baa0fee091033.mspx
  3. Applicare l'hotfix.
  4. Il servizio Archivio informazioni di Microsoft Exchange viene riavviato automaticamente dopo aver applicato l'hotfix. Per assicurarsi che il servizio avviato correttamente, visualizzare lo stato del servizio nella finestra di servizi di snap-in. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic su Start , scegliere Esegui , digitare services.msc e quindi fare clic su OK .
    2. Individuare il servizio Archivio informazioni Microsoft .
    3. Assicurarsi che la colonna di stato indica lo stato di avviato .

      Nota Consentire tempo per l'archivio informazioni di ripristino.
  5. Installare gli archivi di informazioni disinstallato nel passaggio 1. Per ulteriori informazioni su come installare un archivio, vedere "Mount archivio un" in Exchange Server 2003 Guida per.

Istruzioni di installazione dell'aggiornamento rapido per ambiente cluster di Exchange Server 2003

Per installare questo aggiornamento rapido (hotfix) in un ambiente di Exchange Server 2003 cluster, attenersi alla seguente procedura:
  1. Assicurarsi che nel nodo passivo, il nodo non Ŕ proprietaria di Exchange o i gruppi di risorse del gruppo cluster.
  2. Nel nodo passivo, fare clic su Start , scegliere programmi , scegliere Strumenti di amministrazione e quindi fare clic su servizi .
  3. Fare clic con il pulsante destro del mouse su Servizio Cluster e quindi fare clic su Interrompi .

    Nota In questo modo l' Amministrazione Cluster elencare il nodo passivo come non disponibile. L'icona di nodo verrÓ visualizzata con una "X" rossa su di esso.
  4. Installare questo aggiornamento rapido (hotfix) nel nodo passivo.
  5. Riavviare il nodo passivo.
  6. Dopo il riavvio, attendere che Amministrazione Cluster sul nodo attivo Visualizza il nodo passivo di un membro attivo del cluster. L'icona di nodo verrÓ visualizzata senza una "X" rossa su di esso.
  7. Nel nodo attivo, fare clic su Start , scegliere programmi , scegliere Strumenti di amministrazione e quindi fare clic su Cluster Administrator .
  8. Espandere il contenitore gruppi , fare clic su gruppo di risorse Exchange e quindi fare clic con il pulsante destro del mouse sull'Istanza archivio informazioni di Exchange . Fare clic su ProprietÓ , fare clic sulla scheda Avanzate e quindi fare clic su Do not restart .
  9. Fare clic su OK per chiudere la finestra di dialogo.
  10. Disinstallare tutti gli archivi informazioni non verificano il problema Ŕ descritto nella sezione "Sintomi". Per ulteriori informazioni su come disinstallare un archivio, vedere "Disinstallazione archivio un" in Exchange Server 2003 Guida per.

    importante Non Ŕ disinstallare gli archivi informazioni citate in 217 ID evento.
  11. ╚ possibile utilizzare l'utilitÓ kill.exe o l'utilitÓ TaskKill.exe in modo forzato arrestare il servizio di archivio informazioni Microsoft.
    • Se si esegue Exchange Server 2003 in un computer basato su Microsoft Windows 2000 Server, utilizzare l'utilitÓ di kill.exe per arrestare il servizio Archivio informazioni Microsoft. L'utilitÓ Kill.exe Ŕ incluso in Windows 2000 supporto Tools sul CD di Windows 2000 Server. Per utilizzare l'utilitÓ kill.exe, attenersi alla seguente procedura:
      1. Installare gli strumenti di supporto di Windows 2000.

        Per ulteriori informazioni su come installare gli strumenti di supporto, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
        301423HOW TO: Installare gli strumenti di supporto di Windows 2000 in un computer basato su Windows 2000 Server
      2. Fare clic su Start , scegliere Esegui , digitare cmd e quindi fare clic su OK .
      3. Digitare kill -f store.exe e quindi premere INVIO.

        Nota Per ulteriori informazioni sulla sintassi dei comandi kill.exe, digitare kill /? al prompt dei comandi.
    • Se si esegue Exchange Server 2003 in un computer basato su Windows Server 2003, utilizzare l'utilitÓ di TaskKill.exe per arrestare il servizio Archivio informazioni Microsoft. L'utilitÓ TaskKill.exe Ŕ incluso in Windows Server 2003. L'utilitÓ Ŕ disponibile nella cartella % Windir%\System32. Per utilizzare l'utilitÓ TaskKill.exe, attenersi alla seguente procedura:
      1. Fare clic su Start , scegliere Esegui , digitare cmd e quindi fare clic su OK .
      2. Digitare taskkill /f /im store.exe e quindi premere INVIO.

        Nota Per ulteriori informazioni sulla sintassi del comando TaskKill, digitare taskkill /? al prompt dei comandi oppure visitare il seguente sito Web Microsoft:
        http://technet2.microsoft.com/windowsserver/en/library/c1db6dae-41c3-4c94-a038-d87baa0fee091033.mspx
  12. Nel nodo attivo, fare clic su Amministrazione Cluster , espandere il contenitore del gruppo , fare clic con il pulsante destro del mouse sul gruppo di risorse Exchange e quindi scegliere Sposta gruppo per il gruppo spostato un altro nodo passivo.

    Nota VerrÓ avviare i database di Exchange sul nodo giÓ patch e installarli.
  13. Fare clic con il pulsante destro del mouse sul gruppo cluster gruppo di risorse e quindi fare clic su Sposta gruppo per il gruppo spostato un altro nodo passivo.
  14. Utilizzando la console di Gestione servizi, interrompere il Cluster Service nel nodo locale.
  15. Installare l'aggiornamento rapido su questo nodo locale.
  16. Riavviare il nodo locale.

    Nota Il server virtuale Ŕ in esecuzione su un nodo diverso da ci˛ che in precedenza era il nodo attivo. Se necessario, Ŕ possibile spostare i gruppi di tornare al nodo attivo in precedenza.
  17. Espandere il contenitore dei gruppi , fare clic sul gruppo risorsa di Exchange , fare clic con il pulsante destro del mouse l' Istanza archivio informazioni di Exchange , fare clic su ProprietÓ , fare clic sulla scheda Avanzate e quindi fare clic su Riavvia .
  18. Fare clic su OK per chiudere la finestra di dialogo.

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Informazioni

Sfortunatamente, la creazione di un nuovo archivio informazioni e lo spostamento degli utenti al nuovo archivio non potrÓ fungere una soluzione per questo problema. Sono numerose le ragioni che si verifica un errore di-4001. Per numerosi motivi causano errori legittimi. Un esempio di un errore legittimo Ŕ quando una o entrambe le seguenti operazioni si verificano:
  • L'archivio informazioni si blocca.
  • Si verificano problemi di disco.
In uno scenario in cui l'archivio informazioni si blocca o si verificano problemi di disco, questo aggiornamento rapido (hotfix) non impedirÓ gli errori che si verifichino nuovamente. Sebbene gli errori siano gli stessi, non vengono applicate al problema di EOF Ŕ descritto in questo articolo. In uno scenario in cui l'archivio informazioni si blocca o si verificano problemi di disco, sarÓ necessario risolvere tali problemi. Quindi, potrebbe essere necessario ripristinare l'archivio informazioni da un backup precedente.

╚ necessario eseguire l'utilitÓ di kill.exe o l'utilitÓ di Taskkill.exe contro il servizio Archivio informazioni di Exchange per risolvere il problema. Dopo aver eseguito una di queste utilitÓ, tutti i database installati verranno contrassegnati per il ripristino.

Nota Tutti gli archivi informazioni che vengono disinstallati correttamente prima di eseguire l'utilitÓ di kill.exe o l'utilitÓ di Taskkill.exe non interessati da queste utilitÓ.

Per ulteriori informazioni sugli aggiornamenti software Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft
817903Nuovo schema di denominazione per i pacchetti di aggiornamento software Exchange Server

ProprietÓ

Identificativo articolo: 889528 - Ultima modifica: martedý 30 ottobre 2007 - Revisione: 9.3
Le informazioni in questo articolo si applicano a:
  • Microsoft Exchange Server 2003 Service Pack 1
Chiavi:á
kbmt kbautohotfix kbqfe kbhotfixserver kbexchange2003presp2fix kbfix kbbug KB889528 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 889528
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com