Você não pode executar com êxito um backup online de bancos de dados do armazenamento de informações no computador Exchange Server 2003 SP1 e de evento ID 217 é registrada

Traduções deste artigo Traduções deste artigo
ID do artigo: 889528 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Quando você tenta realizar um backup online de bancos de dados do armazenamento de informações no seu Microsoft Exchange Server 2003 Service Pack 1 (SP1) o computador, o backup não é bem-sucedida. O seguinte evento é registrado no log do aplicativo:

IDENTIFICAÇÃO de evento: 217
Fonte: ESE
Tipo: erro
Categoria: Log/recuperação
Descrição:
Erro-4001 durante backup de um banco de dados location. O banco de dados não poderão restaurar.

Observação O código de erro-4001 corresponde a uma condição de erro JET_errFileIOBeyondEOF .

Causa

Em determinadas circunstâncias, os backups do armazenamento de informações podem falhar devido a uma condição "Além do fim de arquivo (EOF)". No Exchange Server 2003 SP1, o mecanismo de armazenamento extensível (ESE) pre-extends o banco de dados de armazenamento de informações como um recurso de otimização.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para instalar esse hotfix, você deve ter um computador que esteja executando o Exchange Server 2003 SP1. Para obter mais informações sobre como obter o Exchange Server 2003 Service Pack 1, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
836993Como obter os service packs mais recentes para o Exchange Server 2003

Requisitos de reinicialização

Em um computador Exchange Server 2003 não-agrupado, autônomo, não é necessário reiniciar o computador para instalar esse hotfix. No entanto, Exchange serviços são automaticamente interrompidos e reiniciados durante a instalação do hotfix. Em computadores em cluster do Exchange Server 2003, você deve reiniciar os nós de cluster. Para obter mais informações sobre como instalar esse hotfix, consulte a seção "Instruções de instalação do hotfix".

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Nov-2004  00:49  6.5.7232.54     2,115,072  Ese.dll     

Hotfix instruções de instalação para computadores com Exchange Server 2003 não agrupado em cluster

Para instalar esse hotfix em um não-agrupado, o computador Exchange Server 2003 autônomo, use o método seguinte.

Quando você usa esse método, você deve primeiro desmontar todos os armazenamentos de informações que não apresentarem o problema. Em seguida, você deve parar o serviço Microsoft Exchange Information Store forçada antes de instalar o hotfix. Para usar esse método, execute essas etapas:
  1. Desmonte todos os armazenamentos de informações que não apresentarem o problema que é descrito na seção "Sintomas". Para obter mais informações sobre como desmontar um armazenamento, consulte o tópico "Desmontar um armazenamento" no Exchange Server 2003 ajuda.

    importante Não desmonte os armazenamentos de informações que são mencionados no evento ID 217. Você deve eliminar o processo Store.exe com o banco de dados montado para forçar o banco de dados Exchange no evento 217 em estado de recuperação de disco. O estado de recuperação de software é necessária para as seguintes etapas para trabalhar.
  2. Use o utilitário kill.exe ou o utilitário TaskKill.exe forçada parar o serviço Microsoft Exchange Information Store.
    • Se você estiver executando o Exchange Server 2003 em um computador com Microsoft Windows 2000 Server, use o utilitário kill.exe para parar o serviço Microsoft Exchange Information Store. O utilitário kill.exe está incluído com as ferramentas de suporte do Windows 2000 no CD-ROM do Windows 2000 Server. Para usar o utilitário kill.exe, execute essas etapas:
      1. Instale as ferramentas de suporte do Windows 2000. Para obter mais informações sobre como instalar as ferramentas de suporte, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
        301423Como instalar as ferramentas de suporte do Windows 2000 em um computador baseado no Windows 2000 Server
      2. Clique em Iniciar , clique em Executar , digite cmd e, em seguida, clique em OK .
      3. Digite kill store.exe -f e pressione ENTER.

        Observação Para obter mais informações sobre sintaxe de comando KILL.exe, digite kill /? no prompt de comando.
    • Se você estiver executando o Exchange Server 2003 em um computador com Windows Server 2003, use o utilitário TaskKill.exe para parar o serviço Microsoft Exchange Information Store. O utilitário TaskKill.exe está incluído no Windows Server 2003. O utilitário está localizado na pasta % Windir%\System32. Para usar o utilitário TaskKill.exe, execute essas etapas:
      1. Clique em Iniciar , clique em Executar , digite cmd e, em seguida, clique em OK .
      2. Digite taskkill /f /im store.exe e, em seguida, pressione ENTER.

        Observação Para obter mais informações sobre sintaxe de comando TaskKill, digite taskkill /? no prompt de comando, ou visite o seguinte site:
        http://technet2.microsoft.com/windowsserver/en/library/c1db6dae-41c3-4c94-a038-d87baa0fee091033.mspx
  3. Aplique o hotfix.
  4. O serviço do Microsoft Exchange Information Store será reinicializado automaticamente depois de aplicar o hotfix. Para certificar-se que o serviço é iniciado corretamente, exiba o status do serviço no serviços de snap-in. Para fazer isso, execute as seguintes etapas:
    1. Clique em Iniciar , clique em Executar , digite services.msc e, em seguida, clique em OK .
    2. Localize o serviço Microsoft Exchange Information Store .
    3. Certifique-se que a coluna status indica o status iniciado .

      Observação Permite que o tempo para recuperação de armazenamento de informações para ocorrer.
  5. Monte os armazenamentos de informações que você desmontado na etapa 1. Para obter mais informações sobre como montar um armazenamento, consulte o tópico "Montar um armazenamento" no Exchange Server 2003 ajuda.

Instruções de instalação hotfix para o ambiente Exchange Server 2003 em cluster

Para instalar esse hotfix em um ambiente de 2003 em cluster do Exchange Server, execute essas etapas:
  1. No nó passivo, verifique se que o nó não possui o Exchange ou os grupos de recurso do grupo de clusters.
  2. No nó passivo, clique em Iniciar , clique em programas , clique em Ferramentas administrativas e em seguida, clique em serviços .
  3. Clique Serviço de cluster com o botão direito do mouse e, em seguida, clique em Parar .

    Observação Isso fará com que o Administrador de cluster listar o nó passivo como não disponível. O ícone de nó será exibido com um "X" vermelho sobre ele.
  4. Instale este hotfix no nó passivo.
  5. Reinicie o nó passivo.
  6. Após a reinicialização, aguarde até que o Administrador de cluster no nó ativo exibe o nó passivo como um membro do cluster ativo. O ícone de nó será exibido sem um "X" vermelho sobre ele.
  7. No nó ativo, clique em Iniciar , clique em programas , clique em Ferramentas administrativas e, em seguida, clique em Administrador de cluster .
  8. Expanda o recipiente de grupos , clique em grupo de recursos do Exchange e, em seguida, clique Instância de armazenamento de informações do Exchange com o botão direito do mouse. Clique em Propriedades , clique na guia Avançado e, em seguida, clique em não reiniciar .
  9. Clique em OK para fechar a caixa de diálogo.
  10. Desmonte todos os armazenamentos de informações que não apresentarem o problema que é descrito na seção "Sintomas". Para obter mais informações sobre como desmontar um armazenamento, consulte o tópico "Desmontar um armazenamento" no Exchange Server 2003 ajuda.

    importante Não desmonte os armazenamentos de informações que são mencionados no 217 de identificação de evento.
  11. Use o utilitário kill.exe ou o utilitário TaskKill.exe forçada parar o serviço Microsoft Exchange Information Store.
    • Se você estiver executando o Exchange Server 2003 em um computador com Microsoft Windows 2000 Server, use o utilitário kill.exe para parar o serviço Microsoft Exchange Information Store. O utilitário kill.exe está incluído com as ferramentas de suporte do Windows 2000 no CD-ROM do Windows 2000 Server. Para usar o utilitário kill.exe, execute essas etapas:
      1. Instale as ferramentas de suporte do Windows 2000.

        Para obter mais informações sobre como instalar as ferramentas de suporte, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
        301423Como instalar as ferramentas de suporte do Windows 2000 em um computador baseado no Windows 2000 Server
      2. Clique em Iniciar , clique em Executar , digite cmd e, em seguida, clique em OK .
      3. Digite kill store.exe -f e pressione ENTER.

        Observação Para obter mais informações sobre sintaxe de comando KILL.exe, digite kill /? no prompt de comando.
    • Se você estiver executando o Exchange Server 2003 em um computador com Windows Server 2003, use o utilitário TaskKill.exe para parar o serviço Microsoft Exchange Information Store. O utilitário TaskKill.exe está incluído no Windows Server 2003. O utilitário está localizado na pasta % Windir%\System32. Para usar o utilitário TaskKill.exe, execute essas etapas:
      1. Clique em Iniciar , clique em Executar , digite cmd e, em seguida, clique em OK .
      2. Digite taskkill /f /im store.exe e, em seguida, pressione ENTER.

        Observação Para obter mais informações sobre sintaxe de comando TaskKill, digite taskkill /? no prompt de comando, ou visite o seguinte site:
        http://technet2.microsoft.com/windowsserver/en/library/c1db6dae-41c3-4c94-a038-d87baa0fee091033.mspx
  12. No nó ativo, clique em Administrador de cluster , expanda recipiente de grupo , clique com o botão direito grupo de recursos do Exchange e, em seguida, clique em Mover grupo para ter o grupo movido para outro nó passivo.

    Observação Isso será inicie os bancos de dados no nó já corrigido e montá-los.
  13. Clique com o botão direito grupo de recursos do grupo de cluster e clique em Mover grupo para que o grupo movido para outro nó passivo.
  14. Usando o console de gerenciamento serviços, interromper o cluster do serviço no nó local.
  15. Instale o hotfix neste nó local.
  16. Reinicie o nó local.

    Observação O servidor virtual do Exchange está em execução em um nó diferente da que foi anteriormente o nó ativo. Se for necessário, você pode mover os grupos de volta para o nó anteriormente ativo.
  17. Expanda o recipiente de grupos , clique em grupo de recursos Exchange , clique a Instância de armazenamento de informações do Exchange com o botão direito do mouse, clique em Propriedades , clique na guia Avançado e, em seguida, clique em Reiniciar .
  18. Clique em OK para fechar a caixa de diálogo.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Infelizmente, criando um novo armazenamento de informações e movendo os usuários para o novo armazenamento não podem atuar como uma solução alternativa para esse problema. Há várias razões que ocorre um erro-4001. Muitos motivos causam erros legítimos. Um exemplo de um erro legítimo é quando um ou ambos os procedimentos a seguir ocorrem:
  • Falha de armazenamento de informações.
  • Problemas de disco.
Em um cenário onde o armazenamento de informações falha ou problemas de disco, esse hotfix não impedirá esses erros ocorra novamente. Embora os erros sejam os mesmos, eles não se aplicam ao problema de EOF é descrito neste artigo. Em um cenário onde o armazenamento de informações falha ou problemas de disco, você precisará corrigir esses problemas. Em seguida, talvez você precise restaurar o armazenamento de informações de um backup anterior.

Você deve executar o utilitário kill.exe ou o utilitário Taskkill.exe contra o serviço de armazenamento de informações do Exchange para resolver esse problema. Depois de executar um desses utilitários, todos os bancos de dados montados serão sinalizados para recuperação.

Observação Todos os armazenamentos de informações que estão desmontados com êxito antes de executar o utilitário kill.exe ou o utilitário Taskkill.exe não serão afetados por esses utilitários.

Para obter mais informações sobre atualizações de software Microsoft, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software
817903Novo esquema para nomeação para pacotes de atualização de software do Exchange Server

Propriedades

ID do artigo: 889528 - Última revisão: terça-feira, 30 de outubro de 2007 - Revisão: 9.3
A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Service Pack 1
Palavras-chave: 
kbmt kbautohotfix kbqfe kbhotfixserver kbexchange2003presp2fix kbfix kbbug KB889528 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 889528

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com