Programas com base em MS-DOS não executam conforme o esperado em um computador executando o Windows Server 2003, Windows XP ou Windows 2000

Traduções deste artigo Traduções deste artigo
ID do artigo: 890067 - Exibir os produtos aos quais esse artigo se aplica.


Importante Este artigo contém informações sobre como modificar o Registro. Antes de modificá-lo, faça um backup e certifique-se de que saiba como restaurá-lo caso ocorra algum problema. Para obter informações sobre como fazer backup, restaurar e modificar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
256986 Descrição do Registro do Microsoft Windows
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Você tenta executar um programa com base no MS-DOS em um computador executando um dos seguintes sistemas operacionais:
  • Microsoft Windows Server 2003
  • Microsoft Windows XP com Service Pack 1 (SP1)
  • Microsoft Windows XP com Service Pack 2 (SP2)
  • Microsoft Windows 2000 com Service Pack 3 (SP3)
  • Microsoft Windows 2000 com Service Pack 4 (SP4)
Porém, o programa não executa conforme o esperado.

Causa

Este problema ocorre se você executar um programa com base no MS-DOS de 16 bits em um prompt de comando e não incluir um espaço entre a extensão de nome de arquivo e a opção de parâmetro (/). Um espaço sempre é adicionado entre a extensão de nome de arquivo e a opção de parâmetro quando um programa com base no MS-DOS estiver executando por uma linha de comando.

Por exemplo, o programa com base no MS-DOS pode tentar executar o comando como Programa.exe /Parâmetro. Mesmo se um espaço não for especificado em um comando, o comando é executado como Programa.exe /Parâmetro.

Resolução

Windows Server 2003

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Server 2003. Para obter mais informações, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
889100 Como obter o service pack mais recente para Windows Server 2003

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Testes adicionais podem ser realizados nesse hotfix. Portanto, se este problema não o prejudicar, é aconselhável aguardar o próximo P1 que contém este hotfix.

Para resolver esse problema, envie uma solicitação para o Atendimento ao Cliente Online Microsoft para obter o hotfix. Para enviar a solicitação online para obter o hotfix, visite o seguinte site da Microsoft:
http://support.microsoft.com/gp/CUHotFix_LandingPage_Request
Observação Se outros problemas ocorrerem ou se uma solução de problemas for requisitada, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem a esse hotfix. Para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support

Pré-requisitos

Para instalar este hotfix, você precisa ter o Service Pack 1 (SP1) do Windows Server 2003 instalado no computador.

Necessidade de reinicialização

Você deve reiniciar o computador após aplicar este hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui nenhum outro.

Informações sobre o arquivo

A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários desses arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas serão convertidas na hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário na ferramenta Data e hora do Painel de Controle.
Windows Server 2003
   Data         Hora   Versão           Tamanho     Nome do arquivo
   --------------------------------------------------------------
   08-Set-2005  01:17  5.2.3790.405      420.864  Ntvdm.exe        
   08-Set-2005  02:10  5.2.3790.2525     443.392  Ntvdm.exe        
   08-Set-2005  02:12  5.2.3790.2525      32.256  Arpidfix.exe  

Windows XP

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Testes adicionais podem ser realizados nesse hotfix. Portanto, se este problema não o prejudicar, é aconselhável o novo service pack do Windows XP que contenha este hotfix.

Para resolver esse problema, envie uma solicitação para o Atendimento ao Cliente Online Microsoft para obter o hotfix. Para enviar a solicitação online para obter o hotfix, visite o seguinte site da Microsoft:
http://support.microsoft.com/gp/CUHotFix_LandingPage_Request
Observação Se outros problemas ocorrerem ou se uma solução de problemas for requisitada, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem a esse hotfix. Para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support

Pré-requisitos

Para instalar este hotfix, você precisa ter o Service Pack 2 (SP2) do Windows XP instalado no computador.

Necessidade de reinicialização

Você deve reiniciar o computador após aplicar este hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui nenhum outro.

Informações sobre o arquivo

A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários destes arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário na ferramenta Data e hora do Painel de Controle.
Windows XP com SP1 ou SP2
   Data         Hora   Versão            Tamanho    Nome do arquivo
   --------------------------------------------------------------
   06-Jul-2005  22:59  3.10.0.103         92.224  Krnl386.exe
   06-Jul-2005  22:56                     33.840  Ntio.sys
   06-Jul-2005  22:56                     34.560  Ntio404.sys
   06-Jul-2005  22:56                     35.648  Ntio411.sys
   06-Jul-2005  22:56                     35.424  Ntio412.sys
   06-Jul-2005  22:56                     34.560  Ntio804.sys
   06-Jul-2005  23:49  5.1.2600.1715     397.312  Ntvdm.exe        
   04-Jun-2004  00:43  5.1.2600.1562     245.760  Wow32.dll        
   06-Jul-2005  23:38  5.1.2600.2715     420.864  Ntvdm.exe      
   06-Jul-2005  23:41  5.1.2600.2715      30.720  Arpidfix.exe 

Windows 2000

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, destina-se somente a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem este problema específico. Testes adicionais poderão ser realizados neste hotfix. Por isso, se esse problema não o prejudicar, é aconselhável aguardar o novo service pack do Windows 2000 que contenha esse hotfix.

Para resolver esse problema imediatamente, contate o Serviços de Suporte da Microsoft para obter o hotfix. Para obter uma lista completa dos números de telefone do Serviços de Suporte da Microsoft e informações sobre os custos de suporte, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Observação Em alguns casos, as taxas cobradas pelas ligações de suporte podem ser canceladas se uma equipe de suporte da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem à atualização específica em questão.

Pré-requisitos

Para instalar este hotfix, você precisa ter o Service Pack 3 do Windows 2000 instalado no computador.

Necessidade de reinicialização

Você deve reiniciar o computador após aplicar este hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui nenhum outro.

Informações sobre o arquivo

A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários destes arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário na ferramenta Data e hora do Painel de Controle.
Windows 2000 com SP3 ou SP4
   Data         Hora   Versão            Tamanho    Nome do arquivo
   --------------------------------------------------------------
   19-Jun-2003  20:05  3.10.0.103         92.032  Krnl386.exe
   19-Jun-2003  20:05                     33.824  Ntio.sys
   19-Jun-2003  20:05                     34.544  Ntio404.sys
   19-Jun-2003  20:05                     35.648  Ntio411.sys
   19-Jun-2003  20:05                     35.408  Ntio412.sys
   19-Jun-2003  20:05                     34.544  Ntio804.sys
   15-Dez-2004  19:24  5.0.2195.7011     398.608  Ntvdm.exe        
   16-Dez-2004  05:02  5.0.2195.7009     239.888  Wow32.dll 

Informação de instalação do hotfix

Aviso O uso incorreto do Editor do Registro pode causar sérios problemas que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. O uso do Editor do Registro é de sua responsabilidade.

Após a aplicação desse hotfix, será necessário adicionar a seguinte entrada ao Registro:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\WOW\CmdLine\NoSpace
Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar, em Executar, digite regedit e clique em OK.
  2. Localize e clique com o botão direito do mouse na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\WOW
  3. Clique com o botão direito do mouse em WOW, aponte para Novo e clique em Chave.
  4. Digite CmdLine e pressione ENTER para nomear a nova subchave.
  5. Clique com o botão direito do mouse em CmdLine, aponte para Novo e clique em Valor DWORD.
  6. Digite NoSpace e pressione ENTER para nomear o novo o valor.
  7. Clique com o botão direito do mouse em NoSpace e clique em Modificar.
  8. Na caixa Dados do valor, digite 1 e clique em OK.
  9. Encerre o Editor do Registro.

Situação

A Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a". Esse problema foi corrigido pela primeira vez no Windows Server 2003 Service Pack 2 (SP2).

Mais Informações

Para obter mais informações, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento Microsoft (alguns artigos podem estar em inglês):
816915 Novo esquema para nomeação de arquivos para os pacotes de atualização de software do Microsoft Windows
824684 Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft

Propriedades

ID do artigo: 890067 - Última revisão: quinta-feira, 15 de novembro de 2007 - Revisão: 4.5
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Service Pack 1
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Service Pack 4
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows XP Service Pack 1 nas seguintes plataformas
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Service Pack 2 nas seguintes plataformas
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
Palavras-chave: 
kbbug kbfix kbqfe kbwin2000presp5fix kbhotfixserver kbwinserv2003sp2fix KB890067

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com