FIX: You receive a "Page cannot be displayed" error message in Internet Explorer when you browse back to a Web page that contains data that you previously submitted after you install Windows XP SP2

Article translations Article translations
Article ID: 890178 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

In Microsoft Internet Explorer, when you browse back to a Web page to which you previously submitted form data, and that Web page contains the cache-control: no-cache HTTP header, you receive the following error message:
Page could not be displayed
You expect to receive the following error message:
Warning: Page has Expired
"The page you requested was created using information you submitted in a form. This page is no longer available. As a security precaution, Internet Explorer does not automatically resubmit your information for you. To resubmit your information and view this Web page, click the Refresh button."
If you click to clear the Show friendly HTTP error messages check box in the advanced options in Internet Explorer, you will receive the second error message as expected.

Note This problem only occurs after you install Microsoft Windows XP Service Pack 2 (SP2).

CAUSE

This problem occurs because of a regression that was introduced in Windows XP Service Pack 2.

RESOLUTION

To resolve this problem, obtain security update MS05-025. For more information, visit the following Microsoft Web site:
http://www.microsoft.com/technet/security/Bulletin/MS05-025.mspx

WORKAROUND

To work around this problem and to return to the behavior that existed before you installed Windows XP SP2, click to clear the Show friendly HTTP error messages check box in the advanced options in Internet Explorer. To do this, follow these steps:
  1. Start Internet Explorer.
  2. On the Tools menu, click Internet Options.
  3. In the Internet Options dialog box, click the Advanced tab.
  4. Locate and then click to clear the Show friendly HTTP error messages check box, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 890178 - Last Review: May 15, 2006 - Revision: 4.3
APPLIES TO
  • Microsoft Windows XP Service Pack 2
Keywords: 
atdownload kbqfe kbbug kbfix kbprb KB890178

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com