Article ID: 890191 - Last Review: April 7, 2006 - Revision: 2.1

FIX: An access violation may occur in the Application Center 2000 Component Load Balancing service

Hotfix download is availableHotfix Download Available
View and request hotfix downloads


On This Page

Expand all | Collapse all

SYMPTOMS

When servers are added and deleted from the routing list on the computer that is running Microsoft Application Center 2000, an access violation may occur in the Application Center 2000 Component Load Balancing service (Comlb.exe).

CAUSE

This problem occurs when the server list and the internal counter that contains the number of servers on the server list are not synchronized correctly. In this case, memory that is not valid may be accessed when the server list is traversed.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   30-Nov-2004  23:45  1.0.781.10         47,104  Comlb.exe        

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Application Center 2000 Standard Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbbug KB890191
 

Article Translations

 

Related Support Centers