"This application must be installed before you can use it" error message when you try to start a program that was installed by using Windows Installer in Windows 2000

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Article ID: 890212 - View products that this article applies to.
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SYMPTOMS

After you install a program that uses the Microsoft Windows Installer, you may receive the following error message when you try to start the program:
This application must be installed before you can use it.
When you open the Add or Remove Programs item in Control Panel, you see that some programs that are installed on your computer may not appear in the list of currently installed programs.

Note Programs that use the Windows Installer include Microsoft Office programs.

CAUSE

This problem occurs if the following conditions are true:
  • A program is installed by using the Windows Installer.
  • The program is installed for all users who use the computer.
  • The local system (NT AUTHORITY\SYSTEM) account profile is deleted, or a temporary profile that is configured for the local system account is deleted.
Note The local system account is a service account that is used by the Windows operating system.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   17-Jun-2004  23:05  5.0.2195.6951      46,352  Basesrv.dll
   21-Sep-2003  00:45  5.0.2195.6824     236,304  Cmd.exe
   17-Jun-2004  23:05  5.0.2195.6945     231,184  Gdi32.dll
   17-Jun-2004  23:05  5.0.2195.6946     712,464  Kernel32.dll
   24-Mar-2004  02:17  5.0.2195.6898      37,136  Mf3216.dll
   24-Mar-2004  02:17  5.0.2195.6824      54,544  Mpr.dll
   17-Jun-2004  23:05  5.0.2195.6928     335,120  Msgina.dll
   24-Mar-2004  02:17  5.0.2195.6892      90,264  Rdpwd.sys
   02-Dec-2004  14:27  5.0.2195.7004   6,272,512  Sp3res.dll
   24-Mar-2004  02:17  5.0.2195.6897     403,216  User32.dll
   09-Dec-2004  06:13  5.0.2195.7002     393,488  Userenv.dll
   10-Aug-2004  03:51  5.0.2195.6966   1,632,624  Win32k.sys
   24-Aug-2004  22:59  5.0.2195.6970     182,544  Winlogon.exe
   17-Jun-2004  23:05  5.0.2195.6946     244,496  Winsrv.dll
   17-Jun-2004  23:05  5.0.2195.6946     712,464  Kernel32.dll
   10-Aug-2004  03:51  5.0.2195.6966   1,632,624  Win32k.sys
   17-Jun-2004  23:05  5.0.2195.6946     244,496  Winsrv.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

When you delete a profile by using the System item in Control Panel, the DeleteProfile function is called. When the DeleteProfile function removes a profile that is associated with the Windows Installer, the following registry subkey is removed:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18
This registry subkey contains information that is required to start some programs. When you apply this hotfix, the DeleteProfile function no longer removes this subkey.

Note The security identifier (SID) of the local system account is S-1-5-18.

For additional information about the new file naming schema for Microsoft Windows software update packages, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 890212 - Last Review: October 27, 2013 - Revision: 1.6
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbbug kbfix kbwin2000presp5fix kbhotfixserver kbqfe KB890212

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