Article ID: 890307 - Last Review: August 15, 2006 - Revision: 3.2

Logging to an SQL database in ISA Server 2004 or in Forefront Threat Management Gateway does not work

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SYMPTOMS

If you configure Microsoft Internet Security and Acceleration (ISA) Server 2004 logging or Microsoft Forefront Threat Management Gateway, Medium Business Editiong logging to log to a Microsoft SQL database, you may receive the following error message:
"Unknown" (error code 0x80040e09, DB_SEC_E_PERMISSIONDENIED)
However, if you use the Test button in the New Connectivity Verifier Wizard, the test is successful.

CAUSE

This issue may occur when the user account that is configured for SQL logging in ISA Server 2004 or in Forefront Threat Management Gateway does not have sufficient permissions configured on the SQL Server to insert records to the log database, or to run a bulk-insertion stored procedure.

Note The Test configuration button tests connectivity to the SQL database. It does not test the ability to read or write to it.

RESOLUTION

To resolve this issue, make sure that the account that you use for SQL logging in ISA Server 2004 or in Forefront Threat Management Gateway logging has the appropriate read and write permissions configured on the computer that is running SQL Server.

MORE INFORMATION

For additional information about how to configure connectivity verifiers , click the following article number to view the article in the Microsoft Knowledge Base:
839509  (http://support.microsoft.com/kb/839509/ ) How to configure connectivity verifiers to monitor selected computers and networks in ISA Server 2004

APPLIES TO
  • Microsoft Internet Security and Acceleration Server 2004 Standard Edition
  • Windows Essential Business Server 2008 Standard
  • Microsoft Forefront Threat Management Gateway, Medium Business Edition
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