文書番号: 890538 - 最終更新日: 2006年12月6日 - リビジョン: 3.1

スパイウェアが原因で発生している問題の対応方法

目次

すべて展開する | すべて折りたたむ

概要

この資料は、スパイウェアと呼ばれるサードパーティ製の不正なソフトウェアが原因で発生する問題とその解決方法について説明しています。

現象

スパイウェアが原因で以下のような現象が発生する場合があります。
  • プログラムを起動できない。(Internet Explorer や他のアプリケーションなどを起動しようとするとエラーが発生して起動ができない。)
  • Web ブラウザが突然終了するか、応答を停止する。 (インターネット接続は可能だが、Internet Explorer で特定のホームページが「ページが表示できません」エラーで参照できない。)
  • Web ブラウザを使用して Web サイトを表示すると、Web ブラウザの別のインスタンスが起動し、Web サイト広告が表示される。(特に英語のホームページが表示されることが多い)
  • Internet Explorer 上で日本語の入力ができない
  • Web ブラウザのホームページ (スタートページ) が知らないうちに変更される。
  • 覚えのない Web ページが [お気に入り] フォルダに追加される。
  • プログラムでリンクをクリックしても、リンクが機能しない。
  • コンピュータの動作が不安定で、何か操作をすると頻繁にフリーズ (コンピュータからの応答がない) 状態になる。
  • 覚えのないフォルダが自動的に作成される。
  • 覚えのない新しいツール バーが Web ブラウザに追加される。
  • 以前は機能した、Windows または他のプログラムのコンポーネントが機能しない。
  • Windows 起動時にマイドキュメントが開いてしまう。
  • マイコンピュータやマイドキュメント等を開くとexplorer.exeが強制終了してしまう。
  • コンピュータの起動、または休止状態からの再開に長い時間がかかる。

原因

現象に記載している問題は、アプリケーションまたはネットワークの設定に問題がある場合やアプリケーションまたはネットワークそのものに問題がある場合に発生する可能性がありますが、ほとんどの場合、スパイウェアと呼ばれるサードパーティ製の不正なソフトウェアがコンピュータにインストールされている場合に発生します。この種類のソフトウェアは、他のソフトウェアのインストール時にその一部としてインストールされる場合や、ダウンロードした Web コンポーネントに含まれている場合があります。

解決方法

STEP 1: スパイウェアのチェック

問題の原因がスパイウェアにあるかどうか、コンピュータをチェックします。

方法 1 : Internet Explorer のブラウザ拡張を無効にする

  1. [スタート] ボタンをクリックし、[コントロール パネル] をクリックします。
  2. [インターネット オプション] をダブル クリックします。
  3. インターネットのプロパティで、[詳細設定] タブをクリックします。
  4. [設定] ボックスの一覧から [ブラウズ] の [サードパーティ製のブラウザ拡張を有効にする (再起動が必要)] チェックボックスをクリックしてチェックを外します。
  5. [OK] をクリックします。
これで現象が回避されるようでしたら、サードパーティ製のプログラムが影響を及ぼしている可能性があります。原因となっているプログラムの実行を Internet Explorer 上で無効にしているだけで、削除はされていない状態です。原因となっているプログラムの削除をおこなう場合は、STEP 2: スパイウェアまたは不要なサードパーティのソフトウェアの削除 を参照してください。

方法 2 : Windows を [セーフ モードとネットワーク] オプションで起動する

スパイウェアや不正なサードパーティ製のプログラムの中には、ユーザーが意図せずに Windows の起動時に自動的に実行されることがあります。Windows を [セーフ モードとネットワーク] オプションで起動した場合、Windows の起動とネットワーク接続に最低限必要なサービスおよびプログラムのみが実行されるため、現象が発生するかどうか確認し問題の原因をチェックすることができます。

注意 : インターネット接続形態によっては、ネットワーク接続に必要なサービスおよびプログラムも実行されない場合があるため、インターネット接続ができなくなることがあります。
  1. コンピュータを起動している場合は、[スタート] ボタンをクリックし、[終了オプション] または [シャットダウン] をクリックします。コンピュータを起動していない場合は電源を入れ、手順 3 に進みます。
  2. [再起動] をクリックします。
  3. コンピュータの起動処理中に、F8 キーを押し続けます。
  4. Windows 拡張オプション メニューが表示されます。

    セーフ モード
    セーフ モードとネットワーク
    セーフ モードとコマンド プロンプト
    ブートのログ作成を有効にする
    VGA モードを有効にする
    前回正常起動時の構成 (正しく動作した最新の設定)
    ディレクトリ サービス復元モード (Windows DC のみ)
    デバック モード
    Windows を通常起動する
    再起動する
    OS 選択メニューに戻る
  5. 方向キーで [セーフ モードとネットワーク] を選択し、Enter キーを押します。
上記の方法で問題が解決した場合
問題の原因が Windows 起動時に自動的に開始されるサービスまたはプログラムにある可能性が高いと判断できるため、STEP 2: スパイウェアまたは不要なサードパーティのソフトウェアの削除 をお奨めします。

方法 3 : システム設定ユーティリティで常駐アプリケーションなどを無効にして Windows を起動する

スパイウェアや不正なサードパーティ製のプログラムの中には、ユーザーが意図せずに Windows の起動時に自動的に実行されるものがあります。システム設定ユーティリティ (msconfig) で常駐アプリケーションおよび Microsoft 以外のサービスなどの Windows 起動時のサービスおよびスタートアップを管理することによって、現象が再現するかどうか確認し問題の原因をチェックすることができます。システム設定ユーティリティの設定を元に戻す場合は、「システム設定ユーティリティを元に戻す方法」 を参照してください。

注意 : インターネット接続形態によっては、ネットワーク接続に必要なサービスおよびプログラムも無効にしてしまう場合があるため、インターネット接続ができなくなることがあります。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、[名前] ボックスに msconfig と入力し、[OK] をクリックします。

    元に戻す画像を拡大する
  2. システム設定ユーティリティの [全般] タブにて、[スタートアップのオプションを選択] を選択し、[スタートアップの項目を読み込む] のチェックをオフにします。

    元に戻す画像を拡大する
  3. システム設定ユーティリティの [サービス] タブにて、[Microsoft のサービスをすべて隠す] のチェックをオンにして、[すべて無効にする] をクリックします。

    元に戻す画像を拡大する
  4. [OK] をクリックします。

    元に戻す画像を拡大する
  5. 次のメッセージが表示されたら、[再起動] をクリックします。

    元に戻す画像を拡大する
    システム構成の変更を有効にするには、再起動する必要があります。
  6. コンピュータの再起動後、次のダイアログが表示されたら、[OK] をクリックします。

    元に戻す画像を拡大する
    システム構成ユーティリティ
  7. [キャンセル] をクリックします。

    元に戻す画像を拡大する
  8. 現象が発生するかどうか確認します。
上記の方法で問題が解決した場合
問題の原因が Windows 起動時に自動的に開始されるサービスまたはプログラムにある可能性が高いと判断できるため、STEP 2: スパイウェアまたは不正なサードパーティのソフトウェアの削除 をお奨めします。


システム設定ユーティリティの設定を元に戻す方法


常駐アプリケーションおよび Microsoft 以外のサービスを無効する前の状態に戻すためには、以下の作業を行ってください。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. [名前] ボックスに msconfig と入力し、[OK] をクリックします。
  3. システム設定ユーティリティの [全般] タブにて、[通常スタートアップ] を選択し、[OK] をクリックします。
  4. 「システム構成の変更を有効にするには、再起動する必要があります。」メッセージが表示されたら、[再起動] をクリックします。

STEP 2: スパイウェアまたは不正なサードパーティのソフトウェアの削除

スパイウェアや不要なサードパーティのソフトウェアを見つけてコンピュータから削除するには、次のいずれかまたはすべての方法を使用します。

: Microsoft Windows には複数のバージョンが存在するため、使用中のコンピュータによっては以下の手順が異なる場合があります。この場合、製品のマニュアルを参照のうえ、手順を実行するようにしてください。

: Windows Millennium Edition (Me) および Windows XP など、システムの復元機能の含まれるオペレーティング システムを使用している場合は、以下の手順を実行する前に、有効な復元ポイントを設定しておきます。変更が不要になった場合には、この復元ポイントを使用して、コンピュータを変更前の構成に復元することができます。

: 不正なサードパーティ ソフトウェアは、標準のインストール手順に準じていない場合があります。そのため、ソフトウェアが以下の手順に記載されている場所で見つからない場合があります。

プログラムの追加と削除を使用する方法

  1. [スタート] ボタンをクリックし、[コントロール パネル] (または [設定] をポイントし、[コントロール パネル]) をクリックします。
  2. [プログラムの追加と削除] (または [アプリケーションの追加と削除]) をダブルクリックします。
  3. [現在インストールされているプログラム] ボックスの一覧で、インストールした覚えのないプログラム、または予期しない現象の原因となっているプログラムに類似した名前のプログラムを探します。

    : インストールした覚えのないプログラムのすべてが問題の原因になるわけではありません。コンピュータの出荷時にプレインストールされているプログラムや、コンピュータにインストールされている他のソフトウェアにとって重要なコンポーネントである可能性もあります。プログラムの削除は慎重に行ってください。
  4. 削除するプログラムをクリックし、[削除] (または [変更と削除]) をクリックします。画面の指示に従って、コンポーネントを削除します。コンピュータの再起動が必要な場合があります。

専用の削除プログラムを使用する方法


プログラムの追加と削除ツールの一覧に該当するプログラムが表示されない場合は、専用のプログラム (アンインストール プログラム) が用意されている場合があります。専用のプログラムを使用して削除するには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[すべてのプログラム] (または [プログラム]) をポイントし、問題のプログラムの名前の付いたフォルダ、または問題のプログラムが含まれている可能性があるプログラムの名前の付いたフォルダを探します。
  2. 該当するフォルダをポイントし、Unist.exe、Uninstall、または Uninstall Program_Name などの名前が付いているファイルを探します。そのようなファイルが専用の削除プログラムである可能性があります。専用の削除プログラムが見つかったら、ファイルをクリックします。
  3. 画面に表示される指示に従ってプログラムを削除します。

エクスプローラでプログラム フォルダを見つける方法


プログラムによっては、プログラムの追加と削除の一覧に登録されず、スタート メニューにフォルダが作成されない場合があります。ただし、プログラムがインストールされているフォルダをハード ディスク上で見つけることができる場合があります。そのフォルダに、問題のプログラムを削除するためのプログラムが含まれている場合があります。問題のプログラムのフォルダを見つけ、プログラムを削除するには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[マイ コンピュータ] を右クリックし (または [プログラム]、[アクセサリ] を順にポイントし)、[エクスプローラ] をクリックします。
  2. フォルダ ツリーを展開して、問題のプログラムの名前の付いたフォルダ、または問題のプログラムが含まれている可能性があるプログラムの名前の付いたフォルダを探します。
  3. 問題のプログラムのフォルダが見つかったら、そのフォルダをクリックします。
  4. 右側のウィンドウで、Unist.exe、Uninstall、または Uninstall Program_Name などの名前が付いているファイルを探します。そのようなファイルが専用の削除プログラムである可能性があります。専用の削除プログラムが見つかったら、ファイルをダブルクリックします。
  5. 画面に表示される指示に従ってプログラムを削除します。
: 問題のプログラムのフォルダが見つかっても、専用の削除プログラムのファイルが見つからない場合は、そのフォルダまたはフォルダの内容を削除しないでください。フォルダまたはフォルダの内容を削除すると、Windows またはプログラムが起動しない、プログラムが応答を停止するなど、コンピュータのパフォーマンスや動作に悪影響が及ぶことがあります。

ウイルス対策ソフトウェアを使用する方法


不正なサードパーティ ソフトウェアは、ウイルス対策ソフトウェアで削除できる場合があります。ただし、このソフトウェアはウイルスとは異なるため、ウイルス対策ソフトウェアによっては検出や削除ができない場合があります。サードパーティ ソフトウェアの削除については、ウイルス対策ソフトウェアの製造元に問い合わせてください。ウイルス対策ソフトウェアの使用方法についてはマイクロソフトではサポートしておりません。

ウイルス対策プログラムの製造元の問い合わせ先の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
49500? (http://support.microsoft.com/kb/49500/JA/ ) ウイルス対策ソフトウェア ベンダーの一覧

スパイウェア対策ソフトウェア


スパイウェアや不正なサードパーティ プログラムを削除するプログラムには、次のようなプログラムがあります。 この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

詳細

スパイウェアを防ぐには

今後スパイウェアの被害にあわないようにする為の対策方法について説明します。
  1. スパイウェア対策の為の基本的な心構えを守る
    • 大切なデータのバックアップをまめに取ります
      スパイウェアに感染するとシステムが正常に動作しなくなる可能性がある為、大切なデータは日ごろからバックアップをとっておくことをお奨めします。
    • 信頼できない怪しい Web サイトへはなるべくアクセスしないよう心掛けます。
      スパイウェアに感染すると個人情報やクレジットカードの情報など盗み取られる可能性がある為、仕事で使うコンピュータやクレジットカード情報などを入力するコンピュータでは特に注意する必要があります。
    • 信頼する Web サイトのみからソフトウェアをインストールするようにします。
      Web サイトからダウンロードする際に、その Web サイトと通信を行っても安心かどうかを確認してください。アクセスすべきではないと判断した場合、そのソフトウェアはダウンロードしないでください。不明な場合、友達に聞いたり、信頼できる他のリソースにて確認するなど、調査を行ってください。
    • 知らない人物からファイルなどを受け取らないようにします。
  2. Internet Explorer 6 (Web ブラウザ) のセキュリティ設定を調整する

    Web ブラウザのセキュリティ設定を調整し、Web サイトから受け入れる情報量を制限することができます。セキュリティ レベルを高くすればするほど、危険性が低減されます。その場合のマイナス面として、セキュリティ レベルを高く設定するほど Web サイトの使用が制限されることがあります。

    既定で、Internet Explorer 6 はバランスのとれた設定がされています。最初に Internet Explorer をインストールすると、すべての Web サイトは 1 つのゾーン (インターネット ゾーン) に分類され、セキュリティ レベルはすべて「中」に設定されます。このレベルのセキュリティ レベルを使用する際、Internet Explorer では、前もってその Web サイトまたは発行者を信頼する設定をしていない限り、ファイルをダウンロードするかどうかを確認するメッセージが表示されます。セキュリティ レベルを「低」に変更すると、Web サイトにより、ユーザーの許可なしにソフトウェアのダウンロードができるようになるため、この設定を使用する際は注意が必要です。何らかの理由によりセキュリティを「低」に変更する必要がある際には、できるだけ早く「中」またはそれ以上に戻すようにしてください。
  3. 不必要なソフトウェアを検出し削除するためのサードパーティ製のウイルス対策ソフトウェアやスパイウェア対策ソフトウェアを使用する

    数社からコンピュータの不必要なソフトウェアをチェックする対策ソフトウェアが提供されています。それらのソフトウェアを利用し、不要なソフトウェアがインストールされているかを確認し、削除する手助けとすることができます。
    インターネット プロバイダからスパイウェアの対策ソフトウェアが提供されていない場合、信頼する人にお勧めの対策ソフトウェアを尋ねてください。そのようなソフトウェアで不必要なソフトウェアを削除すると、一緒にダウンロードした無償プログラムが使用できなくなることにご注意ください。

    対策ソフトウェアは、常に最新の状態で実行してください。多くのメーカーから、ユーザーがオンライン状態になったときに自動的にコンピュータを更新するためのチェック オプションが提供されています。この機能が利用できない場合、メーカーの Web サイトを定期的にチェックし、ダウンロードを確認してください。いずれにしても、頻繁にコンピュータの更新を行ってください。
  4. Windows を最新の状態に保つ

    不正なソフトウェアから保護するための最後のステップは、Windows ソフトウェアを常に最新の状態に保っておくことです。これは、Windows Update にアクセスし、自動更新を有効に設定することにより行うことができます。詳細は、「Microsoft ソフトウェアを更新する (http://www.microsoft.com/japan/athome/security/update/msupdates.mspx) 」をご覧ください。
  5. 信頼できないサイトへアクセスする際の注意事項
    • 信頼できないWebページを参照している際は、ActiveX の警告で「はい」を押すことでスパイウェアに感染してしまう可能性があるため 不用意に ActiveX の警告で「はい」を押さないようにします。
    • 信頼できない場所からダウンロードしたソフトウェアの導入の際には、自動的にスパイウェアがインストールされる可能性ありますので、使用許諾契約書をしっかり確認します。

      プログラムをインストールする際は、「同意します」または「OK」をクリックする前に、すべてのウインドウ上のメッセージを読むようにしてください。また、そのソフトウェアに関連する使用許諾契約書またはプライバシー声明を注意深く読む必要があります。好ましくないと思われる動作が行われる場合があります。そのウインドウ上で「いいえ」または「同意しません」をクリックできない場合、角の "X" をクリックし、ウインドウを終了してください。ウインドウを終了するために「はい」または「同意します」をクリックすることは決してしないでください。
    • トップページが書き換えられる、広告のポップアップ、パフォーマンスの低下などいつもと異なる動作が発生した場合はそのまま放置せず、サードパーティ製のウイルス対策ソフトウェアやスパイウェア対策ソフトをつかってスキャンすることをお勧めします。

関連情報

スパイウェアへの対策について参照するには、次のマイクロソフト Web サイトにアクセスしてください。
スパイウェア対策
http://www.microsoft.com/japan/athome/security/spyware/default.mspx (http://www.microsoft.com/japan/athome/security/spyware/default.mspx)
スパイウェアを知る
http://www.microsoft.com/japan/athome/security/spyware/devioussoftware.mspx (http://www.microsoft.com/japan/athome/security/spyware/devioussoftware.mspx)
マイクロソフトのプライバシー ポリシーについては、次のマイクロソフト Web サイトを参照してください。
http://privacy.microsoft.com/ja-jp/default.aspx (http://privacy.microsoft.com/ja-jp/default.aspx)
Microsoft Media Player のプライバシー ポリシーについては、次のマイクロソフト Web サイトを参照してください。
http://www.microsoft.com/japan/windows/windowsmedia/security/9splayer.aspx (http://www.microsoft.com/japan/windows/windowsmedia/security/9splayer.aspx)
関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
827315? (http://support.microsoft.com/kb/827315/JA/ ) スパイウェアまたはアドウェアなどが原因で予期しない動作が発生する
881873? (http://support.microsoft.com/kb/881873/JA/ ) 意図しない Web ページが表示されてしまう場合の対処方法
881902? (http://support.microsoft.com/kb/881902/JA/ ) スパイウェアやアドウェアによって Internet Explorer が起動しない場合の対処方法
882568? (http://support.microsoft.com/kb/882568/JA/ ) マイ コンピュータが開かない場合の対処方法
881903? (http://support.microsoft.com/kb/881903/JA/ ) winshow.dll のエラーで Internet Explorer が起動できない場合の対処方法
882341? (http://support.microsoft.com/kb/882341/JA/ ) "ページを表示できません" と表示されて Web ページが表示されない場合の対処方法

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
キーワード:?
kbexpertiseinter kbexpertisebeginner kbexpertiseadvanced kbtshoot KB890538
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"