Possono verificarsi dei ritardi di compreso tra 10 e 60 secondi quando si utilizzeranno i percorsi UNC per accedere ai file memorizzati su un server SMB su un computer basato su Windows Server 2003 multihomed

Traduzione articoli Traduzione articoli
Identificativo articolo: 890553 - Visualizza i prodotti a cui si riferisce l?articolo.
importante in questo articolo sono contenute informazioni su come modificare il Registro di sistema (chiamato Registro di configurazione in Windows NT). Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986Descrizione del Registro di sistema di Microsoft Windows
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

In un computer multihomed che esegue Microsoft Windows Server 2003, potrebbero verificarsi ritardi di tra 10 e 60 secondi quando si utilizzeranno i percorsi UNC (Universal Naming CONVENTION) per accedere ai file memorizzati su un server di block (SMB) del messaggio di server remoto. Questo problema si verifica pi¨ frequentemente quando il computer tenta di accedere ai file con maggiore frequenza. Ad esempio, il problema pu˛ verificarsi quando un'applicazione tenta di accedere ai file a due intervalli di secondo. Il problema non si verifica quando si accede i file tramite un'unitÓ di rete connessa. Il problema anche non si verifica quando NetBIOS su TCP/IP (NetBT) Ŕ disabilitato sull'interfaccia di almeno una rete.

Cause

Questo problema si verifica a causa di un problema di temporizzazione tra il redirector SMB e il driver di NetBT.

Risoluzione

avviso Se si utilizza Editor del Registro di sistema in modo non corretto, si potrebbero provocare problemi gravi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce la che Ŕ possibile risolvere i problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. Utilizzare Editor del Registro di sistema a proprio rischio.Per risolvere il problema, installare l'hotfix riportato di seguito. Quindi modificare il Registro di sistema per aggiungere la voce del Registro di sistema ScavengerTimeLimit.

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Prerequisiti

Non Ŕ richiesto alcun prerequisito.

NecessitÓ di riavvio

╚ necessario riavviare il computer dopo aver applicato questo hotfix.

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Date e ore per questi file sono indicati nella coordinated universal time (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
Windows Server 2003, versioni a 32 bit
   Date         Time   Version            Size  File name
   -------------------------------------------------------
   01-Dec-2004  14:33  5.2.3790.238    395,776  Mrxsmb.sys
   01-Dec-2004  14:33  5.2.3790.238    158,720  Rdbss.sys
Windows Server 2003, Enterprise Edition per sistemi basati su Itanium
   Date         Time   Version            Size  File name
   -------------------------------------------------------
   30-Nov-2004  22:37  5.2.3790.238  1,124,864  Mrxsmb.sys
   30-Nov-2004  22:37  5.2.3790.238    465,408  Rdbss.sys
Per aggiungere la voce del Registro di sistema di ScavengerTimeLimit, attenersi alla seguente procedura:
  1. Fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
  2. Individuare la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters
  3. Fare clic con il pulsante destro del mouse su
    parameters
    , scegliere Nuovo , quindi Valore DWORD .
  4. Digitare ScavengerTimeLimit e quindi premere INVIO per denominare la nuova voce del Registro di sistema.
  5. Fare doppio clic su ScavengerTimeLimit .
  6. Nella casella dati valore digitare 30 e quindi fare clic su OK .

    Nota ╚ possibile immettere qualsiasi valore compreso tra 10 e 120 per controllare la frequenza con cui il thread Scavenger pulisce alle connessioni precedente. Se il problema persiste dopo aver impostato il valore su 30, aumentare il valore.

    importante Aumentare il valore utilizza pi¨ risorse sul sia il computer locale e al server remoto. Se si imposta la voce del Registro di sistema ScavengerTimeLimit a pi¨ di 30, si consiglia di monitorare l'utilizzo di pool di paging e l'utilizzo del pool non di paging in entrambi i computer.
  7. Chiudere l'editor del Registro di sistema.

Workaround

Per aggirare questo problema, attenersi alla seguente procedura:
  1. Mappare un'unitÓ di rete al server SMB. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Avviare Esplora risorse.
    2. Scegliere dal menu Strumenti , Connetti unitÓ di rete .
    3. Nell'elenco unitÓ , fare clic su una lettera di unitÓ.
    4. Nell'elenco cartelle , digitare il percorso UNC della risorsa condivisa sul server dei comandi.

      Utilizzare il seguente formato:
      \\ ServerName \ SharedItem
      In alternativa, fare clic su Sfoglia e individuare la risorsa condivisa.
    5. Fare clic su Fine .
  2. Disabilitare NetBT su un'interfaccia di rete. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic su Start , scegliere Esegui , digitare ncpa.cpl e quindi fare clic su OK .
    2. Fare clic con il pulsante destro del mouse sulla rete che si desidera configurare e quindi fare clic su ProprietÓ .
    3. Se la connessione Ŕ una connessione LAN, fare clic sulla scheda Generale , fare clic su Internet Protocol [TCP/IP] nella finestra che la connessione utilizza gli elementi seguenti e quindi scegliere ProprietÓ .

      Se la connessione non Ŕ una connessione LAN, fare clic sulla scheda rete .
    4. Fare clic su Avanzate e scegliere la scheda WINS .
    5. Nell'area impostazione NetBIOS , fare clic su Disabilita NetBIOS su TCP/IP .
    6. Fare clic su OK tre volte.

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sulla terminologia utilizzata nel presente articolo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

ProprietÓ

Identificativo articolo: 890553 - Ultima modifica: martedý 24 luglio 2007 - Revisione: 1.11
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
Chiavi:á
kbmt kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbwinserv2003presp1fix KB890553 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 890553
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com