A utilização da CPU atinge 100 por cento ao executar programas após a instalação do Windows XP Service Pack 2 (SP2)

ID do artigo: 890582 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Nesta página

Sintomas

Ao executar programas, a utilização da CPU atinge 100 por cento. Quando a utilização da CPU atinge 100 por cento, os programas executam lentamente ou param de responder (travam).

Observação Para exibir a utilização da CPU, pressione CTRL+ALT+DEL, clique em Gerenciador de tarefas e na guia Desempenho.

Em computadores multiprocessadores, é possível enfrentar alternâncias de contexto ou chamadas de sistema por segundo.

Esses sintomas ocorrem após a instalação do Microsoft Windows XP Service Pack 2 (SP2).

Causa

Esse problema ocorre porque o código da interface do usuário está incluído no Windows XP SP2. A alta utilização da CPU é causada pela sobrecarga que ocorre quando a função IsWindow é chamada pelo código da interface do usuário.

Resolução

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Testes adicionais podem ser realizados nesse hotfix. Portanto, se esse problema não o prejudicar seriamente, é recomendável que você aguarde o próximo service pack que contenha esse hotfix.

Para resolver esse problema, envie uma solicitação para o Atendimento ao Cliente Online Microsoft para obter o hotfix. Para enviar a solicitação online para obter o hotfix, visite o seguinte site da Microsoft:
http://go.microsoft.com/?linkid=6294451
Observação Se outros problemas ocorrerem ou se uma solução de problemas for requisitada, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem a esse hotfix. Para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support

Pré-requisitos

Para aplicar esse hotfix, é necessário ter o Windows XP SP2 instalado no computador.

Necessidade de reinicialização

É necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui nenhum outro.

Informações sobre o arquivo

A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários destes arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário no item Data e hora do Painel de Controle.
   Data         Hora   Versão            Tamanho    Nome do arquivo
   --------------------------------------------------------------
   30-mar-2005  19:53  5.1.2600.2643     577.024  User32.dll       
   30-mar-2005  01:30  5.1.2600.2643   1.836.544  Win32k.sys
   

Situação

A Microsoft confirmou que esse é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre a terminologia padrão usada para descrever atualizações de software da Microsoft, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
824684 Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft

Propriedades

ID do artigo: 890582 - Última revisão: quinta-feira, 11 de outubro de 2007 - Revisão: 4.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palavras-chave: 
kbtshoot kbbug kbfix kbqfe kbpubtypekc kbwinxpsp3fix kbhotfixserver KB890582

Submeter comentários