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FIX: You cannot change the ownership of files that are owned by other users when you log on as the root user in Windows Services for UNIX 3.5

Article ID:890745
Last Review:November 15, 2007
Revision:2.2
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SYMPTOMS

After you configure Server for NFS in Microsoft Windows Services for UNIX 3.5, you may intermittently experience all the following symptoms:
When you log on as the root user, you cannot change the ownership of files that are owned by other users. For example, if you run the chown command to change the ownership of a file, the file ownership does not change to the new user who you specify. Additionally, you do not receive an error message to indicate that the file ownership does not successfully change.
After you run the chown command, the file ownership that you tried to change is changed to "nobody."

Note To view the file ownership, run the ls -l command.
The following event is logged in the application log of the server that is running the User Name Mapping service:

Event Source: NfsSvr
Event ID: 1021
Type: Warning
Description: There was mapping failure.

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CAUSE

This problem may occur if all the following conditions are true:
You are running Microsoft Windows Server 2003 on all the domain controllers in your domain.
Your domain is running in the Windows Server 2003 domain functional level.
Server for NFS Authentication is not installed on the domain controllers.
When these conditions are all true, the Network File System (NFS) service may sometimes prevent the root user from changing the ownership of files that are owned by other users. Instead, the file ownership is changed to "nobody" for UNIX users, and the file ownership is changed to "anonymous" for Windows users.

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RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to apply this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces 885850.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   ---------------------------------------------------
   10-Dec-2004  19:41  8.0.2254.7  423,424  Nfssvr.sys

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WORKAROUND

To work around this problem, install Server for NFS Authentication on all the domain controllers in your domain.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Microsoft Windows Services for UNIX 3.5

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Keywords: 
kbautohotfix kbqfe kbhotfixserver kbbug kbfix KB890745

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